diff mbox

pkg-cmake: reduce output when being silent

Message ID 1423677141-10912-1-git-send-email-fabio.porcedda@gmail.com
State Accepted
Headers show

Commit Message

Fabio Porcedda Feb. 11, 2015, 5:52 p.m. UTC
Use CMAKE_RULE_MESSAGES and CMAKE_INSTALL_MESSAGE variables to reduce
cmake output when it is a silent build.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
---
 package/pkg-cmake.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni Feb. 11, 2015, 8:14 p.m. UTC | #1
Dear Fabio Porcedda,

On Wed, 11 Feb 2015 18:52:21 +0100, Fabio Porcedda wrote:

> +ifdef QUIET
> +CMAKE_QUIET = -DCMAKE_RULE_MESSAGES=OFF -DCMAKE_INSTALL_MESSAGE=NEVER
> +else
> +CMAKE_QUIET =
> +endif

Use:

ifneq ($(QUIET),)
CMAKE_QUIET = -DCMAKE_RULE_MESSAGES=OFF -DCMAKE_INSTALL_MESSAGE=NEVER
endif

We generally don't use ifdef to test the value of a variable in
Buildroot.

The else part is unnecessary.

Thanks,

Thomas
Fabio Porcedda Feb. 12, 2015, 9:20 p.m. UTC | #2
I've forgotten to do a replay all...

On Thu, Feb 12, 2015 at 6:24 AM, Fabio Porcedda
<fabio.porcedda@gmail.com> wrote:
> On Wed, Feb 11, 2015 at 9:14 PM, Thomas Petazzoni
> <thomas.petazzoni@free-electrons.com> wrote:
>> Dear Fabio Porcedda,
>>
>> On Wed, 11 Feb 2015 18:52:21 +0100, Fabio Porcedda wrote:
>>
>>> +ifdef QUIET
>>> +CMAKE_QUIET = -DCMAKE_RULE_MESSAGES=OFF -DCMAKE_INSTALL_MESSAGE=NEVER
>>> +else
>>> +CMAKE_QUIET =
>>> +endif
>>
>> Use:
>>
>> ifneq ($(QUIET),)
>> CMAKE_QUIET = -DCMAKE_RULE_MESSAGES=OFF -DCMAKE_INSTALL_MESSAGE=NEVER
>> endif
>>
>> We generally don't use ifdef to test the value of a variable in
>> Buildroot.
>
> Ok will change it, nevertheless I like more the "ifdef" but maybe it's
> just may personal preference.
>
>> The else part is unnecessary.
>
> I added that to be able to use "make --warn-undefined-variables", i
> was thinking that is a useful tool for debugging makefile code.
>
> BR
> --
> Fabio Porcedda
Thomas Petazzoni Feb. 14, 2015, 8:01 a.m. UTC | #3
Dear Fabio Porcedda,

On Wed, 11 Feb 2015 18:52:21 +0100, Fabio Porcedda wrote:
> Use CMAKE_RULE_MESSAGES and CMAKE_INSTALL_MESSAGE variables to reduce
> cmake output when it is a silent build.
> 
> Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
> ---
>  package/pkg-cmake.mk | 7 +++++++
>  1 file changed, 7 insertions(+)

Applied to next, after making the following changes:

    [Thomas:
     - use ifneq instead of ifdef
     - remove unneeded else clause
     - also add to the host variant of the configure commands]

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/pkg-cmake.mk b/package/pkg-cmake.mk
index 6c9955d..de11134 100644
--- a/package/pkg-cmake.mk
+++ b/package/pkg-cmake.mk
@@ -31,6 +31,12 @@  CMAKE_HOST_C_COMPILER = $(HOSTCC)
 CMAKE_HOST_CXX_COMPILER = $(HOSTCXX)
 endif
 
+ifdef QUIET
+CMAKE_QUIET = -DCMAKE_RULE_MESSAGES=OFF -DCMAKE_INSTALL_MESSAGE=NEVER
+else
+CMAKE_QUIET =
+endif
+
 ################################################################################
 # inner-cmake-package -- defines how the configuration, compilation and
 # installation of a CMake package should be done, implements a few hooks to
@@ -86,6 +92,7 @@  define $(2)_CONFIGURE_CMDS
 		-DBUILD_TESTING=OFF \
 		-DBUILD_SHARED_LIBS=$$(if $$(BR2_STATIC_LIBS),OFF,ON) \
 		-DUSE_CCACHE=$$(if $$(BR2_CCACHE),ON,OFF) \
+		$$(CMAKE_QUIET) \
 		$$($$(PKG)_CONF_OPTS) \
 	)
 endef