diff mbox

strongswan: bump to version 5.2.1

Message ID 1418691367-12528-1-git-send-email-gustavo@zacarias.com.ar
State Superseded
Headers show

Commit Message

Gustavo Zacarias Dec. 16, 2014, 12:56 a.m. UTC
Also add hash file.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/strongswan/Config.in       | 17 +++++++++++++----
 package/strongswan/strongswan.hash |  2 ++
 package/strongswan/strongswan.mk   |  9 ++++++---
 3 files changed, 21 insertions(+), 7 deletions(-)
 create mode 100644 package/strongswan/strongswan.hash

Comments

Thomas Petazzoni Dec. 20, 2014, 8:48 p.m. UTC | #1
Dear Gustavo Zacarias,

On Mon, 15 Dec 2014 21:56:07 -0300, Gustavo Zacarias wrote:

> -config BR2_PACKAGE_STRONGSWAN_TOOLS
> -	bool "Enable additional utilities (openac, scepclient and pki)"

You're removing this option. Shouldn't it be added to Config.in.legacy,
for proper legacy handling?

Thanks,

Thomas
Gustavo Zacarias Dec. 22, 2014, 11:35 a.m. UTC | #2
On 12/20/2014 05:48 PM, Thomas Petazzoni wrote:
>> -config BR2_PACKAGE_STRONGSWAN_TOOLS
>> -	bool "Enable additional utilities (openac, scepclient and pki)"
> 
> You're removing this option. Shouldn't it be added to Config.in.legacy,
> for proper legacy handling?

Hi.
Possibly, however it won't do any good since some tools (openac) are
just gone upstream and i've defaulted to 'y' for the new split tool options.
Frankly speaking i'd rather see the number of options reduced for this
package, only a few of them introduce dependencies:
Curl fetcher (libcurl)
TNCCS 1.1 (libxml2)
EAP-SIM (pcsc-lite)

And that's it, the other options won't make strongswan that big.
Regards.
Thomas Petazzoni Dec. 22, 2014, 1:04 p.m. UTC | #3
Dear Gustavo Zacarias,

On Mon, 22 Dec 2014 08:35:01 -0300, Gustavo Zacarias wrote:

> Possibly, however it won't do any good since some tools (openac) are
> just gone upstream and i've defaulted to 'y' for the new split tool options.

Ok. But still, even if some tools are gone upstream, we should have
some Config.in.legacy handling, no?

> Frankly speaking i'd rather see the number of options reduced for this
> package, only a few of them introduce dependencies:
> Curl fetcher (libcurl)
> TNCCS 1.1 (libxml2)
> EAP-SIM (pcsc-lite)
> 
> And that's it, the other options won't make strongswan that big.

No problem on my side, feel free to submit some patches :-)

Thomas
diff mbox

Patch

diff --git a/package/strongswan/Config.in b/package/strongswan/Config.in
index 3b0f47f..c1b7f41 100644
--- a/package/strongswan/Config.in
+++ b/package/strongswan/Config.in
@@ -110,13 +110,22 @@  config BR2_PACKAGE_STRONGSWAN_SQL
 
 endif
 
-config BR2_PACKAGE_STRONGSWAN_TOOLS
-	bool "Enable additional utilities (openac, scepclient and pki)"
+config BR2_PACKAGE_STRONGSWAN_PKI
+	bool "Enable pki certificate utility"
+	default y
+
+config BR2_PACKAGE_STRONGSWAN_SCEP
+	bool "Enable SCEP client tool"
 	default y
 
 config BR2_PACKAGE_STRONGSWAN_SCRIPTS
-	bool "Enable additional utilities (found in directory scripts)"
-	depends on BR2_PACKAGE_STRONGSWAN_CHARON || BR2_PACKAGE_STRONGSWAN_TOOLS
+	bool "Enable additional utilities (found in scripts directory)"
+	depends on BR2_PACKAGE_STRONGSWAN_CHARON
+	default y
+
+config BR2_PACKAGE_STRONGSWAN_VICI
+	bool "Enable vici/swanctl"
+	depends on BR2_PACKAGE_STRONGSWAN_CHARON
 	default y
 
 endif
diff --git a/package/strongswan/strongswan.hash b/package/strongswan/strongswan.hash
new file mode 100644
index 0000000..f434530
--- /dev/null
+++ b/package/strongswan/strongswan.hash
@@ -0,0 +1,2 @@ 
+# From http://download.strongswan.org/strongswan-5.2.1.tar.bz2.md5
+md5	dd3717c0aa59ab4591ca1812941ebb82	strongswan-5.2.1.tar.bz2
diff --git a/package/strongswan/strongswan.mk b/package/strongswan/strongswan.mk
index bb1d268..f1fe3cc 100644
--- a/package/strongswan/strongswan.mk
+++ b/package/strongswan/strongswan.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-STRONGSWAN_VERSION = 5.1.3
+STRONGSWAN_VERSION = 5.2.1
 STRONGSWAN_SOURCE = strongswan-$(STRONGSWAN_VERSION).tar.bz2
 STRONGSWAN_SITE = http://download.strongswan.org
 STRONGSWAN_LICENSE = GPLv2+
@@ -28,8 +28,11 @@  STRONGSWAN_CONF_OPTS +=
 	--enable-unity=$(if $(BR2_PACKAGE_STRONGSWAN_UNITY),yes,no)                  \
 	--enable-stroke=$(if $(BR2_PACKAGE_STRONGSWAN_STROKE),yes,no)                \
 	--enable-sql=$(if $(BR2_PACKAGE_STRONGSWAN_SQL),yes,no)                      \
-	--enable-tools=$(if $(BR2_PACKAGE_STRONGSWAN_TOOLS),yes,no)                  \
-	--enable-scripts=$(if $(BR2_PACKAGE_STRONGSWAN_SCRIPTS),yes,no)
+	--enable-pki=$(if $(BR2_PACKAGE_STRONGSWAN_PKI),yes,no)                      \
+	--enable-scepclient=$(if $(BR2_PACKAGE_STRONGSWAN_SCEP),yes,no)              \
+	--enable-scripts=$(if $(BR2_PACKAGE_STRONGSWAN_SCRIPTS),yes,no)              \
+	--enable-vici=$(if $(BR2_PACKAGE_STRONGSWAN_VICI),yes,no)                    \
+	--enable-swanctl=$(if $(BR2_PACKAGE_STRONGSWAN_VICI),yes,no)
 
 ifeq ($(BR2_PACKAGE_STRONGSWAN_EAP),y)
 STRONGSWAN_CONF_OPTS +=               \