diff mbox

[v4,3/9] toolchain/helpers.mk: use --chmod on rsync

Message ID 1416586748-12936-4-git-send-email-guido@vanguardiasur.com.ar
State Accepted
Headers show

Commit Message

Guido Martínez Nov. 21, 2014, 4:19 p.m. UTC
This makes sure we don't have any weird permissions on the staging dir,
which could affect the target.

Signed-off-by: Guido Martínez <guido@vanguardiasur.com.ar>
---
 toolchain/helpers.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Arnout Vandecappelle July 13, 2015, 3:07 p.m. UTC | #1
On 11/21/14 17:19, Guido Martínez wrote:
> This makes sure we don't have any weird permissions on the staging dir,
> which could affect the target.
> 
> Signed-off-by: Guido Martínez <guido@vanguardiasur.com.ar>

Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

 Regards,
 Arnout

> ---
>  toolchain/helpers.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
> index 3121da4..46f5f22 100644
> --- a/toolchain/helpers.mk
> +++ b/toolchain/helpers.mk
> @@ -139,7 +139,7 @@ copy_toolchain_sysroot = \
>  	SUPPORT_LIB_DIR="$(strip $5)" ; \
>  	for i in etc $${ARCH_LIB_DIR} sbin usr usr/$${ARCH_LIB_DIR}; do \
>  		if [ -d $${ARCH_SYSROOT_DIR}/$$i ] ; then \
> -			rsync -au --chmod=Du+w --exclude 'usr/lib/locale' \
> +			rsync -au --chmod=u=rwX,go=rX --exclude 'usr/lib/locale' \
>  				--exclude lib --exclude lib32 --exclude lib64 \
>  				$${ARCH_SYSROOT_DIR}/$$i/ $(STAGING_DIR)/$$i/ ; \
>  		fi ; \
>
Thomas Petazzoni July 13, 2015, 3:13 p.m. UTC | #2
Dear Guido Martínez,

On Fri, 21 Nov 2014 13:19:02 -0300, Guido Martínez wrote:
> This makes sure we don't have any weird permissions on the staging dir,
> which could affect the target.
> 
> Signed-off-by: Guido Martínez <guido@vanguardiasur.com.ar>
> ---
>  toolchain/helpers.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied, thanks.

Thomas
diff mbox

Patch

diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 3121da4..46f5f22 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -139,7 +139,7 @@  copy_toolchain_sysroot = \
 	SUPPORT_LIB_DIR="$(strip $5)" ; \
 	for i in etc $${ARCH_LIB_DIR} sbin usr usr/$${ARCH_LIB_DIR}; do \
 		if [ -d $${ARCH_SYSROOT_DIR}/$$i ] ; then \
-			rsync -au --chmod=Du+w --exclude 'usr/lib/locale' \
+			rsync -au --chmod=u=rwX,go=rX --exclude 'usr/lib/locale' \
 				--exclude lib --exclude lib32 --exclude lib64 \
 				$${ARCH_SYSROOT_DIR}/$$i/ $(STAGING_DIR)/$$i/ ; \
 		fi ; \