diff mbox

[v2,3/3] mysql: use /etc/ld.so.conf.d instead of /etc/ld.so.conf

Message ID 1414768749-15134-3-git-send-email-jezz@sysmic.org
State Changes Requested
Headers show

Commit Message

Jérôme Pouiller Oct. 31, 2014, 3:19 p.m. UTC
Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
---
 package/mysql/ld.so.conf.d-mysql.conf | 1 +
 package/mysql/mysql.mk                | 5 ++++-
 2 files changed, 5 insertions(+), 1 deletion(-)
 create mode 100644 package/mysql/ld.so.conf.d-mysql.conf

Comments

Thomas Petazzoni Oct. 31, 2014, 3:39 p.m. UTC | #1
Dear Jérôme Pouiller,

On Fri, 31 Oct 2014 16:19:09 +0100, Jérôme Pouiller wrote:

>  define MYSQL_ADD_MYSQL_LIB_PATH
> -	echo "/usr/lib/mysql" >> $(TARGET_DIR)/etc/ld.so.conf
> +	$(INSTALL) -d $(TARGET_DIR)/etc/ld.so.conf.d
> +	$(INSTALL) -m 644 \
> +		package/mysql g/ld.so.conf.d-mysql.conf \
> +		$(TARGET_DIR)/etc/ld.so.conf.d
>  endef

Does this works with uClibc?

The gst-fsl-plugins package is limited to glibc, so we don't care. But
mysql is supported with uClibc, and I'm not sure uClibc
supports /etc/ld.so.conf.d/.

Best regards,

Thomas
diff mbox

Patch

diff --git a/package/mysql/ld.so.conf.d-mysql.conf b/package/mysql/ld.so.conf.d-mysql.conf
new file mode 100644
index 0000000..33d9ace
--- /dev/null
+++ b/package/mysql/ld.so.conf.d-mysql.conf
@@ -0,0 +1 @@ 
+/usr/lib/mysql
diff --git a/package/mysql/mysql.mk b/package/mysql/mysql.mk
index 945ca18..1a35378 100644
--- a/package/mysql/mysql.mk
+++ b/package/mysql/mysql.mk
@@ -114,7 +114,10 @@  define MYSQL_REMOVE_TEST_PROGS
 endef
 
 define MYSQL_ADD_MYSQL_LIB_PATH
-	echo "/usr/lib/mysql" >> $(TARGET_DIR)/etc/ld.so.conf
+	$(INSTALL) -d $(TARGET_DIR)/etc/ld.so.conf.d
+	$(INSTALL) -m 644 \
+		package/mysql g/ld.so.conf.d-mysql.conf \
+		$(TARGET_DIR)/etc/ld.so.conf.d
 endef
 
 MYSQL_POST_INSTALL_TARGET_HOOKS += MYSQL_REMOVE_TEST_PROGS