diff mbox

[v2,2/3] gst-fsl-plugins: fix plugins loading

Message ID 1414768749-15134-2-git-send-email-jezz@sysmic.org
State Changes Requested
Headers show

Commit Message

Jérôme Pouiller Oct. 31, 2014, 3:19 p.m. UTC
Problem was reported :
  http://lists.busybox.net/pipermail/buildroot/2014-July/101566.html
  http://lists.busybox.net/pipermail/buildroot/2014-October/107613.html

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
---
 package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk             | 9 +++++++++
 .../gstreamer/gst-fsl-plugins/ld.so.conf.d-gst-fsl-plugins.conf  | 5 +++++
 2 files changed, 14 insertions(+)
 create mode 100644 package/gstreamer/gst-fsl-plugins/ld.so.conf.d-gst-fsl-plugins.conf

Comments

Thomas Petazzoni Oct. 31, 2014, 3:37 p.m. UTC | #1
Dear Jérôme Pouiller,

On Fri, 31 Oct 2014 16:19:08 +0100, Jérôme Pouiller wrote:

> +define GST_FSL_PLUGINS_FIX_LD_PATH
> +	$(INSTALL) -d $(TARGET_DIR)/etc/ld.so.conf.d
> +	$(INSTALL) -m 644 \
> +		package/gstreamer/gst-fsl-plugins/ld.so.conf.d-gst-fsl-plugins.conf \
> +		$(TARGET_DIR)/etc/ld.so.conf.d

In a review of an earlier patch, Yann already suggested to do this in
one command using $(INSTALL) -D -m 644.

Thanks,

Thomas
diff mbox

Patch

diff --git a/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk b/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk
index 8d8b8b4..21046fc 100644
--- a/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk
+++ b/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk
@@ -40,4 +40,13 @@  endef
 
 GST_FSL_PLUGINS_POST_PATCH_HOOKS += GST_FSL_PLUGINS_PATCH_M4
 
+define GST_FSL_PLUGINS_FIX_LD_PATH
+	$(INSTALL) -d $(TARGET_DIR)/etc/ld.so.conf.d
+	$(INSTALL) -m 644 \
+		package/gstreamer/gst-fsl-plugins/ld.so.conf.d-gst-fsl-plugins.conf \
+		$(TARGET_DIR)/etc/ld.so.conf.d
+endef
+
+GST_FSL_PLUGINS_POST_INSTALL_TARGET_HOOKS += GST_FSL_PLUGINS_FIX_LD_PATH
+
 $(eval $(autotools-package))
diff --git a/package/gstreamer/gst-fsl-plugins/ld.so.conf.d-gst-fsl-plugins.conf b/package/gstreamer/gst-fsl-plugins/ld.so.conf.d-gst-fsl-plugins.conf
new file mode 100644
index 0000000..325fbf1
--- /dev/null
+++ b/package/gstreamer/gst-fsl-plugins/ld.so.conf.d-gst-fsl-plugins.conf
@@ -0,0 +1,5 @@ 
+# cf. https://community.freescale.com/thread/300387
+/usr/lib/imx-mm/audio-codec
+/usr/lib/imx-mm/video-codec
+/usr/lib/imx-mm/parser
+