diff mbox

[v2,4/8] package/mpd: enable support for libsoxr

Message ID 1413379134-28918-4-git-send-email-jkrause@posteo.de
State Superseded
Headers show

Commit Message

Jörg Krause Oct. 15, 2014, 1:18 p.m. UTC
Signed-off-by: Jörg Krause <jkrause@posteo.de>
---
Changes v1 -> v2:
  - none
---
 package/mpd/Config.in | 7 +++++++
 package/mpd/mpd.mk    | 7 +++++++
 2 files changed, 14 insertions(+)

Comments

Thomas Petazzoni Oct. 16, 2014, 9:33 a.m. UTC | #1
Dear Jörg Krause,

On Wed, 15 Oct 2014 15:18:50 +0200, Jörg Krause wrote:
> Signed-off-by: Jörg Krause <jkrause@posteo.de>
> ---
> Changes v1 -> v2:
>   - none
> ---
>  package/mpd/Config.in | 7 +++++++
>  package/mpd/mpd.mk    | 7 +++++++
>  2 files changed, 14 insertions(+)
> 
> diff --git a/package/mpd/Config.in b/package/mpd/Config.in
> index 10f3cf0..eba280a 100644
> --- a/package/mpd/Config.in
> +++ b/package/mpd/Config.in
> @@ -46,6 +46,13 @@ config BR2_PACKAGE_MPD_LIBSAMPLERATE
>  		Enable libsamplerate input support.
>  		Select this for software sample rate conversion.
>  
> +config BR2_PACKAGE_MPD_LIBSOXR
> +	bool "libsoxr"
> +	select BR2_PACKAGE_LIBSOXR
> +	help
> +		Enable libsoxr resampler support.
> +		The SoX Resampler library performs software sample-rate conversion.
> +

I apologize for the silly comment, but the indentation is wrong here.
The help text should be indented with one tab plus two spaces, not two
tabs.

Same issue applies to patches 4, 5, 6 and 7 of your series.

Thanks,

Thomas
Jörg Krause Oct. 16, 2014, 10:29 a.m. UTC | #2
Dear Thomas Petazzoni,

On 10/16/2014 11:33 AM, Thomas Petazzoni wrote:
> Dear Jörg Krause,
>
> On Wed, 15 Oct 2014 15:18:50 +0200, Jörg Krause wrote:
>> Signed-off-by: Jörg Krause <jkrause@posteo.de>
>> ---
>> Changes v1 -> v2:
>>    - none
>> ---
>>   package/mpd/Config.in | 7 +++++++
>>   package/mpd/mpd.mk    | 7 +++++++
>>   2 files changed, 14 insertions(+)
>>
>> diff --git a/package/mpd/Config.in b/package/mpd/Config.in
>> index 10f3cf0..eba280a 100644
>> --- a/package/mpd/Config.in
>> +++ b/package/mpd/Config.in
>> @@ -46,6 +46,13 @@ config BR2_PACKAGE_MPD_LIBSAMPLERATE
>>   		Enable libsamplerate input support.
>>   		Select this for software sample rate conversion.
>>   
>> +config BR2_PACKAGE_MPD_LIBSOXR
>> +	bool "libsoxr"
>> +	select BR2_PACKAGE_LIBSOXR
>> +	help
>> +		Enable libsoxr resampler support.
>> +		The SoX Resampler library performs software sample-rate conversion.
>> +
> I apologize for the silly comment, but the indentation is wrong here.
> The help text should be indented with one tab plus two spaces, not two
> tabs.
>
> Same issue applies to patches 4, 5, 6 and 7 of your series.

Don't apologize, every comment is very welcome!

Yes, the intendation is wrong for almost all existing help texts in mpd. 
I will fix the submitted patches and add an additional one to fix the 
intendation of the existing help texts.
diff mbox

Patch

diff --git a/package/mpd/Config.in b/package/mpd/Config.in
index 10f3cf0..eba280a 100644
--- a/package/mpd/Config.in
+++ b/package/mpd/Config.in
@@ -46,6 +46,13 @@  config BR2_PACKAGE_MPD_LIBSAMPLERATE
 		Enable libsamplerate input support.
 		Select this for software sample rate conversion.
 
+config BR2_PACKAGE_MPD_LIBSOXR
+	bool "libsoxr"
+	select BR2_PACKAGE_LIBSOXR
+	help
+		Enable libsoxr resampler support.
+		The SoX Resampler library performs software sample-rate conversion.
+
 comment "Decoder plugins"
 
 config BR2_PACKAGE_MPD_AUDIOFILE
diff --git a/package/mpd/mpd.mk b/package/mpd/mpd.mk
index b10a60a..92d7292 100644
--- a/package/mpd/mpd.mk
+++ b/package/mpd/mpd.mk
@@ -104,6 +104,13 @@  else
 MPD_CONF_OPTS += --disable-sndfile
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_LIBSOXR),y)
+MPD_DEPENDENCIES += libsoxr
+MPD_CONF_OPTS += --enable-soxr
+else
+MPD_CONF_OPTS += --disable-soxr
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_MAD),y)
 MPD_DEPENDENCIES += libid3tag libmad
 MPD_CONF_OPTS += --enable-mad