diff mbox

xbmc: use github call

Message ID 1413138060-1146-1-git-send-email-maxime.hadjinlian@gmail.com
State Accepted
Headers show

Commit Message

Maxime Hadjinlian Oct. 12, 2014, 6:21 p.m. UTC
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
---
 package/xbmc/xbmc.mk | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Yann E. MORIN Oct. 19, 2014, 8:57 a.m. UTC | #1
Maxime, All,

On 2014-10-12 20:21 +0200, Maxime Hadjinlian spake thusly:
> Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>

Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
>  package/xbmc/xbmc.mk | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/package/xbmc/xbmc.mk b/package/xbmc/xbmc.mk
> index 0101ad7..966dbb3 100644
> --- a/package/xbmc/xbmc.mk
> +++ b/package/xbmc/xbmc.mk
> @@ -5,8 +5,7 @@
>  ################################################################################
>  
>  XBMC_VERSION = 13.2-Gotham
> -XBMC_SOURCE = $(XBMC_VERSION).tar.gz
> -XBMC_SITE = https://github.com/xbmc/xbmc/archive
> +XBMC_SITE = $(call github,xbmc,xbmc,$(XBMC_VERSION))
>  XBMC_LICENSE = GPLv2
>  XBMC_LICENSE_FILES = LICENSE.GPL
>  # XBMC needs host-sdl_image (and therefore host-sdl) for a host tools it builds
> -- 
> 2.1.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard Nov. 13, 2014, 8:21 a.m. UTC | #2
>>>>> "Maxime" == Maxime Hadjinlian <maxime.hadjinlian@gmail.com> writes:

 > Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>

Yann pointed out to me on IRC last night that this was needed for
2014.11 as xbmc downloads were otherwise broken, but it doesn't work for
me:

>>> xbmc 13.2-Gotham Downloading
--2014-11-13 09:16:48--  https://github.com/xbmc/xbmc/archive/13.2-Gotham/xbmc-13.2-Gotham.tar.gz
Resolving github.com (github.com)... 192.30.252.129
Connecting to github.com (github.com)|192.30.252.129|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2014-11-13 09:16:50 ERROR 404: Not Found.

--2014-11-13 09:16:50--  http://sources.buildroot.net/xbmc-13.2-Gotham.tar.gz
Resolving sources.buildroot.net (sources.buildroot.net)... 176.9.16.109
Connecting to sources.buildroot.net (sources.buildroot.net)|176.9.16.109|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2014-11-13 09:16:50 ERROR 404: Not Found.

package/pkg-generic.mk:73: recipe for target '/home/peko/source/buildroot/output/build/xbmc-13.2-Gotham/.stamp_downloaded' failed

Whereas the old URL did work:

>>> xbmc 13.2-Gotham Downloading
--2014-11-13 09:21:12--  https://github.com/xbmc/xbmc/archive/13.2-Gotham.tar.gz
Resolving github.com (github.com)... 192.30.252.129
Connecting to github.com (github.com)|192.30.252.129|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://codeload.github.com/xbmc/xbmc/tar.gz/13.2-Gotham [following]
--2014-11-13 09:21:13--  https://codeload.github.com/xbmc/xbmc/tar.gz/13.2-Gotham
Resolving codeload.github.com (codeload.github.com)... 192.30.252.144
Connecting to codeload.github.com (codeload.github.com)|192.30.252.144|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 65900491 (63M) [application/x-gzip]
Saving to: ‘/home/peko/source/buildroot/output/build/.13.2-Gotham.tar.gz.D3JP1O/output’

100%[======================================================================>] 65,900,491  3.51MB/s   in 12s    

So what's going on?
Maxime Hadjinlian Nov. 13, 2014, 9:18 a.m. UTC | #3
Hi Peter, all

On Thu, Nov 13, 2014 at 9:21 AM, Peter Korsgaard <peter@korsgaard.com> wrote:
>>>>>> "Maxime" == Maxime Hadjinlian <maxime.hadjinlian@gmail.com> writes:
>
>  > Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
>
> Yann pointed out to me on IRC last night that this was needed for
> 2014.11 as xbmc downloads were otherwise broken, but it doesn't work for
> me:
>
>>>> xbmc 13.2-Gotham Downloading
> --2014-11-13 09:16:48--  https://github.com/xbmc/xbmc/archive/13.2-Gotham/xbmc-13.2-Gotham.tar.gz
> Resolving github.com (github.com)... 192.30.252.129
> Connecting to github.com (github.com)|192.30.252.129|:443... connected.
> HTTP request sent, awaiting response... 404 Not Found
> 2014-11-13 09:16:50 ERROR 404: Not Found.
>
> --2014-11-13 09:16:50--  http://sources.buildroot.net/xbmc-13.2-Gotham.tar.gz
> Resolving sources.buildroot.net (sources.buildroot.net)... 176.9.16.109
> Connecting to sources.buildroot.net (sources.buildroot.net)|176.9.16.109|:80... connected.
> HTTP request sent, awaiting response... 404 Not Found
> 2014-11-13 09:16:50 ERROR 404: Not Found.
>
> package/pkg-generic.mk:73: recipe for target '/home/peko/source/buildroot/output/build/xbmc-13.2-Gotham/.stamp_downloaded' failed
>
> Whereas the old URL did work:
>
>>>> xbmc 13.2-Gotham Downloading
> --2014-11-13 09:21:12--  https://github.com/xbmc/xbmc/archive/13.2-Gotham.tar.gz
> Resolving github.com (github.com)... 192.30.252.129
> Connecting to github.com (github.com)|192.30.252.129|:443... connected.
> HTTP request sent, awaiting response... 302 Found
> Location: https://codeload.github.com/xbmc/xbmc/tar.gz/13.2-Gotham [following]
> --2014-11-13 09:21:13--  https://codeload.github.com/xbmc/xbmc/tar.gz/13.2-Gotham
> Resolving codeload.github.com (codeload.github.com)... 192.30.252.144
> Connecting to codeload.github.com (codeload.github.com)|192.30.252.144|:443... connected.
> HTTP request sent, awaiting response... 200 OK
> Length: 65900491 (63M) [application/x-gzip]
> Saving to: ‘/home/peko/source/buildroot/output/build/.13.2-Gotham.tar.gz.D3JP1O/output’
>
> 100%[======================================================================>] 65,900,491  3.51MB/s   in 12s
>
> So what's going on?
As it appeared on IRC yesterday also, it seems that github changed
*again* their download schemes silently, so every package using the
github-helper are currently broken.
We need to devise a new github helper, or something to fix this urgently.
Keep this patch in the queue, if we keep the github-helper, it should
work then (or need some rework, depending on the solution we chose)
>
> --
> Bye, Peter Korsgaard
Peter Korsgaard Nov. 13, 2014, 9:22 a.m. UTC | #4
>>>>> "Maxime" == Maxime Hadjinlian <maxime.hadjinlian@gmail.com> writes:

Hi,

 >> So what's going on?
 > As it appeared on IRC yesterday also, it seems that github changed
 > *again* their download schemes silently, so every package using the
 > github-helper are currently broken.
 > We need to devise a new github helper, or something to fix this urgently.
 > Keep this patch in the queue, if we keep the github-helper, it should
 > work then (or need some rework, depending on the solution we chose)

Argh :/

Did anybody ever try contacting github to ask them to not break this
again and again?
Maxime Hadjinlian Nov. 13, 2014, 9:04 p.m. UTC | #5
Hi Peter, all

On Thu, Nov 13, 2014 at 10:22 AM, Peter Korsgaard <peter@korsgaard.com> wrote:
>>>>>> "Maxime" == Maxime Hadjinlian <maxime.hadjinlian@gmail.com> writes:
>
> Hi,
>
>  >> So what's going on?
>  > As it appeared on IRC yesterday also, it seems that github changed
>  > *again* their download schemes silently, so every package using the
>  > github-helper are currently broken.
>  > We need to devise a new github helper, or something to fix this urgently.
>  > Keep this patch in the queue, if we keep the github-helper, it should
>  > work then (or need some rework, depending on the solution we chose)
>
> Argh :/
>
> Did anybody ever try contacting github to ask them to not break this
> again and again?
As Yann told me on IRC, it seems it has been fixed on Github sides.
None the less, we should make a contact to tell them we exist.
Feel free to apply this patch then.
>
> --
> Bye, Peter Korsgaard
Yann E. MORIN Nov. 13, 2014, 10:11 p.m. UTC | #6
Peter, All,

On 2014-11-13 09:21 +0100, Peter Korsgaard spake thusly:
> >>>>> "Maxime" == Maxime Hadjinlian <maxime.hadjinlian@gmail.com> writes:
> 
>  > Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
> 
> Yann pointed out to me on IRC last night that this was needed for
> 2014.11 as xbmc downloads were otherwise broken, but it doesn't work for
> me:
[--SNIP--]
> So what's going on?

GitHub fixed their URLs handling now, so you can apply that patch, now.

Regards,
Yann E. MORIN.
Thomas Petazzoni Dec. 7, 2014, 11:11 p.m. UTC | #7
Dear Maxime Hadjinlian,

On Sun, 12 Oct 2014 20:21:00 +0200, Maxime Hadjinlian wrote:
> Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
> ---
>  package/xbmc/xbmc.mk | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)

Applied, thanks.

Thomas
diff mbox

Patch

diff --git a/package/xbmc/xbmc.mk b/package/xbmc/xbmc.mk
index 0101ad7..966dbb3 100644
--- a/package/xbmc/xbmc.mk
+++ b/package/xbmc/xbmc.mk
@@ -5,8 +5,7 @@ 
 ################################################################################
 
 XBMC_VERSION = 13.2-Gotham
-XBMC_SOURCE = $(XBMC_VERSION).tar.gz
-XBMC_SITE = https://github.com/xbmc/xbmc/archive
+XBMC_SITE = $(call github,xbmc,xbmc,$(XBMC_VERSION))
 XBMC_LICENSE = GPLv2
 XBMC_LICENSE_FILES = LICENSE.GPL
 # XBMC needs host-sdl_image (and therefore host-sdl) for a host tools it builds