diff mbox

pkg-perl: fix build of perl XS packages

Message ID 1408042199-28433-1-git-send-email-francois.perrad@gadz.org
State Accepted
Commit 6057878756f6f58d613a40be9636581ae5950aa0
Headers show

Commit Message

Francois Perrad Aug. 14, 2014, 6:49 p.m. UTC
Set OPTIMIZE in order to avoid the use of the host $Config{optimize} value
which could cause breakage when cross-compiling for the target.

See discussion in http://lists.busybox.net/pipermail/buildroot/2014-August/104129.html

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/pkg-perl.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Peter Korsgaard Aug. 15, 2014, 8:19 a.m. UTC | #1
>>>>> "Francois" == Francois Perrad <fperrad@gmail.com> writes:

 > Set OPTIMIZE in order to avoid the use of the host $Config{optimize} value
 > which could cause breakage when cross-compiling for the target.

 > See discussion in http://lists.busybox.net/pipermail/buildroot/2014-August/104129.html

 > Signed-off-by: Francois Perrad <francois.perrad@gadz.org>

Committed, thanks.
Thomas Petazzoni Aug. 15, 2014, 5:02 p.m. UTC | #2
Dear Francois Perrad,

On Thu, 14 Aug 2014 20:49:59 +0200, Francois Perrad wrote:
> Set OPTIMIZE in order to avoid the use of the host $Config{optimize} value
> which could cause breakage when cross-compiling for the target.
> 
> See discussion in http://lists.busybox.net/pipermail/buildroot/2014-August/104129.html
> 
> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> ---
>  package/pkg-perl.mk | 2 ++
>  1 file changed, 2 insertions(+)

This patch breaks the build of certain packages:
http://autobuild.buildroot.org/results/1a4/1a40923db4ba518001786b02d1d4ad2cf2bf7086/build-end.log.

Thomas
diff mbox

Patch

diff --git a/package/pkg-perl.mk b/package/pkg-perl.mk
index f073d70..51eaf52 100644
--- a/package/pkg-perl.mk
+++ b/package/pkg-perl.mk
@@ -56,6 +56,7 @@  define $(2)_CONFIGURE_CMDS
 			--config full_ar="$$(TARGET_AR)" \
 			--config cc="$$(TARGET_CC)" \
 			--config ccflags="$$(TARGET_CFLAGS)" \
+			--config optimize=" " \
 			--config ld="$$(TARGET_CC)" \
 			--config lddlflags="-shared $$(TARGET_LDFLAGS)" \
 			--config ldflags="$$(TARGET_LDFLAGS)" \
@@ -78,6 +79,7 @@  define $(2)_CONFIGURE_CMDS
 			FULL_AR="$$(TARGET_AR)" \
 			CC="$$(TARGET_CC)" \
 			CCFLAGS="$$(TARGET_CFLAGS)" \
+			OPTIMIZE=" " \
 			LD="$$(TARGET_CC)" \
 			LDDLFLAGS="-shared $$(TARGET_LDFLAGS)" \
 			LDFLAGS="$$(TARGET_LDFLAGS)" \