diff mbox

[1/2] mongoose: bump to version 5.4

Message ID 1407187903-10013-1-git-send-email-zinosat@tiscali.it
State Superseded
Headers show

Commit Message

Davide Viti Aug. 4, 2014, 9:31 p.m. UTC
Avoid compilation of the server via the upstream Makefile which
unconditionally uses -lssl

Signed-off-by: Davide Viti <zinosat@tiscali.it>
---
 package/mongoose/mongoose.mk |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni Aug. 5, 2014, 7:46 a.m. UTC | #1
Dear Davide Viti,

On Mon,  4 Aug 2014 23:31:42 +0200, Davide Viti wrote:
> Avoid compilation of the server via the upstream Makefile which
> unconditionally uses -lssl

Ok, but then, don't we want to optionally use the SSL support when
available (i.e when BR2_PACKAGE_OPENSSL=y) ?

Thomas
diff mbox

Patch

diff --git a/package/mongoose/mongoose.mk b/package/mongoose/mongoose.mk
index ee93846..4182a30 100644
--- a/package/mongoose/mongoose.mk
+++ b/package/mongoose/mongoose.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-MONGOOSE_VERSION = 5.3
+MONGOOSE_VERSION = 5.4
 MONGOOSE_SITE = $(call github,cesanta,mongoose,$(MONGOOSE_VERSION))
 MONGOOSE_LICENSE = GPLv2
 MONGOOSE_LICENSE_FILES = LICENSE
@@ -19,8 +19,8 @@  MONGOOSE_CFLAGS += -DNS_ENABLE_SSL -lssl -lcrypto -lz
 endif
 
 define MONGOOSE_BUILD_CMDS
-	$(MAKE) CC="$(TARGET_CC)" LD="$(TARGET_LD)" -C $(@D)/examples \
-		CFLAGS_EXTRA="$(MONGOOSE_CFLAGS)" server
+	$(TARGET_CC) $(@D)/examples/server.c $(@D)/mongoose.c \
+		-o $(@D)/examples/server $(MONGOOSE_CFLAGS) -pthread -ldl
 	$(TARGET_CC) -c $(@D)/mongoose.c $(MONGOOSE_CFLAGS) -o $(@D)/mongoose.o
 	$(TARGET_AR) rcs $(@D)/libmongoose.a $(@D)/mongoose.o
 endef