diff mbox

[2/2] bandwidthd: new package

Message ID 1406548649-4649-2-git-send-email-nroach44@gmail.com
State Superseded
Headers show

Commit Message

Nathaniel Roach July 28, 2014, 11:57 a.m. UTC
Signed-off-by: Nathaniel Roach <nroach44@gmail.com>
---
 package/Config.in                |  1 +
 package/bandwidthd/Config.in     | 39 +++++++++++++++++++++++++++++++++++++++
 package/bandwidthd/bandwidthd.mk | 25 +++++++++++++++++++++++++
 3 files changed, 65 insertions(+)
 create mode 100644 package/bandwidthd/Config.in
 create mode 100644 package/bandwidthd/bandwidthd.mk

Comments

Thomas Petazzoni July 28, 2014, 7 p.m. UTC | #1
Dear Nathaniel Roach,

On Mon, 28 Jul 2014 19:57:29 +0800, Nathaniel Roach wrote:

> diff --git a/package/bandwidthd/Config.in b/package/bandwidthd/Config.in
> new file mode 100644
> index 0000000..7305060
> --- /dev/null
> +++ b/package/bandwidthd/Config.in
> @@ -0,0 +1,39 @@
> +config BR2_PACKAGE_BANDWIDTHD
> +	bool "bandwidthd"
> +	depends on BR2_USE_MMU # fork()

No other toolchain dependency? Can you try building this package with
the following base configuration:

  http://autobuild.buildroot.org/toolchains/configs/br-arm-basic.config

> +if BR2_PACKAGE_BANDWIDTHD

Please add an empty new line here.

> +config BR2_PACKAGE_BANDWIDTHD_POSTGRESQL
> +	bool "enable postgresql log target support"
> +	select BR2_PACKAGE_POSTGRESQL

When selecting a package, you need to propagate its dependencies. Since
postgresql depends on glibc, you need to propagate this dependency here:

	depends on BR2_TOOLCHAIN_USES_GLIBC # postgresql

> diff --git a/package/bandwidthd/bandwidthd.mk b/package/bandwidthd/bandwidthd.mk
> new file mode 100644
> index 0000000..e294af3
> --- /dev/null
> +++ b/package/bandwidthd/bandwidthd.mk
> @@ -0,0 +1,25 @@
> +################################################################################
> +#
> +# bandwidthd

One new line needed here. See other packages for the format of the
header.

> +################################################################################
> +
> +BANDWIDTHD_VERSION = v2.0.1-auto-r03
> +BANDWIDTHD_SITE = $(call github,nroach44,bandwidthd,$(BANDWIDTHD_VERSION))
> +BANDWIDTHD_CONF_OPT = 
> +BANDWIDTHD_CONF_ENV =

Empty variables not needed.

> +BANDWIDTHD_LICENSE = GPL+

It's rather unfortunate that they do not specify the version of the
GPL. So, I don't think the "+" is in order here. Maybe just:

# GPL version unspecified by upstream authors
BANDWIDTHD_LICENSE = GPL

> +BANDWIDTHD_DEPENDENCIES += gd
> +BANDWIDTHD_DEPENDENCIES += libpng
> +BANDWIDTHD_DEPENDENCIES += libpcap

Just one line:

BANDWIDTHD_DEPENDENCIES = gd libpng libpcap

> +
> +BANDWIDTHD_AUTORECONF = YES
> +
> +ifeq ($(BR2_PACKAGE_BANDWIDTHD_POSTGRESQL),y)
> +BANDWIDTHD_DEPENDENCIES += postgresql
> +BANDWIDTHD_CONF_OPT += --with-postgresql-logging=true
> +else
> +BANDWIDTHD_CONF_OPT += --with-postgresql-logging=false
> +endif
> +
> +$(eval $(autotools-package))

Other than that, looks good. Could you resubmit an updated version
fixing those issues?

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index 559b895..04d666e 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -937,6 +937,7 @@  menu "Networking applications"
 	source "package/autossh/Config.in"
 	source "package/avahi/Config.in"
 	source "package/axel/Config.in"
+	source "package/bandwidthd/Config.in"
 	source "package/bcusdk/Config.in"
 	source "package/bind/Config.in"
 	source "package/bluez_utils/Config.in"
diff --git a/package/bandwidthd/Config.in b/package/bandwidthd/Config.in
new file mode 100644
index 0000000..7305060
--- /dev/null
+++ b/package/bandwidthd/Config.in
@@ -0,0 +1,39 @@ 
+config BR2_PACKAGE_BANDWIDTHD
+	bool "bandwidthd"
+	depends on BR2_USE_MMU # fork()
+	select BR2_PACKAGE_LIBPNG
+	select BR2_PACKAGE_LIBPCAP
+	select BR2_PACKAGE_GD
+	help
+	  BandwidthD - Bandwidth monitoring
+
+	  Provides a method to measure the bandwidth that travels through the
+	  machine, grouped by subnet and IP. This information can be stored
+	  locally in /var/lib/bandwidthd and can be configured to generate
+	  static HTML pages which can be hosted by a web server.
+
+	  It is highly recommended that the target has some way of retaining the
+	  time between reboots. (e.g. NTP on boot or an RTC)
+	  
+	  It is suggested to install sqlite for logfile storage but works fine
+	  without, and can be completely ignored if the postgresql portion
+	  is used. 
+
+	  As upstream is no longer actively maintained, a fork is available
+	  on github that works on making BandwidthD's build process more
+	  compatible with buildroot's.
+
+	  Upstream: http://bandwidthd.sourceforge.net/
+	  Github fork: http://github.com/nroach44/bandwidthd
+
+if BR2_PACKAGE_BANDWIDTHD
+config BR2_PACKAGE_BANDWIDTHD_POSTGRESQL
+	bool "enable postgresql log target support"
+	select BR2_PACKAGE_POSTGRESQL
+	help
+	  Enable logging the bandwidthd data to a remote (or local) postgresql
+	  server. This can then be accessed through a php site. See 
+	  README in the source code (github.com/nroach44/bandwidthd) for more
+	  information.
+
+endif
diff --git a/package/bandwidthd/bandwidthd.mk b/package/bandwidthd/bandwidthd.mk
new file mode 100644
index 0000000..e294af3
--- /dev/null
+++ b/package/bandwidthd/bandwidthd.mk
@@ -0,0 +1,25 @@ 
+################################################################################
+#
+# bandwidthd
+################################################################################
+
+BANDWIDTHD_VERSION = v2.0.1-auto-r03
+BANDWIDTHD_SITE = $(call github,nroach44,bandwidthd,$(BANDWIDTHD_VERSION))
+BANDWIDTHD_CONF_OPT = 
+BANDWIDTHD_CONF_ENV =
+BANDWIDTHD_LICENSE = GPL+
+
+BANDWIDTHD_DEPENDENCIES += gd
+BANDWIDTHD_DEPENDENCIES += libpng
+BANDWIDTHD_DEPENDENCIES += libpcap
+
+BANDWIDTHD_AUTORECONF = YES
+
+ifeq ($(BR2_PACKAGE_BANDWIDTHD_POSTGRESQL),y)
+BANDWIDTHD_DEPENDENCIES += postgresql
+BANDWIDTHD_CONF_OPT += --with-postgresql-logging=true
+else
+BANDWIDTHD_CONF_OPT += --with-postgresql-logging=false
+endif
+
+$(eval $(autotools-package))