diff mbox

Makefile: do not purge locale-archive from target

Message ID 1403083410-4278-1-git-send-email-neumann@teufel.de
State Accepted
Headers show

Commit Message

Sven Neumann June 18, 2014, 9:23 a.m. UTC
The rules to purge unwanted locales from the target also removed
the locale-archive file from /usr/lib/locale which contains the
locale definitions explicitly generated for the target.

Signed-off-by: Sven Neumann <neumann@teufel.de>
---
 Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni June 22, 2014, 8:27 p.m. UTC | #1
Dear Sven Neumann,

On Wed, 18 Jun 2014 11:23:30 +0200, Sven Neumann wrote:
> The rules to purge unwanted locales from the target also removed
> the locale-archive file from /usr/lib/locale which contains the
> locale definitions explicitly generated for the target.
> 
> Signed-off-by: Sven Neumann <neumann@teufel.de>
> ---
>  Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/Makefile b/Makefile
> index 14fca2b..d7590ef 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -516,7 +516,7 @@ LOCALE_NOPURGE = $(call qstrip,$(BR2_ENABLE_LOCALE_WHITELIST))
>  
>  define TARGET_PURGE_LOCALES
>  	rm -f $(LOCALE_WHITELIST)
> -	for i in $(LOCALE_NOPURGE); do echo $$i >> $(LOCALE_WHITELIST); done
> +	for i in $(LOCALE_NOPURGE) locale-archive; do echo $$i >> $(LOCALE_WHITELIST); done

Hum, right, but isn't 'locale-archive' an archive of many locales?
Shouldn't we get rid of the locales we don't want from this archive?

Which toolchain have you used to get a locale-archive file?

Thanks,

Thomas
Sven Neumann June 24, 2014, 12:01 p.m. UTC | #2
Hi,

On So, 2014-06-22 at 22:27 +0200, Thomas Petazzoni wrote:

> On Wed, 18 Jun 2014 11:23:30 +0200, Sven Neumann wrote:
> > The rules to purge unwanted locales from the target also removed
> > the locale-archive file from /usr/lib/locale which contains the
> > locale definitions explicitly generated for the target.
> > 
> > Signed-off-by: Sven Neumann <neumann@teufel.de>
> > ---
> >  Makefile | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/Makefile b/Makefile
> > index 14fca2b..d7590ef 100644
> > --- a/Makefile
> > +++ b/Makefile
> > @@ -516,7 +516,7 @@ LOCALE_NOPURGE = $(call qstrip,$(BR2_ENABLE_LOCALE_WHITELIST))
> >  
> >  define TARGET_PURGE_LOCALES
> >  	rm -f $(LOCALE_WHITELIST)
> > -	for i in $(LOCALE_NOPURGE); do echo $$i >> $(LOCALE_WHITELIST); done
> > +	for i in $(LOCALE_NOPURGE) locale-archive; do echo $$i >> $(LOCALE_WHITELIST); done
> 
> Hum, right, but isn't 'locale-archive' an archive of many locales?
> Shouldn't we get rid of the locales we don't want from this archive?

Well, as far as I can see only the locales selected by
BR2_GENERATE_LOCALE should have been generated into the archive. So I
don't think it makes sense to purge locales from this archive. It would
be possible to do this though using "locale-def --delete-from-archiv".

> Which toolchain have you used to get a locale-archive file?

glibc 2.18


Greetings,
Sven
Thomas Petazzoni July 15, 2014, 8:56 p.m. UTC | #3
Dear Sven Neumann,

On Wed, 18 Jun 2014 11:23:30 +0200, Sven Neumann wrote:
> The rules to purge unwanted locales from the target also removed
> the locale-archive file from /usr/lib/locale which contains the
> locale definitions explicitly generated for the target.
> 
> Signed-off-by: Sven Neumann <neumann@teufel.de>
> ---
>  Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied, thanks.

Thomas
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 14fca2b..d7590ef 100644
--- a/Makefile
+++ b/Makefile
@@ -516,7 +516,7 @@  LOCALE_NOPURGE = $(call qstrip,$(BR2_ENABLE_LOCALE_WHITELIST))
 
 define TARGET_PURGE_LOCALES
 	rm -f $(LOCALE_WHITELIST)
-	for i in $(LOCALE_NOPURGE); do echo $$i >> $(LOCALE_WHITELIST); done
+	for i in $(LOCALE_NOPURGE) locale-archive; do echo $$i >> $(LOCALE_WHITELIST); done
 
 	for dir in $(wildcard $(addprefix $(TARGET_DIR),/usr/share/locale /usr/share/X11/locale /usr/man /usr/share/man /usr/lib/locale)); \
 	do \