diff mbox

[1/1] ti-gfx: bump to version 5_01_01_01

Message ID 1401812044-11578-1-git-send-email-hadrien.boutteville@gmail.com
State Changes Requested
Headers show

Commit Message

Hadrien Boutteville June 3, 2014, 4:14 p.m. UTC
Note that SDK 5_01_01_01 only support EABIhf.

Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com>
---
 package/ti-gfx/Config.in | 7 ++++---
 package/ti-gfx/ti-gfx.mk | 8 +-------
 2 files changed, 5 insertions(+), 10 deletions(-)

Comments

Yann E. MORIN June 4, 2014, 6:04 p.m. UTC | #1
Hadrien, All,

On 2014-06-03 18:14 +0200, Hadrien Boutteville spake thusly:
> Note that SDK 5_01_01_01 only support EABIhf.

Then maybe we should fallback to the 5.01.00.01 version for non-EABIhf
builds?

If we want to still support that, of course, but I guess we should.
There are still binary-only, legacy code that is using the softfp ABI,
so I suggest we should stick to supporting it for a while.

Regards,
Yann E. MORIN.

> Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com>
> ---
>  package/ti-gfx/Config.in | 7 ++++---
>  package/ti-gfx/ti-gfx.mk | 8 +-------
>  2 files changed, 5 insertions(+), 10 deletions(-)
> 
> diff --git a/package/ti-gfx/Config.in b/package/ti-gfx/Config.in
> index 4ee8622..bd6189e 100644
> --- a/package/ti-gfx/Config.in
> +++ b/package/ti-gfx/Config.in
> @@ -4,7 +4,8 @@ config BR2_PACKAGE_TI_GFX
>  	select BR2_PACKAGE_HAS_LIBGLES
>  	select BR2_PACKAGE_HAS_POWERVR
>  	select BR2_PACKAGE_FBSET if !BR2_PACKAGE_BUSYBOX # Runtime dependency only
> -	depends on BR2_LINUX_KERNEL && BR2_TOOLCHAIN_USES_GLIBC && BR2_arm
> +	depends on BR2_LINUX_KERNEL && BR2_TOOLCHAIN_USES_GLIBC && BR2_arm && \
> +		BR2_ARM_EABIHF
>  	help
>  	  Graphics libraries for TI boards.
>  
> @@ -70,6 +71,6 @@ endchoice
>  
>  endif
>  
> -comment "ti-gfx needs an (e)glibc toolchain and a Linux kernel to be built"
> +comment "ti-gfx needs an (e)glibc and EABIhf toolchain and a Linux kernel to be built"
>  	depends on BR2_arm
> -	depends on !(BR2_LINUX_KERNEL && BR2_TOOLCHAIN_USES_GLIBC)
> +	depends on !(BR2_LINUX_KERNEL && BR2_TOOLCHAIN_USES_GLIBC && BR2_ARM_EABIHF)
> diff --git a/package/ti-gfx/ti-gfx.mk b/package/ti-gfx/ti-gfx.mk
> index 324e19c..8235917 100644
> --- a/package/ti-gfx/ti-gfx.mk
> +++ b/package/ti-gfx/ti-gfx.mk
> @@ -4,15 +4,9 @@
>  #
>  ################################################################################
>  
> -TI_GFX_VERSION = 5_01_00_01
> +TI_GFX_VERSION = 5_01_01_01
>  TI_GFX_SO_VERSION = 1.10.2359475
> -
> -ifeq ($(BR2_ARM_EABIHF),y)
>  TI_GFX_SOURCE = Graphics_SDK_setuplinux_hardfp_$(TI_GFX_VERSION).bin
> -else
> -TI_GFX_SOURCE = Graphics_SDK_setuplinux_softfp_$(TI_GFX_VERSION).bin
> -endif
> -
>  TI_GFX_SITE = http://downloads.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/$(TI_GFX_VERSION)/exports/
>  TI_GFX_LICENSE = Technology / Software Publicly Available
>  TI_GFX_LICENSE_FILES = TSPA.txt
> -- 
> 2.0.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni June 8, 2014, 2:35 p.m. UTC | #2
Dear Hadrien Boutteville,

On Tue,  3 Jun 2014 18:14:04 +0200, Hadrien Boutteville wrote:
> Note that SDK 5_01_01_01 only support EABIhf.
> 
> Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com>
> ---
>  package/ti-gfx/Config.in | 7 ++++---
>  package/ti-gfx/ti-gfx.mk | 8 +-------
>  2 files changed, 5 insertions(+), 10 deletions(-)

Can you fix according to Yann's comments?

Thanks,

Thomas
diff mbox

Patch

diff --git a/package/ti-gfx/Config.in b/package/ti-gfx/Config.in
index 4ee8622..bd6189e 100644
--- a/package/ti-gfx/Config.in
+++ b/package/ti-gfx/Config.in
@@ -4,7 +4,8 @@  config BR2_PACKAGE_TI_GFX
 	select BR2_PACKAGE_HAS_LIBGLES
 	select BR2_PACKAGE_HAS_POWERVR
 	select BR2_PACKAGE_FBSET if !BR2_PACKAGE_BUSYBOX # Runtime dependency only
-	depends on BR2_LINUX_KERNEL && BR2_TOOLCHAIN_USES_GLIBC && BR2_arm
+	depends on BR2_LINUX_KERNEL && BR2_TOOLCHAIN_USES_GLIBC && BR2_arm && \
+		BR2_ARM_EABIHF
 	help
 	  Graphics libraries for TI boards.
 
@@ -70,6 +71,6 @@  endchoice
 
 endif
 
-comment "ti-gfx needs an (e)glibc toolchain and a Linux kernel to be built"
+comment "ti-gfx needs an (e)glibc and EABIhf toolchain and a Linux kernel to be built"
 	depends on BR2_arm
-	depends on !(BR2_LINUX_KERNEL && BR2_TOOLCHAIN_USES_GLIBC)
+	depends on !(BR2_LINUX_KERNEL && BR2_TOOLCHAIN_USES_GLIBC && BR2_ARM_EABIHF)
diff --git a/package/ti-gfx/ti-gfx.mk b/package/ti-gfx/ti-gfx.mk
index 324e19c..8235917 100644
--- a/package/ti-gfx/ti-gfx.mk
+++ b/package/ti-gfx/ti-gfx.mk
@@ -4,15 +4,9 @@ 
 #
 ################################################################################
 
-TI_GFX_VERSION = 5_01_00_01
+TI_GFX_VERSION = 5_01_01_01
 TI_GFX_SO_VERSION = 1.10.2359475
-
-ifeq ($(BR2_ARM_EABIHF),y)
 TI_GFX_SOURCE = Graphics_SDK_setuplinux_hardfp_$(TI_GFX_VERSION).bin
-else
-TI_GFX_SOURCE = Graphics_SDK_setuplinux_softfp_$(TI_GFX_VERSION).bin
-endif
-
 TI_GFX_SITE = http://downloads.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/$(TI_GFX_VERSION)/exports/
 TI_GFX_LICENSE = Technology / Software Publicly Available
 TI_GFX_LICENSE_FILES = TSPA.txt