diff mbox

pkg-perl: prevents the interactive prompts

Message ID 1395169199-31890-1-git-send-email-francois.perrad@gadz.org
State Superseded
Headers show

Commit Message

Francois Perrad March 18, 2014, 6:59 p.m. UTC
during configure and build steps of Perl/CPAN package.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/pkg-perl.mk |    3 +++
 1 file changed, 3 insertions(+)

Comments

Thomas Petazzoni March 18, 2014, 10:28 p.m. UTC | #1
Dear Francois Perrad,

On Tue, 18 Mar 2014 19:59:59 +0100, Francois Perrad wrote:
> during configure and build steps of Perl/CPAN package.
> 
> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> ---
>  package/pkg-perl.mk |    3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/package/pkg-perl.mk b/package/pkg-perl.mk
> index fdf1580..b5fada1 100644
> --- a/package/pkg-perl.mk
> +++ b/package/pkg-perl.mk
> @@ -19,6 +19,9 @@
>  #
>  ################################################################################
>  
> +# prevents the interactive prompts
> +export PERL_MM_USE_DEFAULT=1

Instead of exporting globally this variable, I believe I would prefer
to see it passed only in the configure and build steps of the
appropriate package infrastructure, passed explicitly. Like what we do
for all autoconf arguments and environment variables, for example.

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/pkg-perl.mk b/package/pkg-perl.mk
index fdf1580..b5fada1 100644
--- a/package/pkg-perl.mk
+++ b/package/pkg-perl.mk
@@ -19,6 +19,9 @@ 
 #
 ################################################################################
 
+# prevents the interactive prompts
+export PERL_MM_USE_DEFAULT=1
+
 PERL_ARCHNAME	= $(ARCH)-linux
 
 ################################################################################