diff mbox

[4/4] i.MX6: Update Freescale hardware-acceleration bits to latest versions

Message ID 1380136072-9879-5-git-send-email-eric.nelson@boundarydevices.com
State Superseded
Headers show

Commit Message

Eric Nelson Sept. 25, 2013, 7:07 p.m. UTC
This patchset updates the Freescale gstreamer and GPU libraries
to the latest release (3.0.35_4.1.0).

Note that the package names refer to and are compatible with
an alpha release of kernel version 3.5.7.

The primary release package (based on LTIB) is available
here and includes documentation.
	https://community.freescale.com/docs/DOC-95560

The 3.5.7 kernel sources are available here:
	http://git.freescale.com/git/cgit.cgi/imx/linux-2.6-imx.git/log/?h=imx_3.5.7_1.0.0_alpha

Signed-off-by: Eric Nelson <eric.nelson@boundarydevices.com>
---
 package/freescale-imx/freescale-imx.mk             |  4 ++--
 .../gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk           |  8 +++++---
 package/freescale-imx/imx-lib/imx-lib.mk           | 11 ++++++++++-
 .../gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk   |  4 ++--
 package/libfslcodec/libfslcodec.mk                 |  4 ++--
 package/libfslparser/libfslparser.mk               |  8 +++++---
 package/libfslvpuwrap/libfslvpuwrap.mk             | 22 ++++++++++++++++++++--
 7 files changed, 46 insertions(+), 15 deletions(-)

Comments

Peter Korsgaard Sept. 26, 2013, 7:36 p.m. UTC | #1
>>>>> "Eric" == Eric Nelson <eric.nelson@boundarydevices.com> writes:

 Eric> This patchset updates the Freescale gstreamer and GPU libraries
 Eric> to the latest release (3.0.35_4.1.0).

 Eric> Note that the package names refer to and are compatible with
 Eric> an alpha release of kernel version 3.5.7.

 Eric> The primary release package (based on LTIB) is available
 Eric> here and includes documentation.
 Eric> 	https://community.freescale.com/docs/DOC-95560

 Eric> The 3.5.7 kernel sources are available here:
 Eric> 	http://git.freescale.com/git/cgit.cgi/imx/linux-2.6-imx.git/log/?h=imx_3.5.7_1.0.0_alpha


 Eric> # No official download site from freescale, just this mirror
 Eric> -FREESCALE_IMX_MIRROR_SITE   = http://download.ossystems.com.br/bsp/freescale/source
 Eric> +FREESCALE_IMX_MIRROR_SITE   = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/

That sounds pretty official to me, so the comment should probably go and
the variable perhaps renamed to FREESCALE_IMX_SITE?

The page btw seems to be down at the moment as I just get:
The system is currently unavailable.

Please accept our apologies for any inconvenience this may cause.
Feel free to contact our Technical Helpline at one of the following numbers:
...


 Eric> +++ b/package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk
 Eric> @@ -3,8 +3,12 @@
 Eric>  # gpu-viv-bin-mx6q
 Eric>  #
 Eric>  ################################################################################
 Eric> +ifeq ($(BR2_ARM_EABIHF),y)
 Eric> +GPU_VIV_BIN_MX6Q_VERSION = $(FREESCALE_IMX_VERSION)-hfp
 Eric> +else
 Eric> +GPU_VIV_BIN_MX6Q_VERSION = $(FREESCALE_IMX_VERSION)-sfp
 Eric> +endif

NIT: There should be an empty line after the ##### line.
 
 Eric> -GPU_VIV_BIN_MX6Q_VERSION = $(FREESCALE_IMX_VERSION)
 Eric>  GPU_VIV_BIN_MX6Q_SITE    = $(FREESCALE_IMX_MIRROR_SITE)
 Eric>  GPU_VIV_BIN_MX6Q_SOURCE  = gpu-viv-bin-mx6q-$(GPU_VIV_BIN_MX6Q_VERSION).bin
 
 Eric> @@ -30,8 +34,6 @@ endif
 Eric>  # The archive is a shell-self-extractor of a bzipped tar. It happens
 Eric>  # to extract in the correct directory (gpu-viv-bin-mx6q-x.y.z)
 Eric>  # The --force makes sure it doesn't fail if the source dir already exists.
 Eric> -# The --auto-accept skips the license check - not needed for us
 Eric> -# because we have legal-info.
 Eric>  define GPU_VIV_BIN_MX6Q_EXTRACT_CMDS
 Eric>  	(cd $(BUILD_DIR); \
 Eric>  		sh $(DL_DIR)/$(GPU_VIV_BIN_MX6Q_SOURCE) --force --auto-accept)

Did you remove this on purpose? If the --auto-accept option is gone then
it should also be removed from here.


 Eric> diff --git a/package/freescale-imx/imx-lib/imx-lib.mk b/package/freescale-imx/imx-lib/imx-lib.mk
 Eric> index bd7e174..e3c29b1 100644
 Eric> --- a/package/freescale-imx/imx-lib/imx-lib.mk
 Eric> +++ b/package/freescale-imx/imx-lib/imx-lib.mk
 Eric> @@ -6,7 +6,8 @@
 
 Eric>  IMX_LIB_VERSION = $(FREESCALE_IMX_VERSION)
 Eric>  IMX_LIB_SITE    = $(FREESCALE_IMX_MIRROR_SITE)
 Eric> -IMX_LIB_LICENSE = LGPLv2.1+
 Eric> +IMX_LIB_SOURCE = imx-lib-$(IMX_LIB_VERSION).bin
 Eric> +IMX_LIB_LICENSE = Freescale Semiconductor Software License Agreement
 Eric>  # No license file included

Sigh, back to self extracting binaries? :/

 
 Eric>  IMX_LIB_INSTALL_STAGING = YES
 Eric> @@ -25,6 +26,14 @@ IMX_LIB_MAKE_ENV = \
 Eric>  	PLATFORM=$(BR2_PACKAGE_IMX_LIB_PLATFORM) \
 Eric>  	INCLUDE="$(IMX_LIB_INCLUDE)"
 
 Eric> +# The archive is a shell-self-extractor of a bzipped tar. It happens
 Eric> +# to extract in the correct directory (imx-lib-x.y.z)
 Eric> +# The --force makes sure it doesn't fail if the source dir already exists.
 Eric> +define IMX_LIB_EXTRACT_CMDS
 Eric> +	(cd $(BUILD_DIR); \
 Eric> +		sh $(DL_DIR)/$(IMX_LIB_SOURCE) --force --auto-accept)
 Eric> +endef

Does it have an --auto-accept option? If so, please document it, if not
remove it here.

 Eric> +++ b/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk
 Eric> @@ -4,9 +4,9 @@
 Eric>  #
 Eric>  ################################################################################
 
 Eric> -GST_FSL_PLUGINS_VERSION = 3.0.1
 Eric> +GST_FSL_PLUGINS_VERSION = 3.5.7-1.0.0
 Eric>  # No official download site from freescale, just this mirror
 Eric> -GST_FSL_PLUGINS_SITE = http://download.ossystems.com.br/bsp/freescale/source
 Eric> +GST_FSL_PLUGINS_SITE = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/

Is this still for gstreamer 0.10?
 

Eric> +++ b/package/libfslcodec/libfslcodec.mk
 Eric> @@ -4,9 +4,9 @@
 Eric>  #
 Eric>  ################################################################################
 
 Eric> -LIBFSLCODEC_VERSION = 3.0.1
 Eric> +LIBFSLCODEC_VERSION = 3.5.7-1.0.0
 Eric>  # No official download site from freescale, just this mirror
 Eric> -LIBFSLCODEC_SITE = http://download.ossystems.com.br/bsp/freescale/source
 Eric> +LIBFSLCODEC_SITE = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/

Maybe this should use FREESCALE_IMX_SITE


 Eric>  LIBFSLCODEC_SOURCE = libfslcodec-$(LIBFSLCODEC_VERSION).bin
 Eric>  LIBFSLCODEC_LICENSE = Freescale Semiconductor Software License Agreement, BSD-3c (flac, ogg headers)
 Eric>  LIBFSLCODEC_LICENSE_FILES = EULA EULA.txt
 Eric> diff --git a/package/libfslparser/libfslparser.mk b/package/libfslparser/libfslparser.mk
 Eric> index 3e27a6a..66068fe 100644
 Eric> --- a/package/libfslparser/libfslparser.mk
 Eric> +++ b/package/libfslparser/libfslparser.mk
 Eric> @@ -4,9 +4,9 @@
 Eric>  #
 Eric>  ################################################################################
 
 Eric> -LIBFSLPARSER_VERSION = 3.0.1
 Eric> +LIBFSLPARSER_VERSION = 3.5.7-1.0.0
 Eric>  # No official download site from freescale, just this mirror
 Eric> -LIBFSLPARSER_SITE = http://download.ossystems.com.br/bsp/freescale/source
 Eric> +LIBFSLPARSER_SITE = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/

Same here (and comment dropped).


 Eric>  LIBFSLPARSER_SOURCE = libfslparser-$(LIBFSLPARSER_VERSION).bin
 Eric>  LIBFSLPARSER_LICENSE = Freescale Semiconductor Software License Agreement
 Eric>  LIBFSLPARSER_LICENSE_FILES = EULA EULA.txt
 Eric> @@ -31,7 +31,9 @@ define LIBFSLPARSER_EXTRACT_CMDS
 Eric>  	     /<<EOEULA/ { start=1; }'\
 Eric>  	    $(DL_DIR)/$(LIBFSLPARSER_SOURCE) > $(@D)/EULA
 Eric>  	cd $(BUILD_DIR); \
 Eric> -	sh $(DL_DIR)/$(LIBFSLPARSER_SOURCE) --force --auto-accept
 Eric> +	sh $(DL_DIR)/$(LIBFSLPARSER_SOURCE) --force --auto-accept ; \
 Eric> +	cd libfslparser-3.5.7-1.0.0; \
 Eric> +	pwd && sh ./autogen.sh
 Eric>  endef

Why the pwd?

We do have generic autoreconf support in Buildroot. Normally you can
just set:

 LIBFSLPARSERS_AUTORECONF = YES

And Buildroot will take care of building the proper auto* packages for
the host and running autoreconf.


 Eric> +++ b/package/libfslvpuwrap/libfslvpuwrap.mk
 Eric> @@ -4,9 +4,10 @@
 Eric>  #
 Eric>  ################################################################################
 
 Eric> -LIBFSLVPUWRAP_VERSION = 1.0.17
 Eric> +LIBFSLVPUWRAP_VERSION = 3.5.7-1.0.0
 Eric>  # No official download site from freescale, just this mirror
 Eric> -LIBFSLVPUWRAP_SITE = http://download.ossystems.com.br/bsp/freescale/source
 Eric> +LIBFSLVPUWRAP_SITE = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/

Same comment as elsewhere.

Care to fix these issues and resubmit? Thanks.
Eric Nelson Sept. 26, 2013, 8:41 p.m. UTC | #2
Hi Peter,

On 09/26/2013 12:36 PM, Peter Korsgaard wrote:
>>>>>> "Eric" == Eric Nelson <eric.nelson@boundarydevices.com> writes:
>
>   Eric> This patchset updates the Freescale gstreamer and GPU libraries
>   Eric> to the latest release (3.0.35_4.1.0).
>
>   Eric> Note that the package names refer to and are compatible with
>   Eric> an alpha release of kernel version 3.5.7.
>
>   Eric> The primary release package (based on LTIB) is available
>   Eric> here and includes documentation.
>   Eric> 	https://community.freescale.com/docs/DOC-95560
>
>   Eric> The 3.5.7 kernel sources are available here:
>   Eric> 	http://git.freescale.com/git/cgit.cgi/imx/linux-2.6-imx.git/log/?h=imx_3.5.7_1.0.0_alpha
>
>
>   Eric> # No official download site from freescale, just this mirror
>   Eric> -FREESCALE_IMX_MIRROR_SITE   = http://download.ossystems.com.br/bsp/freescale/source
>   Eric> +FREESCALE_IMX_MIRROR_SITE   = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/
>

OT: How do you get this nifty formatting? It's about time for me to
retire my crusty Mozilla Thunderbird...

> That sounds pretty official to me, so the comment should probably go and
> the variable perhaps renamed to FREESCALE_IMX_SITE?
>
> The page btw seems to be down at the moment as I just get:
> The system is currently unavailable.
>
> Please accept our apologies for any inconvenience this may cause.
> Feel free to contact our Technical Helpline at one of the following numbers:
> ...
>

There's no page at http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/.

This is simply the repository used to feed packages to the Yocto
project, with a mirror at O.S. Systems:

	https://github.com/Freescale/meta-fsl-arm/blob/master/conf/layer.conf#L14

>
>   Eric> +++ b/package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk
>   Eric> @@ -3,8 +3,12 @@
>   Eric>  # gpu-viv-bin-mx6q
>   Eric>  #
>   Eric>  ################################################################################
>   Eric> +ifeq ($(BR2_ARM_EABIHF),y)
>   Eric> +GPU_VIV_BIN_MX6Q_VERSION = $(FREESCALE_IMX_VERSION)-hfp
>   Eric> +else
>   Eric> +GPU_VIV_BIN_MX6Q_VERSION = $(FREESCALE_IMX_VERSION)-sfp
>   Eric> +endif
>
> NIT: There should be an empty line after the ##### line.
>

Ok.

>   Eric> -GPU_VIV_BIN_MX6Q_VERSION = $(FREESCALE_IMX_VERSION)
>   Eric>  GPU_VIV_BIN_MX6Q_SITE    = $(FREESCALE_IMX_MIRROR_SITE)
>   Eric>  GPU_VIV_BIN_MX6Q_SOURCE  = gpu-viv-bin-mx6q-$(GPU_VIV_BIN_MX6Q_VERSION).bin
>
>   Eric> @@ -30,8 +34,6 @@ endif
>   Eric>  # The archive is a shell-self-extractor of a bzipped tar. It happens
>   Eric>  # to extract in the correct directory (gpu-viv-bin-mx6q-x.y.z)
>   Eric>  # The --force makes sure it doesn't fail if the source dir already exists.
>   Eric> -# The --auto-accept skips the license check - not needed for us
>   Eric> -# because we have legal-info.
>   Eric>  define GPU_VIV_BIN_MX6Q_EXTRACT_CMDS
>   Eric>  	(cd $(BUILD_DIR); \
>   Eric>  		sh $(DL_DIR)/$(GPU_VIV_BIN_MX6Q_SOURCE) --force --auto-accept)
>
> Did you remove this on purpose? If the --auto-accept option is gone then
> it should also be removed from here.
>

I actually meant to, but hadn't yet started a discussion on the topic.

We should be able to get rid of these comments:
	http://git.buildroot.net/buildroot/tree/package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk#n15

By following the lead of the meta-fsl-arm project and allowing the first
of any packages with the Freescale EULA to prompt the user for
acceptance, but I'm not sure how to accomplish that.

In the Yocto world, a tag ("ACCEPT_FREESCALE_EULA") placed in local.conf
is sufficient to bypass the prompt, which requires action by the user.

>
>   Eric> diff --git a/package/freescale-imx/imx-lib/imx-lib.mk b/package/freescale-imx/imx-lib/imx-lib.mk
>   Eric> index bd7e174..e3c29b1 100644
>   Eric> --- a/package/freescale-imx/imx-lib/imx-lib.mk
>   Eric> +++ b/package/freescale-imx/imx-lib/imx-lib.mk
>   Eric> @@ -6,7 +6,8 @@
>
>   Eric>  IMX_LIB_VERSION = $(FREESCALE_IMX_VERSION)
>   Eric>  IMX_LIB_SITE    = $(FREESCALE_IMX_MIRROR_SITE)
>   Eric> -IMX_LIB_LICENSE = LGPLv2.1+
>   Eric> +IMX_LIB_SOURCE = imx-lib-$(IMX_LIB_VERSION).bin
>   Eric> +IMX_LIB_LICENSE = Freescale Semiconductor Software License Agreement
>   Eric>  # No license file included
>
> Sigh, back to self extracting binaries? :/
>

Yep. The tar-balls are gone. This one (imx-lib) is a bit misleading,
since the extracted files say very clearly that all of the components
are released under LGPL.

I think somebody in the packaging department was in the "EULA zone"...

>
>   Eric>  IMX_LIB_INSTALL_STAGING = YES
>   Eric> @@ -25,6 +26,14 @@ IMX_LIB_MAKE_ENV = \
>   Eric>  	PLATFORM=$(BR2_PACKAGE_IMX_LIB_PLATFORM) \
>   Eric>  	INCLUDE="$(IMX_LIB_INCLUDE)"
>
>   Eric> +# The archive is a shell-self-extractor of a bzipped tar. It happens
>   Eric> +# to extract in the correct directory (imx-lib-x.y.z)
>   Eric> +# The --force makes sure it doesn't fail if the source dir already exists.
>   Eric> +define IMX_LIB_EXTRACT_CMDS
>   Eric> +	(cd $(BUILD_DIR); \
>   Eric> +		sh $(DL_DIR)/$(IMX_LIB_SOURCE) --force --auto-accept)
>   Eric> +endef
>
> Does it have an --auto-accept option? If so, please document it, if not
> remove it here.
>

Okay, will do.

>   Eric> +++ b/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk
>   Eric> @@ -4,9 +4,9 @@
>   Eric>  #
>   Eric>  ################################################################################
>
>   Eric> -GST_FSL_PLUGINS_VERSION = 3.0.1
>   Eric> +GST_FSL_PLUGINS_VERSION = 3.5.7-1.0.0
>   Eric>  # No official download site from freescale, just this mirror
>   Eric> -GST_FSL_PLUGINS_SITE = http://download.ossystems.com.br/bsp/freescale/source
>   Eric> +GST_FSL_PLUGINS_SITE = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/
>
> Is this still for gstreamer 0.10?
>

Yes, but version "1.0.0" of the "3.5.7" package and to make things
even more confusing, this is the binary that matches up with kernel
version 3.0.35_4.1.0....

Have you noticed how the Freescale packages often name things
"MXC-something"... I think the "MXC" stands for "Mobile eXtreme 
Confusion"...

>
> Eric> +++ b/package/libfslcodec/libfslcodec.mk
>   Eric> @@ -4,9 +4,9 @@
>   Eric>  #
>   Eric>  ################################################################################
>
>   Eric> -LIBFSLCODEC_VERSION = 3.0.1
>   Eric> +LIBFSLCODEC_VERSION = 3.5.7-1.0.0
>   Eric>  # No official download site from freescale, just this mirror
>   Eric> -LIBFSLCODEC_SITE = http://download.ossystems.com.br/bsp/freescale/source
>   Eric> +LIBFSLCODEC_SITE = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/
>
> Maybe this should use FREESCALE_IMX_SITE
>

Agreed. I'm also confused about why this isn't in the freescale-imx/
directory.

>
>   Eric>  LIBFSLCODEC_SOURCE = libfslcodec-$(LIBFSLCODEC_VERSION).bin
>   Eric>  LIBFSLCODEC_LICENSE = Freescale Semiconductor Software License Agreement, BSD-3c (flac, ogg headers)
>   Eric>  LIBFSLCODEC_LICENSE_FILES = EULA EULA.txt
>   Eric> diff --git a/package/libfslparser/libfslparser.mk b/package/libfslparser/libfslparser.mk
>   Eric> index 3e27a6a..66068fe 100644
>   Eric> --- a/package/libfslparser/libfslparser.mk
>   Eric> +++ b/package/libfslparser/libfslparser.mk
>   Eric> @@ -4,9 +4,9 @@
>   Eric>  #
>   Eric>  ################################################################################
>
>   Eric> -LIBFSLPARSER_VERSION = 3.0.1
>   Eric> +LIBFSLPARSER_VERSION = 3.5.7-1.0.0
>   Eric>  # No official download site from freescale, just this mirror
>   Eric> -LIBFSLPARSER_SITE = http://download.ossystems.com.br/bsp/freescale/source
>   Eric> +LIBFSLPARSER_SITE = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/
>
> Same here (and comment dropped).
>
>
>   Eric>  LIBFSLPARSER_SOURCE = libfslparser-$(LIBFSLPARSER_VERSION).bin
>   Eric>  LIBFSLPARSER_LICENSE = Freescale Semiconductor Software License Agreement
>   Eric>  LIBFSLPARSER_LICENSE_FILES = EULA EULA.txt
>   Eric> @@ -31,7 +31,9 @@ define LIBFSLPARSER_EXTRACT_CMDS
>   Eric>  	     /<<EOEULA/ { start=1; }'\
>   Eric>  	    $(DL_DIR)/$(LIBFSLPARSER_SOURCE) > $(@D)/EULA
>   Eric>  	cd $(BUILD_DIR); \
>   Eric> -	sh $(DL_DIR)/$(LIBFSLPARSER_SOURCE) --force --auto-accept
>   Eric> +	sh $(DL_DIR)/$(LIBFSLPARSER_SOURCE) --force --auto-accept ; \
>   Eric> +	cd libfslparser-3.5.7-1.0.0; \
>   Eric> +	pwd && sh ./autogen.sh
>   Eric>  endef
>
> Why the pwd?
>

'Cause I was debugging ;)

> We do have generic autoreconf support in Buildroot. Normally you can
> just set:
>
>   LIBFSLPARSERS_AUTORECONF = YES
>
> And Buildroot will take care of building the proper auto* packages for
> the host and running autoreconf.
>

Thanks for the tip. I'll re-try with that bit.

>
>   Eric> +++ b/package/libfslvpuwrap/libfslvpuwrap.mk
>   Eric> @@ -4,9 +4,10 @@
>   Eric>  #
>   Eric>  ################################################################################
>
>   Eric> -LIBFSLVPUWRAP_VERSION = 1.0.17
>   Eric> +LIBFSLVPUWRAP_VERSION = 3.5.7-1.0.0
>   Eric>  # No official download site from freescale, just this mirror
>   Eric> -LIBFSLVPUWRAP_SITE = http://download.ossystems.com.br/bsp/freescale/source
>   Eric> +LIBFSLVPUWRAP_SITE = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/
>
> Same comment as elsewhere.
>
> Care to fix these issues and resubmit? Thanks.
>

Will do.

Regards,


Eric
Arnout Vandecappelle Oct. 1, 2013, 6:20 a.m. UTC | #3
On 09/26/13 22:41, Eric Nelson wrote:
> Hi Peter,
>
> On 09/26/2013 12:36 PM, Peter Korsgaard wrote:
>>>>>>> "Eric" == Eric Nelson <eric.nelson@boundarydevices.com> writes:
[snip]
>>   Eric> @@ -30,8 +34,6 @@ endif
>>   Eric>  # The archive is a shell-self-extractor of a bzipped tar. It happens
>>   Eric>  # to extract in the correct directory (gpu-viv-bin-mx6q-x.y.z)
>>   Eric>  # The --force makes sure it doesn't fail if the source dir already exists.
>>   Eric> -# The --auto-accept skips the license check - not needed for us
>>   Eric> -# because we have legal-info.
>>   Eric>  define GPU_VIV_BIN_MX6Q_EXTRACT_CMDS
>>   Eric>      (cd $(BUILD_DIR); \
>>   Eric>          sh $(DL_DIR)/$(GPU_VIV_BIN_MX6Q_SOURCE) --force --auto-accept)
>>
>> Did you remove this on purpose? If the --auto-accept option is gone then
>> it should also be removed from here.
>>
>
> I actually meant to, but hadn't yet started a discussion on the topic.
>
> We should be able to get rid of these comments:
>      http://git.buildroot.net/buildroot/tree/package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk#n15
>
> By following the lead of the meta-fsl-arm project and allowing the first
> of any packages with the Freescale EULA to prompt the user for
> acceptance, but I'm not sure how to accomplish that.
>
> In the Yocto world, a tag ("ACCEPT_FREESCALE_EULA") placed in local.conf
> is sufficient to bypass the prompt, which requires action by the user.

  We prefer to avoid that the build stops after half an hour or so 
because it is waiting for user input. Also, I don't see a reason why we 
have to explicitly ask the user to accept this license. If we do that, we 
should probably do the same for all the other packages.

  If we do want explicit acceptance, then it can be done similar to the 
Qt license, i.e. add a config option that enables the --auto-accept.


>
>>
>>   Eric> diff --git a/package/freescale-imx/imx-lib/imx-lib.mk
>> b/package/freescale-imx/imx-lib/imx-lib.mk
>>   Eric> index bd7e174..e3c29b1 100644
>>   Eric> --- a/package/freescale-imx/imx-lib/imx-lib.mk
>>   Eric> +++ b/package/freescale-imx/imx-lib/imx-lib.mk
>>   Eric> @@ -6,7 +6,8 @@
>>
>>   Eric>  IMX_LIB_VERSION = $(FREESCALE_IMX_VERSION)
>>   Eric>  IMX_LIB_SITE    = $(FREESCALE_IMX_MIRROR_SITE)
>>   Eric> -IMX_LIB_LICENSE = LGPLv2.1+
>>   Eric> +IMX_LIB_SOURCE = imx-lib-$(IMX_LIB_VERSION).bin
>>   Eric> +IMX_LIB_LICENSE = Freescale Semiconductor Software License
>> Agreement
>>   Eric>  # No license file included
>>
>> Sigh, back to self extracting binaries? :/
>>
>
> Yep. The tar-balls are gone. This one (imx-lib) is a bit misleading,
> since the extracted files say very clearly that all of the components
> are released under LGPL.

  In that case, the license is still LGPL. The EULA text specifies:

This Agreement does not concern your use of any files that
are subject to an "open source" software license, such as the Free
Software Foundation "General Public License," or "GNU GPL."

  Since only GPL stuff is included in imx-lib, the rest of the EULA 
essentially doesn't apply.

[snip]
>>   Eric> -LIBFSLCODEC_VERSION = 3.0.1
>>   Eric> +LIBFSLCODEC_VERSION = 3.5.7-1.0.0
>>   Eric>  # No official download site from freescale, just this mirror
>>   Eric> -LIBFSLCODEC_SITE =
>> http://download.ossystems.com.br/bsp/freescale/source
>>   Eric> +LIBFSLCODEC_SITE =
>> http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/
>>
>> Maybe this should use FREESCALE_IMX_SITE
>>
>
> Agreed. I'm also confused about why this isn't in the freescale-imx/
> directory.

  Because the libfslcodec fits in the multimedia libraries menu more than 
in the hardware handling menu.

  Note that it is not necessary to put the libfslcodec package under the 
freescale-imx directory for it to use the FREESCALE_IMX_SITE variable. At 
least, I think so :-)


  Regards,
  Arnout

[snip]
Eric Nelson Oct. 1, 2013, 2:07 p.m. UTC | #4
Hi Arnout,

On 09/30/2013 11:20 PM, Arnout Vandecappelle wrote:
> On 09/26/13 22:41, Eric Nelson wrote:
>> Hi Peter,
>>
>> On 09/26/2013 12:36 PM, Peter Korsgaard wrote:
>>>>>>>> "Eric" == Eric Nelson <eric.nelson@boundarydevices.com> writes:
> [snip]
>>>   Eric> @@ -30,8 +34,6 @@ endif
>>>   Eric>  # The archive is a shell-self-extractor of a bzipped tar. It
>>> happens
>>>   Eric>  # to extract in the correct directory (gpu-viv-bin-mx6q-x.y.z)
>>>   Eric>  # The --force makes sure it doesn't fail if the source dir
>>> already exists.
>>>   Eric> -# The --auto-accept skips the license check - not needed for us
>>>   Eric> -# because we have legal-info.
>>>   Eric>  define GPU_VIV_BIN_MX6Q_EXTRACT_CMDS
>>>   Eric>      (cd $(BUILD_DIR); \
>>>   Eric>          sh $(DL_DIR)/$(GPU_VIV_BIN_MX6Q_SOURCE) --force
>>> --auto-accept)
>>>
>>> Did you remove this on purpose? If the --auto-accept option is gone then
>>> it should also be removed from here.
>>>
>>
>> I actually meant to, but hadn't yet started a discussion on the topic.
>>
>> We should be able to get rid of these comments:
>>
>> http://git.buildroot.net/buildroot/tree/package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk#n15
>>
>>
>> By following the lead of the meta-fsl-arm project and allowing the first
>> of any packages with the Freescale EULA to prompt the user for
>> acceptance, but I'm not sure how to accomplish that.
>>
>> In the Yocto world, a tag ("ACCEPT_FREESCALE_EULA") placed in local.conf
>> is sufficient to bypass the prompt, which requires action by the user.
>
>   We prefer to avoid that the build stops after half an hour or so
> because it is waiting for user input. Also, I don't see a reason why we
> have to explicitly ask the user to accept this license. If we do that,
> we should probably do the same for all the other packages.
>
>   If we do want explicit acceptance, then it can be done similar to the
> Qt license, i.e. add a config option that enables the --auto-accept.
>

I'll take a whack at that, but it may take a week or so.

>>
>>>
>>>   Eric> diff --git a/package/freescale-imx/imx-lib/imx-lib.mk
>>> b/package/freescale-imx/imx-lib/imx-lib.mk
>>>   Eric> index bd7e174..e3c29b1 100644
>>>   Eric> --- a/package/freescale-imx/imx-lib/imx-lib.mk
>>>   Eric> +++ b/package/freescale-imx/imx-lib/imx-lib.mk
>>>   Eric> @@ -6,7 +6,8 @@
>>>
>>>   Eric>  IMX_LIB_VERSION = $(FREESCALE_IMX_VERSION)
>>>   Eric>  IMX_LIB_SITE    = $(FREESCALE_IMX_MIRROR_SITE)
>>>   Eric> -IMX_LIB_LICENSE = LGPLv2.1+
>>>   Eric> +IMX_LIB_SOURCE = imx-lib-$(IMX_LIB_VERSION).bin
>>>   Eric> +IMX_LIB_LICENSE = Freescale Semiconductor Software License
>>> Agreement
>>>   Eric>  # No license file included
>>>
>>> Sigh, back to self extracting binaries? :/
>>>
>>
>> Yep. The tar-balls are gone. This one (imx-lib) is a bit misleading,
>> since the extracted files say very clearly that all of the components
>> are released under LGPL.
>
>   In that case, the license is still LGPL. The EULA text specifies:
>
> This Agreement does not concern your use of any files that
> are subject to an "open source" software license, such as the Free
> Software Foundation "General Public License," or "GNU GPL."
>
>   Since only GPL stuff is included in imx-lib, the rest of the EULA
> essentially doesn't apply.
>

Right.

> [snip]
>>>   Eric> -LIBFSLCODEC_VERSION = 3.0.1
>>>   Eric> +LIBFSLCODEC_VERSION = 3.5.7-1.0.0
>>>   Eric>  # No official download site from freescale, just this mirror
>>>   Eric> -LIBFSLCODEC_SITE =
>>> http://download.ossystems.com.br/bsp/freescale/source
>>>   Eric> +LIBFSLCODEC_SITE =
>>> http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/
>>>
>>> Maybe this should use FREESCALE_IMX_SITE
>>>
>>
>> Agreed. I'm also confused about why this isn't in the freescale-imx/
>> directory.
>
>   Because the libfslcodec fits in the multimedia libraries menu more
> than in the hardware handling menu.
>

I'm not sure. It shows up under Packages/Libraries/Multimedia and I
found the packages difficult to locate.

>   Note that it is not necessary to put the libfslcodec package under the
> freescale-imx directory for it to use the FREESCALE_IMX_SITE variable.
> At least, I think so :-)
>

That variable (currently FREESCALE_IMX_MIRROR_SITE) is defined
in the parent makefile:
	http://git.buildroot.net/buildroot/tree/package/freescale-imx/freescale-imx.mk

... so it's not appropriate to include from the other tree.

Can you take a look at the more recent patch set? Things seem
much cleaner by having this all in the same tree.

Thanks,


Eric
Thomas Petazzoni Oct. 1, 2013, 7:42 p.m. UTC | #5
Dear Arnout Vandecappelle,

On Tue, 01 Oct 2013 08:20:47 +0200, Arnout Vandecappelle wrote:

> > By following the lead of the meta-fsl-arm project and allowing the first
> > of any packages with the Freescale EULA to prompt the user for
> > acceptance, but I'm not sure how to accomplish that.
> >
> > In the Yocto world, a tag ("ACCEPT_FREESCALE_EULA") placed in local.conf
> > is sufficient to bypass the prompt, which requires action by the user.
> 
>   We prefer to avoid that the build stops after half an hour or so 
> because it is waiting for user input. Also, I don't see a reason why we 
> have to explicitly ask the user to accept this license. If we do that, we 
> should probably do the same for all the other packages.
> 
>   If we do want explicit acceptance, then it can be done similar to the 
> Qt license, i.e. add a config option that enables the --auto-accept.

Agreed.

> > Agreed. I'm also confused about why this isn't in the freescale-imx/
> > directory.
> 
>   Because the libfslcodec fits in the multimedia libraries menu more than 
> in the hardware handling menu.

I don't quite agree here. The location of the package in the menu has
nothing to do with the location of the package .mk file and directory.
So if the libfslcodec is downloaded from the same site and with the
same version as the other package/freescale-imx/ stuff and therefore
re-use the same variables, it could very well be moved under this
directory.

Best regards,

Thomas
diff mbox

Patch

diff --git a/package/freescale-imx/freescale-imx.mk b/package/freescale-imx/freescale-imx.mk
index d35a62e..42ef11c 100644
--- a/package/freescale-imx/freescale-imx.mk
+++ b/package/freescale-imx/freescale-imx.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-FREESCALE_IMX_VERSION = 1.1.0
+FREESCALE_IMX_VERSION = 3.5.7-1.0.0
 
 # No official download site from freescale, just this mirror
-FREESCALE_IMX_MIRROR_SITE   = http://download.ossystems.com.br/bsp/freescale/source
+FREESCALE_IMX_MIRROR_SITE   = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/
 
 include $(sort $(wildcard package/freescale-imx/*/*.mk))
diff --git a/package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk b/package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk
index c48d108..499f617 100644
--- a/package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk
+++ b/package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk
@@ -3,8 +3,12 @@ 
 # gpu-viv-bin-mx6q
 #
 ################################################################################
+ifeq ($(BR2_ARM_EABIHF),y)
+GPU_VIV_BIN_MX6Q_VERSION = $(FREESCALE_IMX_VERSION)-hfp
+else
+GPU_VIV_BIN_MX6Q_VERSION = $(FREESCALE_IMX_VERSION)-sfp
+endif
 
-GPU_VIV_BIN_MX6Q_VERSION = $(FREESCALE_IMX_VERSION)
 GPU_VIV_BIN_MX6Q_SITE    = $(FREESCALE_IMX_MIRROR_SITE)
 GPU_VIV_BIN_MX6Q_SOURCE  = gpu-viv-bin-mx6q-$(GPU_VIV_BIN_MX6Q_VERSION).bin
 
@@ -30,8 +34,6 @@  endif
 # The archive is a shell-self-extractor of a bzipped tar. It happens
 # to extract in the correct directory (gpu-viv-bin-mx6q-x.y.z)
 # The --force makes sure it doesn't fail if the source dir already exists.
-# The --auto-accept skips the license check - not needed for us
-# because we have legal-info.
 define GPU_VIV_BIN_MX6Q_EXTRACT_CMDS
 	(cd $(BUILD_DIR); \
 		sh $(DL_DIR)/$(GPU_VIV_BIN_MX6Q_SOURCE) --force --auto-accept)
diff --git a/package/freescale-imx/imx-lib/imx-lib.mk b/package/freescale-imx/imx-lib/imx-lib.mk
index bd7e174..e3c29b1 100644
--- a/package/freescale-imx/imx-lib/imx-lib.mk
+++ b/package/freescale-imx/imx-lib/imx-lib.mk
@@ -6,7 +6,8 @@ 
 
 IMX_LIB_VERSION = $(FREESCALE_IMX_VERSION)
 IMX_LIB_SITE    = $(FREESCALE_IMX_MIRROR_SITE)
-IMX_LIB_LICENSE = LGPLv2.1+
+IMX_LIB_SOURCE = imx-lib-$(IMX_LIB_VERSION).bin
+IMX_LIB_LICENSE = Freescale Semiconductor Software License Agreement
 # No license file included
 
 IMX_LIB_INSTALL_STAGING = YES
@@ -25,6 +26,14 @@  IMX_LIB_MAKE_ENV = \
 	PLATFORM=$(BR2_PACKAGE_IMX_LIB_PLATFORM) \
 	INCLUDE="$(IMX_LIB_INCLUDE)"
 
+# The archive is a shell-self-extractor of a bzipped tar. It happens
+# to extract in the correct directory (imx-lib-x.y.z)
+# The --force makes sure it doesn't fail if the source dir already exists.
+define IMX_LIB_EXTRACT_CMDS
+	(cd $(BUILD_DIR); \
+		sh $(DL_DIR)/$(IMX_LIB_SOURCE) --force --auto-accept)
+endef
+
 define IMX_LIB_BUILD_CMDS
 	$(IMX_LIB_MAKE_ENV) $(MAKE1) -C $(@D)
 endef
diff --git a/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk b/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk
index ccdb521..c46073d 100644
--- a/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk
+++ b/package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-GST_FSL_PLUGINS_VERSION = 3.0.1
+GST_FSL_PLUGINS_VERSION = 3.5.7-1.0.0
 # No official download site from freescale, just this mirror
-GST_FSL_PLUGINS_SITE = http://download.ossystems.com.br/bsp/freescale/source
+GST_FSL_PLUGINS_SITE = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/
 
 # Most is LGPLv2+, but some sources are copied from upstream and are
 # LGPLv2.1+, which essentially makes it LGPLv2.1+
diff --git a/package/libfslcodec/libfslcodec.mk b/package/libfslcodec/libfslcodec.mk
index c18332a..b1991f8 100644
--- a/package/libfslcodec/libfslcodec.mk
+++ b/package/libfslcodec/libfslcodec.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-LIBFSLCODEC_VERSION = 3.0.1
+LIBFSLCODEC_VERSION = 3.5.7-1.0.0
 # No official download site from freescale, just this mirror
-LIBFSLCODEC_SITE = http://download.ossystems.com.br/bsp/freescale/source
+LIBFSLCODEC_SITE = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/
 LIBFSLCODEC_SOURCE = libfslcodec-$(LIBFSLCODEC_VERSION).bin
 LIBFSLCODEC_LICENSE = Freescale Semiconductor Software License Agreement, BSD-3c (flac, ogg headers)
 LIBFSLCODEC_LICENSE_FILES = EULA EULA.txt
diff --git a/package/libfslparser/libfslparser.mk b/package/libfslparser/libfslparser.mk
index 3e27a6a..66068fe 100644
--- a/package/libfslparser/libfslparser.mk
+++ b/package/libfslparser/libfslparser.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-LIBFSLPARSER_VERSION = 3.0.1
+LIBFSLPARSER_VERSION = 3.5.7-1.0.0
 # No official download site from freescale, just this mirror
-LIBFSLPARSER_SITE = http://download.ossystems.com.br/bsp/freescale/source
+LIBFSLPARSER_SITE = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/
 LIBFSLPARSER_SOURCE = libfslparser-$(LIBFSLPARSER_VERSION).bin
 LIBFSLPARSER_LICENSE = Freescale Semiconductor Software License Agreement
 LIBFSLPARSER_LICENSE_FILES = EULA EULA.txt
@@ -31,7 +31,9 @@  define LIBFSLPARSER_EXTRACT_CMDS
 	     /<<EOEULA/ { start=1; }'\
 	    $(DL_DIR)/$(LIBFSLPARSER_SOURCE) > $(@D)/EULA
 	cd $(BUILD_DIR); \
-	sh $(DL_DIR)/$(LIBFSLPARSER_SOURCE) --force --auto-accept
+	sh $(DL_DIR)/$(LIBFSLPARSER_SOURCE) --force --auto-accept ; \
+	cd libfslparser-3.5.7-1.0.0; \
+	pwd && sh ./autogen.sh
 endef
 
 # The Makefile installs several versions of the libraries, but we only
diff --git a/package/libfslvpuwrap/libfslvpuwrap.mk b/package/libfslvpuwrap/libfslvpuwrap.mk
index 1bc7129..cf11968 100644
--- a/package/libfslvpuwrap/libfslvpuwrap.mk
+++ b/package/libfslvpuwrap/libfslvpuwrap.mk
@@ -4,9 +4,10 @@ 
 #
 ################################################################################
 
-LIBFSLVPUWRAP_VERSION = 1.0.17
+LIBFSLVPUWRAP_VERSION = 3.5.7-1.0.0
 # No official download site from freescale, just this mirror
-LIBFSLVPUWRAP_SITE = http://download.ossystems.com.br/bsp/freescale/source
+LIBFSLVPUWRAP_SITE = http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/
+LIBFSLVPUWRAP_SOURCE = libfslvpuwrap-$(LIBFSLVPUWRAP_VERSION).bin
 LIBFSLVPUWRAP_LICENSE = Freescale Semiconductor Software License Agreement
 LIBFSLVPUWRAP_LICENSE_FILES = EULA.txt
 LIBFSLVPUWRAP_REDISTRIBUTE = NO
@@ -15,4 +16,21 @@  LIBFSLVPUWRAP_INSTALL_STAGING = YES
 
 LIBFSLVPUWRAP_DEPENDENCIES += imx-lib
 
+# The archive is a shell-self-extractor of a bzipped tar. It happens
+# to extract in the correct directory (libfslvpuwrap-x.y.z)
+# The --force makes sure it doesn't fail if the source dir already exists.
+# The --auto-accept skips the license check - not needed for us
+# because we have legal-info
+# Since the EULA in the bin file differs from the one in the tar file,
+# extract the one from the bin file as well.
+define LIBFSLVPUWRAP_EXTRACT_CMDS
+	awk 'BEGIN      { start=0; } \
+	     /^EOEULA/  { start = 0; } \
+	                { if (start) print; } \
+	     /<<EOEULA/ { start=1; }'\
+	    $(DL_DIR)/$(LIBFSLVPUWRAP_SOURCE) > $(@D)/EULA
+	cd $(BUILD_DIR); \
+	sh $(DL_DIR)/$(LIBFSLVPUWRAP_SOURCE) --force --auto-accept
+endef
+
 $(eval $(autotools-package))