diff mbox

[1/1,v2] Hide issue and hostname menu when using a custom skeleton.

Message ID 1358102400-9628-1-git-send-email-sagaert.johan@skynet.be
State Changes Requested
Headers show

Commit Message

Sagaert Johan Jan. 13, 2013, 6:39 p.m. UTC
Only show hostname and issue options when the default skeleton is selected.
Moved the menu sections so that when a custom skeleton is selected the 
issue and hostname options are hidden.

Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be>
---
 v2 : Only hide issue and hostname menu when a custom skeleton is selected.

 system/Config.in | 24 ++++++++++++------------
 1 file changed, 12 insertions(+), 12 deletions(-)

Comments

Thomas Petazzoni Aug. 13, 2013, 10:11 p.m. UTC | #1
Gustavo, Yann, Thomas, Arnout,

What do you think of the below patch?

My main concern is that it handles the case of /etc/issue
and /etc/hostname, but I see potentially other "System configuration"
parameters that may conflict with a custom skeleton.

Thoughts?

Thomas

On Sun, 13 Jan 2013 19:39:59 +0100, Sagaert Johan wrote:
> 
> Only show hostname and issue options when the default skeleton is selected.
> Moved the menu sections so that when a custom skeleton is selected the 
> issue and hostname options are hidden.
> 
> Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be>
> ---
>  v2 : Only hide issue and hostname menu when a custom skeleton is selected.
> 
>  system/Config.in | 24 ++++++++++++------------
>  1 file changed, 12 insertions(+), 12 deletions(-)
> 
> diff --git a/system/Config.in b/system/Config.in
> index 69863c4..5b38cae 100644
> --- a/system/Config.in
> +++ b/system/Config.in
> @@ -1,17 +1,5 @@
>  menu "System configuration"
>  
> -config BR2_TARGET_GENERIC_HOSTNAME
> -       string "System hostname"
> -       default "buildroot"
> -       help
> -         Select system hostname to be stored in /etc/hostname.
> -
> -config BR2_TARGET_GENERIC_ISSUE
> -       string "System banner"
> -       default "Welcome to Buildroot"
> -       help
> -         Select system banner (/etc/issue) to be displayed at login.
> -
>  choice
>  	bool "Passwords encoding"
>  	default BR2_TARGET_GENERIC_PASSWD_MD5
> @@ -173,6 +161,18 @@ endif
>  
>  if BR2_ROOTFS_SKELETON_DEFAULT
>  
> +config BR2_TARGET_GENERIC_HOSTNAME
> +       string "System hostname"
> +       default "buildroot"
> +       help
> +         Select system hostname to be stored in /etc/hostname.
> +
> +config BR2_TARGET_GENERIC_ISSUE
> +       string "System banner"
> +       default "Welcome to Buildroot"
> +       help
> +         Select system banner (/etc/issue) to be displayed at login.
> +
>  config BR2_TARGET_GENERIC_ROOT_PASSWD
>  	string "Root password"
>  	default ""
Yann E. MORIN Aug. 13, 2013, 10:29 p.m. UTC | #2
Thomas, All,

On 2013-08-14 00:11 +0200, Thomas Petazzoni spake thusly:
> Gustavo, Yann, Thomas, Arnout,
> 
> What do you think of the below patch?

I think the idea behind the patch is valid.

However, I've not teted it, so I can't say if the patch is OK or not.
With a simple look at system/system.mk, it seems it would work as
expected.

> My main concern is that it handles the case of /etc/issue
> and /etc/hostname, but I see potentially other "System configuration"
> parameters that may conflict with a custom skeleton.
> 
> Thoughts?

I'd say, we should take it, and if some other "System configuration"
items need to be guarded behind BR2_ROOTFS_SKELETON_DEFAULT, we can
still move them later when the need arises.
 
> Thomas
> 
> On Sun, 13 Jan 2013 19:39:59 +0100, Sagaert Johan wrote:
> > 
> > Only show hostname and issue options when the default skeleton is selected.
> > Moved the menu sections so that when a custom skeleton is selected the 
> > issue and hostname options are hidden.
> > 
> > Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be>
> > ---
> >  v2 : Only hide issue and hostname menu when a custom skeleton is selected.
> > 
> >  system/Config.in | 24 ++++++++++++------------
> >  1 file changed, 12 insertions(+), 12 deletions(-)
> > 
> > diff --git a/system/Config.in b/system/Config.in
> > index 69863c4..5b38cae 100644
> > --- a/system/Config.in
> > +++ b/system/Config.in
> > @@ -1,17 +1,5 @@
> >  menu "System configuration"
> >  
> > -config BR2_TARGET_GENERIC_HOSTNAME
> > -       string "System hostname"
> > -       default "buildroot"
> > -       help
> > -         Select system hostname to be stored in /etc/hostname.
> > -
> > -config BR2_TARGET_GENERIC_ISSUE
> > -       string "System banner"
> > -       default "Welcome to Buildroot"
> > -       help
> > -         Select system banner (/etc/issue) to be displayed at login.
> > -
> >  choice
> >  	bool "Passwords encoding"
> >  	default BR2_TARGET_GENERIC_PASSWD_MD5
> > @@ -173,6 +161,18 @@ endif
> >  
> >  if BR2_ROOTFS_SKELETON_DEFAULT
> >  
> > +config BR2_TARGET_GENERIC_HOSTNAME
> > +       string "System hostname"
> > +       default "buildroot"
> > +       help
> > +         Select system hostname to be stored in /etc/hostname.
> > +
> > +config BR2_TARGET_GENERIC_ISSUE
> > +       string "System banner"
> > +       default "Welcome to Buildroot"
> > +       help
> > +         Select system banner (/etc/issue) to be displayed at login.
> > +
> >  config BR2_TARGET_GENERIC_ROOT_PASSWD
> >  	string "Root password"
> >  	default ""
> 
> 
> 
> -- 
> Thomas Petazzoni, Free Electrons
> Kernel, drivers, real-time and embedded Linux
> development, consulting, training and support.
> http://free-electrons.com
Gustavo Zacarias Aug. 14, 2013, 12:37 p.m. UTC | #3
On 08/13/2013 07:11 PM, Thomas Petazzoni wrote:

> Gustavo, Yann, Thomas, Arnout,
> 
> What do you think of the below patch?
> 
> My main concern is that it handles the case of /etc/issue
> and /etc/hostname, but I see potentially other "System configuration"
> parameters that may conflict with a custom skeleton.
> 
> Thoughts?

+1 to what Yann said.
Haven't tested it's working properly yet but the principle is fine.
The "Root FS skeleton" option should probably be moved to the top,
otherwise a lower option is afecting top ones - a hierarchy/look thing.
Regards.
Yann E. MORIN Jan. 5, 2014, 5:41 p.m. UTC | #4
Sagaert, All,

On 2013-01-13 19:39 +0100, Sagaert Johan spake thusly:
> Only show hostname and issue options when the default skeleton is selected.
> Moved the menu sections so that when a custom skeleton is selected the 
> issue and hostname options are hidden.

After fiddling with the idea, I believe we should not do it that way.

It can well happen that a custom skeleton does not already have an
hostname or issue file, and we may want to create either or both in this
case.

So I think we should do it differently:

    config BR2_TARGET_GENERIC_HOSTNAME
        string "System hostname"
        default "buildroot" if BR2_ROOTFS_SKELETON_DEFAULT
        default ""          if ! BR2_ROOTFS_SKELETON_DEFAULT
        help
          Select system hostname to be stored in /etc/hostname.
          Leave empty to not create /etc/hostname, or to keep the
          one from a custom skeleton.

And system/system.mk already ensures we do not create /etc/hostname if
BR2_TARGET_GENERIC_HOSTNAME is empty.

That way, the default is correct in both cases, and it is still possible
to create/override hostname and issue for a custom skeleton.

(Ditto for /etc/issue).

Thoughts?

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/system/Config.in b/system/Config.in
index 69863c4..5b38cae 100644
--- a/system/Config.in
+++ b/system/Config.in
@@ -1,17 +1,5 @@ 
 menu "System configuration"
 
-config BR2_TARGET_GENERIC_HOSTNAME
-       string "System hostname"
-       default "buildroot"
-       help
-         Select system hostname to be stored in /etc/hostname.
-
-config BR2_TARGET_GENERIC_ISSUE
-       string "System banner"
-       default "Welcome to Buildroot"
-       help
-         Select system banner (/etc/issue) to be displayed at login.
-
 choice
 	bool "Passwords encoding"
 	default BR2_TARGET_GENERIC_PASSWD_MD5
@@ -173,6 +161,18 @@  endif
 
 if BR2_ROOTFS_SKELETON_DEFAULT
 
+config BR2_TARGET_GENERIC_HOSTNAME
+       string "System hostname"
+       default "buildroot"
+       help
+         Select system hostname to be stored in /etc/hostname.
+
+config BR2_TARGET_GENERIC_ISSUE
+       string "System banner"
+       default "Welcome to Buildroot"
+       help
+         Select system banner (/etc/issue) to be displayed at login.
+
 config BR2_TARGET_GENERIC_ROOT_PASSWD
 	string "Root password"
 	default ""