diff mbox

python: firefox host-python dependency needs --enable-unicodedata

Message ID 1345057226-18726-2-git-send-email-stefan.froberg@petroprogram.com
State Changes Requested
Headers show

Commit Message

Stefan Fröberg Aug. 15, 2012, 7 p.m. UTC
Signed-off-by: Stefan Froberg <stefan.froberg@petroprogram.com>
---
 package/python/python.mk |    8 +++++++-
 1 files changed, 7 insertions(+), 1 deletions(-)

Comments

Thomas Petazzoni Aug. 21, 2012, 11:23 a.m. UTC | #1
Le Wed, 15 Aug 2012 22:00:26 +0300,
Stefan Froberg <stefan.froberg@petroprogram.com> a écrit :

> +ifneq ($(BR2_PACKAGE_PYTHON_UNICODEDATA),y)
> +	HOST_PYTHON_CONF_OPT += --disable-unicodedata	
> +else
> +	HOST_PYTHON_CONF_OPT += --enable-unicodedata
> +endif

No, this is not correct. The BR2_PACKAGE_* options are here to
configure the *target* packages. Host packages that are only
dependencies to build target packages do not have kconfig options. So
in this case, the only solution is to simply use --enable-unicodedata
unconditionally to the host-python build.

Can you post an updated patch with this change?

Thanks,

Thomas
Stefan Fröberg Aug. 21, 2012, 1:37 p.m. UTC | #2
Hello Thomas

21.8.2012 14:23, Thomas Petazzoni kirjoitti:
> Le Wed, 15 Aug 2012 22:00:26 +0300,
> Stefan Froberg <stefan.froberg@petroprogram.com> a écrit :
>
>> +ifneq ($(BR2_PACKAGE_PYTHON_UNICODEDATA),y)
>> +	HOST_PYTHON_CONF_OPT += --disable-unicodedata	
>> +else
>> +	HOST_PYTHON_CONF_OPT += --enable-unicodedata
>> +endif
> No, this is not correct. The BR2_PACKAGE_* options are here to
> configure the *target* packages. Host packages that are only
> dependencies to build target packages do not have kconfig options. So
> in this case, the only solution is to simply use --enable-unicodedata
> unconditionally to the host-python build.

Oh, sorry.
I was just trying to be carefull and not to mess with host-python too much.

>
> Can you post an updated patch with this change?

No problem. I will cook a new lil patch and resend.


By the way Thomas, what do you think about these two little changes to
SQLite and Valgrind ?

http://lists.busybox.net/pipermail/buildroot/2012-August/057377.html

http://lists.busybox.net/pipermail/buildroot/2012-August/057379.html


I also noticed that you accepted yasm and that little cairo patch for
next version.
Thank you!

Stefan

> Thanks,
>
> Thomas
diff mbox

Patch

diff --git a/package/python/python.mk b/package/python/python.mk
index fae4e5c..805e40c 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -22,7 +22,6 @@  HOST_PYTHON_CONF_OPT += 	\
 	--disable-curses	\
 	--disable-codecs-cjk	\
 	--disable-nis		\
-	--disable-unicodedata	\
 	--disable-dbm		\
 	--disable-gdbm		\
 	--disable-bsddb		\
@@ -30,6 +29,13 @@  HOST_PYTHON_CONF_OPT += 	\
 	--disable-bz2		\
 	--disable-ssl
 
+ifneq ($(BR2_PACKAGE_PYTHON_UNICODEDATA),y)
+	HOST_PYTHON_CONF_OPT += --disable-unicodedata	
+else
+	HOST_PYTHON_CONF_OPT += --enable-unicodedata
+endif
+
+
 HOST_PYTHON_MAKE_ENV = \
 	PYTHON_MODULES_INCLUDE=$(HOST_DIR)/usr/include \
 	PYTHON_MODULES_LIB="$(HOST_DIR)/lib $(HOST_DIR)/usr/lib"