diff mbox

[2/5] lua : don't install static library in target

Message ID 1342446352-31231-2-git-send-email-francois.perrad@gadz.org
State Rejected
Headers show

Commit Message

Francois Perrad July 16, 2012, 1:45 p.m. UTC
---
 package/lua/lua.mk |    5 -----
 1 file changed, 5 deletions(-)

Comments

Thomas Petazzoni July 16, 2012, 3:41 p.m. UTC | #1
Le Mon, 16 Jul 2012 15:45:49 +0200,
Francois Perrad <fperrad@gmail.com> a écrit :

> ---
>  package/lua/lua.mk |    5 -----
>  1 file changed, 5 deletions(-)
> 
> diff --git a/package/lua/lua.mk b/package/lua/lua.mk
> index 2fc838b..ab9a1a2 100644
> --- a/package/lua/lua.mk
> +++ b/package/lua/lua.mk
> @@ -79,11 +79,6 @@ define LUA_INSTALL_LIBRARY
>  	$(INSTALL) $(@D)/src/liblua.so.$(LUA_VERSION) \
>  		$(TARGET_DIR)/usr/lib/liblua.so.$(LUA_VERSION)
>  	ln -sf liblua.so.$(LUA_VERSION)
> $(TARGET_DIR)/usr/lib/liblua.so
> -	$(INSTALL) $(@D)/src/liblua.a $(TARGET_DIR)/usr/lib/liblua.a
> -endef
> -else
> -define LUA_INSTALL_LIBRARY
> -	$(INSTALL) $(@D)/src/liblua.a $(TARGET_DIR)/usr/lib/liblua.a
>  endef
>  endif

Well, even though not respected by all packages, the rule is normally
to install all .a, .h files and everything to the target, since the
target-finalize thing in the Makefile gets rid of .h and .a files when
BR2_HAVE_DEVFILES is not selected.

Regards,

Thomas
diff mbox

Patch

diff --git a/package/lua/lua.mk b/package/lua/lua.mk
index 2fc838b..ab9a1a2 100644
--- a/package/lua/lua.mk
+++ b/package/lua/lua.mk
@@ -79,11 +79,6 @@  define LUA_INSTALL_LIBRARY
 	$(INSTALL) $(@D)/src/liblua.so.$(LUA_VERSION) \
 		$(TARGET_DIR)/usr/lib/liblua.so.$(LUA_VERSION)
 	ln -sf liblua.so.$(LUA_VERSION) $(TARGET_DIR)/usr/lib/liblua.so
-	$(INSTALL) $(@D)/src/liblua.a $(TARGET_DIR)/usr/lib/liblua.a
-endef
-else
-define LUA_INSTALL_LIBRARY
-	$(INSTALL) $(@D)/src/liblua.a $(TARGET_DIR)/usr/lib/liblua.a
 endef
 endif