diff mbox series

[5/5,v3] package/pkg-golang: host-go is also a build dependency

Message ID 11477_1644506977_62052F61_11477_142_1_1cfdf4aa3ac96d2d2cf246385325f93b451d773b.1644506959.git.yann.morin@orange.com
State Accepted
Headers show
Series [1/5,v3] package/pkg-cargo: allow packages to define download environment | expand

Commit Message

Yann E. MORIN Feb. 10, 2022, 3:29 p.m. UTC
From: "Yann E. MORIN" <yann.morin@orange.com>

Currently, host-go is a download dependency, because we need go for the
vendoring during the download step.

However, when using a package in override-srcdir, there is no download
step, so host-go is not pulled in as a dependency, which will break the
build of a single package from scratch.

We fix that by adding host-go as a standard dependency too.

Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: Christian Stewart <christian@paral.in>
Cc: Anisse Astier <anisse@astier.eu>
Acked-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Reviewed-by: Christian Stewart <christian@paral.in>
---
 package/pkg-golang.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard March 7, 2022, 9:08 p.m. UTC | #1
>>>>>   <yann.morin@orange.com> writes:

 > From: "Yann E. MORIN" <yann.morin@orange.com>
 > Currently, host-go is a download dependency, because we need go for the
 > vendoring during the download step.

 > However, when using a package in override-srcdir, there is no download
 > step, so host-go is not pulled in as a dependency, which will break the
 > build of a single package from scratch.

 > We fix that by adding host-go as a standard dependency too.

 > Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
 > Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
 > Cc: Christian Stewart <christian@paral.in>
 > Cc: Anisse Astier <anisse@astier.eu>
 > Acked-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
 > Reviewed-by: Christian Stewart <christian@paral.in>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/pkg-golang.mk b/package/pkg-golang.mk
index 69eae02830..ddefdf1214 100644
--- a/package/pkg-golang.mk
+++ b/package/pkg-golang.mk
@@ -47,8 +47,10 @@  $(2)_BUILD_OPTS += \
 	-trimpath \
 	-p $(PARALLEL_JOBS)
 
-# Target packages need the Go compiler on the host.
+# Target packages need the Go compiler on the host at download time (for
+# vendoring), and at build and install time.
 $(2)_DOWNLOAD_DEPENDENCIES += host-go
+$(2)_DEPENDENCIES += host-go
 
 $(2)_BUILD_TARGETS ?= .