diff mbox series

[4/5,v3] package/pkg-golang: allow packages to define download environment

Message ID 1449_1644506975_62052F5F_1449_399_1_68889e1f1d960c99ade7457d58a115bf955a7b64.1644506959.git.yann.morin@orange.com
State Accepted
Headers show
Series [1/5,v3] package/pkg-cargo: allow packages to define download environment | expand

Commit Message

Yann E. MORIN Feb. 10, 2022, 3:29 p.m. UTC
From: "Yann E. MORIN" <yann.morin@orange.com>

Currently, the golang infrastructure forcibly sets the package _DL_ENV
variable, instead of appending to it, which prevents packages from
providing their own download environment variables.

We fix that by using an append-assignment.

Note: when introduced, that variable was explicitly not documented, and
is supposed to only be used by packages infrastructures. However, that
variable exists, and it can be (ab)used by br2-external packages (most
probably to ill effects, but heh!). We anyway leave it undocumented,
like _ROOTFS_PRE_CMD_HOOKS.

Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: Christian Stewart <christian@paral.in>
Cc: Anisse Astier <anisse@astier.eu>
Acked-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Reviewed-by: Christian Stewart <christian@paral.in>
---
 package/pkg-golang.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard March 7, 2022, 9:07 p.m. UTC | #1
>>>>>   <yann.morin@orange.com> writes:

 > From: "Yann E. MORIN" <yann.morin@orange.com>
 > Currently, the golang infrastructure forcibly sets the package _DL_ENV
 > variable, instead of appending to it, which prevents packages from
 > providing their own download environment variables.

 > We fix that by using an append-assignment.

 > Note: when introduced, that variable was explicitly not documented, and
 > is supposed to only be used by packages infrastructures. However, that
 > variable exists, and it can be (ab)used by br2-external packages (most
 > probably to ill effects, but heh!). We anyway leave it undocumented,
 > like _ROOTFS_PRE_CMD_HOOKS.

 > Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
 > Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
 > Cc: Christian Stewart <christian@paral.in>
 > Cc: Anisse Astier <anisse@astier.eu>
 > Acked-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
 > Reviewed-by: Christian Stewart <christian@paral.in>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/pkg-golang.mk b/package/pkg-golang.mk
index 35bcb1673b..69eae02830 100644
--- a/package/pkg-golang.mk
+++ b/package/pkg-golang.mk
@@ -83,7 +83,7 @@  endef
 $(2)_POST_PATCH_HOOKS += $(2)_GEN_GOMOD
 
 $(2)_DOWNLOAD_POST_PROCESS = go
-$(2)_DL_ENV = \
+$(2)_DL_ENV += \
 	$(HOST_GO_COMMON_ENV) \
 	GOPROXY=direct \
 	BR_GOMOD=$$($(2)_GOMOD)