[2/2] toolchain/gcc: the ARC version of gcc needs host-flex/host-bison

Submitted by Thomas Petazzoni on May 9, 2013, 3:53 p.m.


Message ID 1368114785-14666-2-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Commit 7c6232658a61c33d4746ace8f479916f957a5a6b
Headers show

Commit Message

Thomas Petazzoni May 9, 2013, 3:53 p.m.
For some reason (probably because the ARC changes modify some lex/yacc
files without updating their pre-generated variants, or because the
date/time of the pre-generated files is not correct), building the ARC
gcc requires host-flex and host-bison.

We have tested 4.2 for AVR, 4.3 and 4.4 for ARM, and none of those
need host-flex or host-bison to be installed, so only the 4.4 for ARC
seems to be affected.

Fixes the build failure visible at

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
 toolchain/gcc/gcc-uclibc-4.x.mk |    4 ++++
 1 file changed, 4 insertions(+)

Patch hide | download patch | download mbox

diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 8cacc32..21679ef 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -180,6 +180,10 @@  endif
 GCC_HOST_PREREQ += host-mpc
+ifeq ($(BR2_GCC_VERSION_4_4_7_ARC),y)
+GCC_HOST_PREREQ += host-flex host-bison
 ifeq ($(BR2_GCC_SHARED_LIBGCC),y)