Patchwork mplayer: not supported on sh4a/sh4aeb

mail settings
Submitter Thomas Petazzoni
Date Sept. 19, 2012, 8:42 p.m.
Message ID <>
Download mbox | patch
Permalink /patch/185221/
State Accepted
Commit 14af091234840bf22f240b66bcb78da00950f8f8
Headers show


Thomas Petazzoni - Sept. 19, 2012, 8:42 p.m.
The mplayer configure script says that sh4a is not supported,
according to:

Apparently, sh4 is supported, but not sh4a, even though it seems that
sh4a is a super-set of sh4. So it would probably not be too difficult
to get mplayer to build/work for sh4a, but we don't have hardware to
test this easily, and we can leave this work to the first developer
who will need mplayer on sh4a: let's only support what the upstream
package supports.

Signed-off-by: Thomas Petazzoni <>
 package/multimedia/mplayer/ |    3 +++
 1 file changed, 3 insertions(+)
Peter Korsgaard - Sept. 20, 2012, 12:10 p.m.
>>>>> "Thomas" == Thomas Petazzoni <> writes:

 Thomas> The mplayer configure script says that sh4a is not supported,
 Thomas> according to:

Committed, thanks.


diff --git a/package/multimedia/mplayer/ b/package/multimedia/mplayer/
index a9a4bb6..77bf9dc 100644
--- a/package/multimedia/mplayer/
+++ b/package/multimedia/mplayer/
@@ -1,5 +1,8 @@ 
 	bool "mplayer"
+	# "Error: unsupported architecture sh4a" says mplayer
+	# configure script.
+	depends on !BR2_sh4a && !BR2_sh4aeb
 	  MPlayer is a movie player which runs on many systems and supports
 	  many different file formats.