diff mbox series

[05/11] powerpc/powernv/ioda: Find opencapi slot for a device node

Message ID 20190909154600.19917-6-fbarrat@linux.ibm.com (mailing list archive)
State Superseded
Headers show
Series opencapi: enable card reset and link retraining | expand

Checks

Context Check Description
snowpatch_ozlabs/apply_patch success Successfully applied on branch next (c317052c95bef1f977b023158e5aa929215f443d)
snowpatch_ozlabs/checkpatch success total: 0 errors, 0 warnings, 0 checks, 34 lines checked

Commit Message

Frederic Barrat Sept. 9, 2019, 3:45 p.m. UTC
Unlike real PCI slots, opencapi slots are directly associated to
the (virtual) opencapi PHB, there's no intermediate bridge. So when
looking for a slot ID, we must start the search from the device node
itself and not its parent.

Also, the slot ID is not attached to a specific bdfn, so let's build
it from the PHB ID, like skiboot.

Signed-off-by: Frederic Barrat <fbarrat@linux.ibm.com>
---
 arch/powerpc/include/asm/pnv-pci.h   |  1 +
 arch/powerpc/platforms/powernv/pci.c | 10 +++++++---
 2 files changed, 8 insertions(+), 3 deletions(-)

Comments

Alastair D'Silva Sept. 10, 2019, 12:57 a.m. UTC | #1
On Mon, 2019-09-09 at 17:45 +0200, Frederic Barrat wrote:
> Unlike real PCI slots, opencapi slots are directly associated to
> the (virtual) opencapi PHB, there's no intermediate bridge. So when
> looking for a slot ID, we must start the search from the device node
> itself and not its parent.
> 
> Also, the slot ID is not attached to a specific bdfn, so let's build
> it from the PHB ID, like skiboot.
> 
> Signed-off-by: Frederic Barrat <fbarrat@linux.ibm.com>
> ---
>  arch/powerpc/include/asm/pnv-pci.h   |  1 +
>  arch/powerpc/platforms/powernv/pci.c | 10 +++++++---
>  2 files changed, 8 insertions(+), 3 deletions(-)
> 
> diff --git a/arch/powerpc/include/asm/pnv-pci.h
> b/arch/powerpc/include/asm/pnv-pci.h
> index edcb1fc50aeb..d0ee0ede5767 100644
> --- a/arch/powerpc/include/asm/pnv-pci.h
> +++ b/arch/powerpc/include/asm/pnv-pci.h
> @@ -15,6 +15,7 @@
>  #define PCI_SLOT_ID_PREFIX	(1UL << 63)
>  #define PCI_SLOT_ID(phb_id, bdfn)	\
>  	(PCI_SLOT_ID_PREFIX | ((uint64_t)(bdfn) << 16) | (phb_id))
> +#define PCI_PHB_SLOT_ID(phb_id)		(phb_id)
>  
>  extern int pnv_pci_get_slot_id(struct device_node *np, uint64_t
> *id);
>  extern int pnv_pci_get_device_tree(uint32_t phandle, void *buf,
> uint64_t len);
> diff --git a/arch/powerpc/platforms/powernv/pci.c
> b/arch/powerpc/platforms/powernv/pci.c
> index 6104418c9ad5..00a79f3c989f 100644
> --- a/arch/powerpc/platforms/powernv/pci.c
> +++ b/arch/powerpc/platforms/powernv/pci.c
> @@ -48,13 +48,14 @@ int pnv_pci_get_slot_id(struct device_node *np,
> uint64_t *id)
>  		return -ENXIO;
>  
>  	bdfn = ((bdfn & 0x00ffff00) >> 8);
> -	while ((parent = of_get_parent(parent))) {
> +	for (parent = np; parent; parent = of_get_parent(parent)) {
>  		if (!PCI_DN(parent)) {
>  			of_node_put(parent);
>  			break;
>  		}
>  
> -		if (!of_device_is_compatible(parent, "ibm,ioda2-phb"))
> {
> +		if (!of_device_is_compatible(parent, "ibm,ioda2-phb")
> &&
> +		    !of_device_is_compatible(parent, "ibm,ioda2-npu2-
> opencapi-phb")) {
>  			of_node_put(parent);
>  			continue;
>  		}
> @@ -65,7 +66,10 @@ int pnv_pci_get_slot_id(struct device_node *np,
> uint64_t *id)
>  			return -ENXIO;
>  		}
>  
> -		*id = PCI_SLOT_ID(phbid, bdfn);
> +		if (of_device_is_compatible(parent, "ibm,ioda2-npu2-
> opencapi-phb"))
> +			*id = PCI_PHB_SLOT_ID(phbid);
> +		else
> +			*id = PCI_SLOT_ID(phbid, bdfn);
>  		return 0;
>  	}
>  

Reviewed-by: Alastair D'Silva <alastair@d-silva.org>
Andrew Donnellan Nov. 19, 2019, 1:26 a.m. UTC | #2
On 10/9/19 1:45 am, Frederic Barrat wrote:
> diff --git a/arch/powerpc/platforms/powernv/pci.c b/arch/powerpc/platforms/powernv/pci.c
> index 6104418c9ad5..00a79f3c989f 100644
> --- a/arch/powerpc/platforms/powernv/pci.c
> +++ b/arch/powerpc/platforms/powernv/pci.c
> @@ -48,13 +48,14 @@ int pnv_pci_get_slot_id(struct device_node *np, uint64_t *id)
>   		return -ENXIO;
>   
>   	bdfn = ((bdfn & 0x00ffff00) >> 8);
> -	while ((parent = of_get_parent(parent))) {
> +	for (parent = np; parent; parent = of_get_parent(parent)) {

I think we should rename this pointer from "parent" as it no longer 
means that.
Frederic Barrat Nov. 19, 2019, 2:33 p.m. UTC | #3
Le 19/11/2019 à 02:26, Andrew Donnellan a écrit :
> On 10/9/19 1:45 am, Frederic Barrat wrote:
>> diff --git a/arch/powerpc/platforms/powernv/pci.c 
>> b/arch/powerpc/platforms/powernv/pci.c
>> index 6104418c9ad5..00a79f3c989f 100644
>> --- a/arch/powerpc/platforms/powernv/pci.c
>> +++ b/arch/powerpc/platforms/powernv/pci.c
>> @@ -48,13 +48,14 @@ int pnv_pci_get_slot_id(struct device_node *np, 
>> uint64_t *id)
>>           return -ENXIO;
>>       bdfn = ((bdfn & 0x00ffff00) >> 8);
>> -    while ((parent = of_get_parent(parent))) {
>> +    for (parent = np; parent; parent = of_get_parent(parent)) {
> 
> I think we should rename this pointer from "parent" as it no longer 
> means that.


ok. We still walk the parent list, but we don't start from the first 
parent any more. I'll rename with a more generic "node" to avoid confusion.

   Fred
diff mbox series

Patch

diff --git a/arch/powerpc/include/asm/pnv-pci.h b/arch/powerpc/include/asm/pnv-pci.h
index edcb1fc50aeb..d0ee0ede5767 100644
--- a/arch/powerpc/include/asm/pnv-pci.h
+++ b/arch/powerpc/include/asm/pnv-pci.h
@@ -15,6 +15,7 @@ 
 #define PCI_SLOT_ID_PREFIX	(1UL << 63)
 #define PCI_SLOT_ID(phb_id, bdfn)	\
 	(PCI_SLOT_ID_PREFIX | ((uint64_t)(bdfn) << 16) | (phb_id))
+#define PCI_PHB_SLOT_ID(phb_id)		(phb_id)
 
 extern int pnv_pci_get_slot_id(struct device_node *np, uint64_t *id);
 extern int pnv_pci_get_device_tree(uint32_t phandle, void *buf, uint64_t len);
diff --git a/arch/powerpc/platforms/powernv/pci.c b/arch/powerpc/platforms/powernv/pci.c
index 6104418c9ad5..00a79f3c989f 100644
--- a/arch/powerpc/platforms/powernv/pci.c
+++ b/arch/powerpc/platforms/powernv/pci.c
@@ -48,13 +48,14 @@  int pnv_pci_get_slot_id(struct device_node *np, uint64_t *id)
 		return -ENXIO;
 
 	bdfn = ((bdfn & 0x00ffff00) >> 8);
-	while ((parent = of_get_parent(parent))) {
+	for (parent = np; parent; parent = of_get_parent(parent)) {
 		if (!PCI_DN(parent)) {
 			of_node_put(parent);
 			break;
 		}
 
-		if (!of_device_is_compatible(parent, "ibm,ioda2-phb")) {
+		if (!of_device_is_compatible(parent, "ibm,ioda2-phb") &&
+		    !of_device_is_compatible(parent, "ibm,ioda2-npu2-opencapi-phb")) {
 			of_node_put(parent);
 			continue;
 		}
@@ -65,7 +66,10 @@  int pnv_pci_get_slot_id(struct device_node *np, uint64_t *id)
 			return -ENXIO;
 		}
 
-		*id = PCI_SLOT_ID(phbid, bdfn);
+		if (of_device_is_compatible(parent, "ibm,ioda2-npu2-opencapi-phb"))
+			*id = PCI_PHB_SLOT_ID(phbid);
+		else
+			*id = PCI_SLOT_ID(phbid, bdfn);
 		return 0;
 	}