diff mbox series

[1/7,Focal/linux-azure] net: mana: Use struct_size() in kzalloc()

Message ID 20211021122400.10390-2-tim.gardner@canonical.com
State New
Headers show
Series Update Microsoft MANA to 5.15-rc6 | expand

Commit Message

Tim Gardner Oct. 21, 2021, 12:23 p.m. UTC
From: "Gustavo A. R. Silva" <gustavoars@kernel.org>

BugLink: https://bugs.launchpad.net/bugs/1947859

Make use of the struct_size() helper instead of an open-coded version,
in order to avoid any potential type mistakes or integer overflows
that, in the worst scenario, could lead to heap overflows.

This code was detected with the help of Coccinelle and, audited and
fixed manually.

Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
Signed-off-by: David S. Miller <davem@davemloft.net>
(cherry picked from commit ea89c862f01e02ec459932c7c3113fa37aedd09a)
Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
---
 drivers/net/ethernet/microsoft/mana/mana_en.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/drivers/net/ethernet/microsoft/mana/mana_en.c b/drivers/net/ethernet/microsoft/mana/mana_en.c
index 987e11c02f727..02aff16df27f0 100644
--- a/drivers/net/ethernet/microsoft/mana/mana_en.c
+++ b/drivers/net/ethernet/microsoft/mana/mana_en.c
@@ -1388,8 +1388,7 @@  static struct mana_rxq *mana_create_rxq(struct mana_port_context *apc,
 
 	gc = gd->gdma_context;
 
-	rxq = kzalloc(sizeof(*rxq) +
-		      RX_BUFFERS_PER_QUEUE * sizeof(struct mana_recv_buf_oob),
+	rxq = kzalloc(struct_size(rxq, rx_oobs, RX_BUFFERS_PER_QUEUE),
 		      GFP_KERNEL);
 	if (!rxq)
 		return NULL;