diff mbox series

fs: fat: use ATTR_ARCH instead of anonymous 0x20

Message ID 20201122101757.22978-1-xypron.glpk@gmx.de
State Superseded, archived
Delegated to: Tom Rini
Headers show
Series fs: fat: use ATTR_ARCH instead of anonymous 0x20 | expand

Commit Message

Heinrich Schuchardt Nov. 22, 2020, 10:17 a.m. UTC
Using constants instead of anonymous numbers increases code readability.

Fixes: 704df6aa0a28 ("fs: fat: refactor write interface for a file offset")
Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
---
 fs/fat/fat_write.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

--
2.29.2

Comments

Simon Glass Nov. 23, 2020, 1:28 a.m. UTC | #1
On Sun, 22 Nov 2020 at 03:18, Heinrich Schuchardt <xypron.glpk@gmx.de> wrote:
>
> Using constants instead of anonymous numbers increases code readability.
>
> Fixes: 704df6aa0a28 ("fs: fat: refactor write interface for a file offset")
> Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
> ---
>  fs/fat/fat_write.c | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>

Reviewed-by: Simon Glass <sjg@chromium.org>
diff mbox series

Patch

diff --git a/fs/fat/fat_write.c b/fs/fat/fat_write.c
index fc932df953..7afc8388b2 100644
--- a/fs/fat/fat_write.c
+++ b/fs/fat/fat_write.c
@@ -1191,7 +1191,8 @@  int file_fat_write_at(const char *filename, loff_t pos, void *buffer,
 		}

 		/* Set short name entry */
-		fill_dentry(itr->fsdata, itr->dent, filename, 0, size, 0x20);
+		fill_dentry(itr->fsdata, itr->dent, filename, 0, size,
+			    ATTR_ARCH);

 		retdent = itr->dent;
 	}