diff mbox series

[RFC] cmd: mp: change the command name from cpu to mp

Message ID 20200314124704.19731-1-pragnesh.patel@sifive.com
State RFC
Headers show
Series [RFC] cmd: mp: change the command name from cpu to mp | expand

Commit Message

Pragnesh Patel March 14, 2020, 12:47 p.m. UTC
when CONFIG_CMD_CPU and CONFIG_MP both are enabled, u-boot compilation
gives an error of "multiple definition of `_u_boot_list_2_cmd_2_cpu'"
so cpu command(cmd/cpu.c) and mp command(cmd/mp.c) should have different
command name.

Signed-off-by: Pragnesh Patel <pragnesh.patel@sifive.com>
---
 cmd/mp.c | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

Comments

Bin Meng March 14, 2020, 2:01 p.m. UTC | #1
On Sat, Mar 14, 2020 at 8:47 PM Pragnesh Patel
<pragnesh.patel@sifive.com> wrote:
>
> when CONFIG_CMD_CPU and CONFIG_MP both are enabled, u-boot compilation
> gives an error of "multiple definition of `_u_boot_list_2_cmd_2_cpu'"
> so cpu command(cmd/cpu.c) and mp command(cmd/mp.c) should have different
> command name.
>
> Signed-off-by: Pragnesh Patel <pragnesh.patel@sifive.com>
> ---
>  cmd/mp.c | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/cmd/mp.c b/cmd/mp.c
> index 4c8f5fc3fa..26995c9976 100644
> --- a/cmd/mp.c
> +++ b/cmd/mp.c
> @@ -68,11 +68,11 @@ cpu_cmd(cmd_tbl_t *cmdtp, int flag, int argc, char * const argv[])
>
>  #ifdef CONFIG_SYS_LONGHELP
>  static char cpu_help_text[] =

rename this to mp_help_text[]?

> -           "<num> reset                 - Reset cpu <num>\n"
> -       "cpu status                      - Status of all cpus\n"
> -       "cpu <num> status                - Status of cpu <num>\n"
> -       "cpu <num> disable               - Disable cpu <num>\n"
> -       "cpu <num> release <addr> [args] - Release cpu <num> at <addr> with [args]"
> +       "mp <num> reset                 - Reset cpu <num>\n"
> +       "mp status                      - Status of all cpus\n"
> +       "mp <num> status                - Status of cpu <num>\n"
> +       "mp <num> disable               - Disable cpu <num>\n"
> +       "mp <num> release <addr> [args] - Release cpu <num> at <addr> with [args]"
>  #ifdef CONFIG_PPC
>         "\n"
>         "                         [args] : <pir> <r3> <r6>\n" \
> @@ -90,6 +90,6 @@ static char cpu_help_text[] =
>  #endif
>
>  U_BOOT_CMD(
> -       cpu, CONFIG_SYS_MAXARGS, 1, cpu_cmd,
> +       mp, CONFIG_SYS_MAXARGS, 1, cpu_cmd,

mp_cmd

>         "Multiprocessor CPU boot manipulation and release", cpu_help_text
>  );
> --

Please check the same file, there are some additional places using 'cpu'

Regards,
Bin
Simon Glass March 14, 2020, 8:34 p.m. UTC | #2
Hi,

On Sat, 14 Mar 2020 at 06:47, Pragnesh Patel <pragnesh.patel@sifive.com> wrote:
>
> when CONFIG_CMD_CPU and CONFIG_MP both are enabled, u-boot compilation
> gives an error of "multiple definition of `_u_boot_list_2_cmd_2_cpu'"
> so cpu command(cmd/cpu.c) and mp command(cmd/mp.c) should have different
> command name.
>
> Signed-off-by: Pragnesh Patel <pragnesh.patel@sifive.com>
> ---
>  cmd/mp.c | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/cmd/mp.c b/cmd/mp.c
> index 4c8f5fc3fa..26995c9976 100644
> --- a/cmd/mp.c
> +++ b/cmd/mp.c
> @@ -68,11 +68,11 @@ cpu_cmd(cmd_tbl_t *cmdtp, int flag, int argc, char * const argv[])
>
>  #ifdef CONFIG_SYS_LONGHELP
>  static char cpu_help_text[] =
> -           "<num> reset                 - Reset cpu <num>\n"
> -       "cpu status                      - Status of all cpus\n"
> -       "cpu <num> status                - Status of cpu <num>\n"
> -       "cpu <num> disable               - Disable cpu <num>\n"
> -       "cpu <num> release <addr> [args] - Release cpu <num> at <addr> with [args]"
> +       "mp <num> reset                 - Reset cpu <num>\n"
> +       "mp status                      - Status of all cpus\n"
> +       "mp <num> status                - Status of cpu <num>\n"
> +       "mp <num> disable               - Disable cpu <num>\n"
> +       "mp <num> release <addr> [args] - Release cpu <num> at <addr> with [args]"

This interface should be migrated to driver model (using UCLASS_CPU) instead.

Regards,
Simon
diff mbox series

Patch

diff --git a/cmd/mp.c b/cmd/mp.c
index 4c8f5fc3fa..26995c9976 100644
--- a/cmd/mp.c
+++ b/cmd/mp.c
@@ -68,11 +68,11 @@  cpu_cmd(cmd_tbl_t *cmdtp, int flag, int argc, char * const argv[])
 
 #ifdef CONFIG_SYS_LONGHELP
 static char cpu_help_text[] =
-	    "<num> reset                 - Reset cpu <num>\n"
-	"cpu status                      - Status of all cpus\n"
-	"cpu <num> status                - Status of cpu <num>\n"
-	"cpu <num> disable               - Disable cpu <num>\n"
-	"cpu <num> release <addr> [args] - Release cpu <num> at <addr> with [args]"
+	"mp <num> reset                 - Reset cpu <num>\n"
+	"mp status                      - Status of all cpus\n"
+	"mp <num> status                - Status of cpu <num>\n"
+	"mp <num> disable               - Disable cpu <num>\n"
+	"mp <num> release <addr> [args] - Release cpu <num> at <addr> with [args]"
 #ifdef CONFIG_PPC
 	"\n"
 	"                         [args] : <pir> <r3> <r6>\n" \
@@ -90,6 +90,6 @@  static char cpu_help_text[] =
 #endif
 
 U_BOOT_CMD(
-	cpu, CONFIG_SYS_MAXARGS, 1, cpu_cmd,
+	mp, CONFIG_SYS_MAXARGS, 1, cpu_cmd,
 	"Multiprocessor CPU boot manipulation and release", cpu_help_text
 );