mbox

[PULL,00/21] Monitor patches

Message ID 1433233439-3386-1-git-send-email-armbru@redhat.com
State New
Headers show

Pull-request

git://repo.or.cz/qemu/armbru.git tags/pull-monitor-2015-06-02

Message

Markus Armbruster June 2, 2015, 8:23 a.m. UTC
These change the monitor core, shared by HMP (maintained by Luiz) and
QMP (maintained by myself).  Luiz reviewed and asked me to take them
through my tree.

This is v3 with the (reviewed!) one-line amend to PATCH 14 squashed
in, and trivially rebased.

The following changes since commit b821cbe274c5a5cacf1a7b28360d869ae1e6e0c3:

  Merge remote-tracking branch 'remotes/mst/tags/for_upstream' into staging (2015-06-01 15:22:46 +0100)

are available in the git repository at:


  git://repo.or.cz/qemu/armbru.git tags/pull-monitor-2015-06-02

for you to fetch changes up to 489653b5db17679fd61b740dd289c798bb25d7b9:

  monitor: Change return type of monitor_cur_is_qmp() to bool (2015-06-02 10:07:16 +0200)

----------------------------------------------------------------
Monitor patches

----------------------------------------------------------------
Markus Armbruster (21):
      monitor: Drop broken, unused asynchronous command interface
      monitor: Clean up after previous commit
      monitor: Improve and document client_migrate_info protocol error
      monitor: Convert client_migrate_info to QAPI
      monitor: Use traditional command interface for HMP drive_del
      monitor: Use traditional command interface for HMP device_add
      monitor: Use trad. command interface for HMP pcie_aer_inject_error
      monitor: Drop unused "new" HMP command interface
      monitor: Propagate errors through qmp_check_client_args()
      monitor: Propagate errors through qmp_check_input_obj()
      monitor: Propagate errors through invalid_qmp_mode()
      monitor: Wean monitor_protocol_emitter() off mon->error
      monitor: Inline monitor_has_error() into its only caller
      monitor: Limit QError use to command handlers
      monitor: Rename handle_user_command() to handle_hmp_command()
      monitor: Rename monitor_control_read(), monitor_control_event()
      monitor: Unbox Monitor member mc and rename to qmp
      monitor: Drop do_qmp_capabilities()'s superfluous QMP check
      monitor: Turn int command_mode into bool in_command_mode
      monitor: Rename monitor_ctrl_mode() to monitor_is_qmp()
      monitor: Change return type of monitor_cur_is_qmp() to bool

 blockdev.c                |   9 +-
 hmp-commands.hx           |  20 +--
 hmp.c                     |  23 +++
 hmp.h                     |   2 +
 hw/pci/pci-stub.c         |  14 +-
 hw/pci/pcie_aer.c         |  39 +++--
 include/monitor/monitor.h |   7 +-
 include/sysemu/blockdev.h |   2 +-
 include/sysemu/sysemu.h   |   4 +-
 monitor.c                 | 397 ++++++++++++++++------------------------------
 qapi-schema.json          |  19 +++
 qmp-commands.hx           |  16 +-
 stubs/mon-is-qmp.c        |   4 +-
 13 files changed, 231 insertions(+), 325 deletions(-)

Comments

Peter Maydell June 4, 2015, 9:21 a.m. UTC | #1
On 2 June 2015 at 09:23, Markus Armbruster <armbru@redhat.com> wrote:
> These change the monitor core, shared by HMP (maintained by Luiz) and
> QMP (maintained by myself).  Luiz reviewed and asked me to take them
> through my tree.
>
> This is v3 with the (reviewed!) one-line amend to PATCH 14 squashed
> in, and trivially rebased.
>
> The following changes since commit b821cbe274c5a5cacf1a7b28360d869ae1e6e0c3:
>
>   Merge remote-tracking branch 'remotes/mst/tags/for_upstream' into staging (2015-06-01 15:22:46 +0100)
>
> are available in the git repository at:
>
>
>   git://repo.or.cz/qemu/armbru.git tags/pull-monitor-2015-06-02
>
> for you to fetch changes up to 489653b5db17679fd61b740dd289c798bb25d7b9:
>
>   monitor: Change return type of monitor_cur_is_qmp() to bool (2015-06-02 10:07:16 +0200)
>
> ----------------------------------------------------------------
> Monitor patches

Applied, thanks.

-- PMM