diff mbox series

[uci,v2] cmake: Allow override of install directories

Message ID mailman.3637.1633452892.1923571.openwrt-devel@lists.openwrt.org
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series [uci,v2] cmake: Allow override of install directories | expand

Commit Message

Hauke Mehrtens Oct. 5, 2021, 4:54 p.m. UTC
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
Use the GNUInstallDirs include to allow callers to override the install
directories. This is helpful when building uci in build systems like
Yocto which prefer to use /usr/lib64 for the 64 bit libraries.

Signed-off-by: Hauke Mehrtens <hmehrtens@maxlinear.com>
---

Change since:
v1:
  overwrite -> override

 CMakeLists.txt | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 560ed65..50e7f51 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,5 @@ 
 cmake_minimum_required(VERSION 2.6)
+INCLUDE(GNUInstallDirs)
 
 PROJECT(uci C)
 
@@ -74,12 +75,12 @@  IF(UNIT_TESTING)
 ENDIF()
 
 INSTALL(FILES uci.h uci_config.h uci_blob.h ucimap.h
-	DESTINATION include
+	DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
 )
 
 INSTALL(TARGETS uci cli
-	ARCHIVE DESTINATION lib
-	LIBRARY DESTINATION lib
-	RUNTIME DESTINATION bin
+	ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+	LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+	RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
 )