diff mbox

[OpenWrt-Devel,ramips] Adjust image size limit for the D-Link DIR-860L B1

Message ID 56FC576F.1070104@pyret.net
State Accepted
Headers show

Commit Message

Daniel Engberg March 30, 2016, 10:47 p.m. UTC
Currently the maximum image size defaults to 8Mbyte even though this model has 16Mbyte of flash memory.

Tested and works on my device.

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>

---

Comments

Kristian Evensen April 9, 2016, 12:10 p.m. UTC | #1
Hi,

On Thu, Mar 31, 2016 at 12:47 AM, Daniel Engberg
<daniel.engberg.lists@pyret.net> wrote:
> Currently the maximum image size defaults to 8Mbyte even though this model has 16Mbyte of flash memory.

Something has gone wrong when merging this patch (look at the Makefile
in the upstream commit), causing building mt7621 to break.

-Kristian
Chuanhong Guo April 9, 2016, 2:10 p.m. UTC | #2
According to https://dev.openwrt.org/changeset/49129 The patch is
applied with the git conflict remains and it breaks MT7621 target.

2016-04-09 20:10 GMT+08:00 Kristian Evensen <kristian.evensen@gmail.com>:
> Hi,
>
> On Thu, Mar 31, 2016 at 12:47 AM, Daniel Engberg
> <daniel.engberg.lists@pyret.net> wrote:
>> Currently the maximum image size defaults to 8Mbyte even though this model has 16Mbyte of flash memory.
>
> Something has gone wrong when merging this patch (look at the Makefile
> in the upstream commit), causing building mt7621 to break.
>
> -Kristian
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
John Crispin April 9, 2016, 2:45 p.m. UTC | #3
oh dear, let me fix that

On 09/04/2016 16:10, 郭传鈜 wrote:
> According to https://dev.openwrt.org/changeset/49129 The patch is
> applied with the git conflict remains and it breaks MT7621 target.
> 
> 2016-04-09 20:10 GMT+08:00 Kristian Evensen <kristian.evensen@gmail.com>:
>> Hi,
>>
>> On Thu, Mar 31, 2016 at 12:47 AM, Daniel Engberg
>> <daniel.engberg.lists@pyret.net> wrote:
>>> Currently the maximum image size defaults to 8Mbyte even though this model has 16Mbyte of flash memory.
>>
>> Something has gone wrong when merging this patch (look at the Makefile
>> in the upstream commit), causing building mt7621 to break.
>>
>> -Kristian
>> _______________________________________________
>> openwrt-devel mailing list
>> openwrt-devel@lists.openwrt.org
>> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
diff mbox

Patch

diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 0cfb8fb..2590e2b 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -1085,6 +1085,7 @@  define Device/dir-860l-b1
   DTS := DIR-860L-B1
   IMAGES += factory.bin
   KERNEL := kernel-bin | patch-dtb | relocate-kernel | lzma | uImage lzma
+  IMAGE_SIZE := $(ralink_default_fw_size_16M)
   IMAGE/sysupgrade.bin := \
 	append-kernel | pad-offset 65536 64 | append-rootfs | \
 	seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \