diff mbox series

[v2,2/9] kernel: Add kmod-rtc-x1205

Message ID 20230928-ixp4xx-v2-2-ce011eef8239@linaro.org
State Superseded
Headers show
Series Resurrect OpenWrt IXP4xx support | expand

Commit Message

Linus Walleij Sept. 28, 2023, 1:28 p.m. UTC
To support the IXP42x platforms we need a kernel module
for the X1205 RTC so we can load it as an optional module.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
---
 package/kernel/linux/modules/other.mk | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

Comments

Robert Marko Oct. 4, 2023, 12:47 p.m. UTC | #1
On Thu, 28 Sept 2023 at 15:29, Linus Walleij <linus.walleij@linaro.org> wrote:
>
> To support the IXP42x platforms we need a kernel module
> for the X1205 RTC so we can load it as an optional module.
>
> Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
> ---
>  package/kernel/linux/modules/other.mk | 16 ++++++++++++++++
>  1 file changed, 16 insertions(+)
>
> diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
> index ac26c2a15037..187c0c56f0bb 100644
> --- a/package/kernel/linux/modules/other.mk
> +++ b/package/kernel/linux/modules/other.mk
> @@ -780,6 +780,22 @@ endef
>
>  $(eval $(call KernelPackage,rtc-s35390a))
>
> +define KernelPackage/rtc-x1205
> +  SUBMENU:=$(OTHER_MENU)
> +  TITLE:=Xicor Intersil X1205
> +  DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
> +  DEPENDS:=+kmod-i2c-core
> +  KCONFIG:=CONFIG_RTC_DRV_X1205 \
> +       CONFIG_RTC_CLASS=y
> +  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-x1205.ko
> +  AUTOLOAD:=$(call AutoLoad,50,rtc-x1205,1)

Any reason why this cannot be probed instead, also why does it have to
be included in
preinit as well?

Regards,
Robert
> +endef
> +
> +define KernelPackage/rtc-x1205/description
> + Kernel module for Xicor Intersil X1205 I2C RTC chip
> +endef
> +
> +$(eval $(call KernelPackage,rtc-x1205))
>
>  define KernelPackage/mtdtests
>    SUBMENU:=$(OTHER_MENU)
>
> --
> 2.34.1
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index ac26c2a15037..187c0c56f0bb 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -780,6 +780,22 @@  endef
 
 $(eval $(call KernelPackage,rtc-s35390a))
 
+define KernelPackage/rtc-x1205
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Xicor Intersil X1205
+  DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+  DEPENDS:=+kmod-i2c-core
+  KCONFIG:=CONFIG_RTC_DRV_X1205 \
+	CONFIG_RTC_CLASS=y
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-x1205.ko
+  AUTOLOAD:=$(call AutoLoad,50,rtc-x1205,1)
+endef
+
+define KernelPackage/rtc-x1205/description
+ Kernel module for Xicor Intersil X1205 I2C RTC chip
+endef
+
+$(eval $(call KernelPackage,rtc-x1205))
 
 define KernelPackage/mtdtests
   SUBMENU:=$(OTHER_MENU)