diff mbox series

[v2,3/9] kernel: Add kmod-rtc-r7301

Message ID 20230928-ixp4xx-v2-3-ce011eef8239@linaro.org
State Superseded
Headers show
Series Resurrect OpenWrt IXP4xx support | expand

Commit Message

Linus Walleij Sept. 28, 2023, 1:28 p.m. UTC
To support the IXP42x platforms we need a kernel module
for the Epson R7301 RTC so we can load it as an optional
module.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
---
 package/kernel/linux/modules/other.mk | 15 +++++++++++++++
 1 file changed, 15 insertions(+)

Comments

Robert Marko Oct. 4, 2023, 12:48 p.m. UTC | #1
On Thu, 28 Sept 2023 at 15:29, Linus Walleij <linus.walleij@linaro.org> wrote:
>
> To support the IXP42x platforms we need a kernel module
> for the Epson R7301 RTC so we can load it as an optional
> module.
>
> Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
> ---
>  package/kernel/linux/modules/other.mk | 15 +++++++++++++++
>  1 file changed, 15 insertions(+)
>
> diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
> index 187c0c56f0bb..8e7da1ca2c6f 100644
> --- a/package/kernel/linux/modules/other.mk
> +++ b/package/kernel/linux/modules/other.mk
> @@ -728,6 +728,21 @@ endef
>
>  $(eval $(call KernelPackage,rtc-pcf2127))
>
> +define KernelPackage/rtc-r7301
> +  SUBMENU:=$(OTHER_MENU)
> +  TITLE:=Epson RTC7301 support
> +  DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
> +  KCONFIG:=CONFIG_RTC_DRV_R7301 \
> +       CONFIG_RTC_CLASS=y
> +  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-r7301.ko
> +  AUTOLOAD:=$(call AutoLoad,50,rtc-r7301,1)

Same question as for the other RTC kmod:
Any reason why this cannot be probed instead, also why does it have to
be included in
preinit as well?

Regards,
Robert
> +endef
> +
> +define KernelPackage/rtc-r7301/description
> + Kernel module for Epson RTC7301 RTC chip
> +endef
> +
> +$(eval $(call KernelPackage,rtc-r7301))
>
>  define KernelPackage/rtc-rs5c372a
>    SUBMENU:=$(OTHER_MENU)
>
> --
> 2.34.1
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 187c0c56f0bb..8e7da1ca2c6f 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -728,6 +728,21 @@  endef
 
 $(eval $(call KernelPackage,rtc-pcf2127))
 
+define KernelPackage/rtc-r7301
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Epson RTC7301 support
+  DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+  KCONFIG:=CONFIG_RTC_DRV_R7301 \
+	CONFIG_RTC_CLASS=y
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-r7301.ko
+  AUTOLOAD:=$(call AutoLoad,50,rtc-r7301,1)
+endef
+
+define KernelPackage/rtc-r7301/description
+ Kernel module for Epson RTC7301 RTC chip
+endef
+
+$(eval $(call KernelPackage,rtc-r7301))
 
 define KernelPackage/rtc-rs5c372a
   SUBMENU:=$(OTHER_MENU)