diff mbox series

[2/2] package/alsa-plugins: require libsamplerate for the plugins

Message ID 20230620173813.4590-2-ckhardin@gmail.com
State Superseded
Headers show
Series [1/2] package/alsa-plugins: fix dependencies for the alsa plugin package | expand

Commit Message

Charles Hardin June 20, 2023, 5:38 p.m. UTC
During the execution of the alsa plugins on a test application,
the library would not function without samplerate being enabled
and present. So, this is a patch to just include the samplerate
since the latest versions seem to require it for the plugins to
work.

There might be another fix instead of this patch, but this got
the sound to play for the bluez alsa stack as expected.

Signed-off-by: Charles Hardin <ckhardin@gmail.com>
---
 package/alsa-plugins/Config.in       |  1 +
 package/alsa-plugins/alsa-plugins.mk | 22 ++++++----------------
 2 files changed, 7 insertions(+), 16 deletions(-)

Comments

Arnout Vandecappelle June 25, 2023, 8:04 p.m. UTC | #1
On 20/06/2023 19:38, Charles Hardin wrote:
> During the execution of the alsa plugins on a test application,
> the library would not function without samplerate being enabled
> and present. So, this is a patch to just include the samplerate
> since the latest versions seem to require it for the plugins to
> work.

  It doesn't sound unreasonable that some plugins require samplerate, but it 
seems unlikely that none of them work without libsamplerate...


> There might be another fix instead of this patch, but this got
> the sound to play for the bluez alsa stack as expected.

  If it's just for bluez, then it sounds more logical to do it in bluez-alsa?

  Regards,
  Arnout

> 
> Signed-off-by: Charles Hardin <ckhardin@gmail.com>
> ---
>   package/alsa-plugins/Config.in       |  1 +
>   package/alsa-plugins/alsa-plugins.mk | 22 ++++++----------------
>   2 files changed, 7 insertions(+), 16 deletions(-)
> 
> diff --git a/package/alsa-plugins/Config.in b/package/alsa-plugins/Config.in
> index ee0fb4c1d5..e85ff218dd 100644
> --- a/package/alsa-plugins/Config.in
> +++ b/package/alsa-plugins/Config.in
> @@ -2,6 +2,7 @@ config BR2_PACKAGE_ALSA_PLUGINS
>   	bool "alsa-plugins"
>   	depends on BR2_PACKAGE_ALSA_LIB
>   	select BR2_PACKAGE_ALSA_LIB_HWDEP
> +	select BR2_PACKAGE_LIBSAMPLERATE
>   	help
>   	  Advanced Linux Sound Architecture Plugins
>   
> diff --git a/package/alsa-plugins/alsa-plugins.mk b/package/alsa-plugins/alsa-plugins.mk
> index d23a81c5ee..8046720297 100644
> --- a/package/alsa-plugins/alsa-plugins.mk
> +++ b/package/alsa-plugins/alsa-plugins.mk
> @@ -7,30 +7,20 @@
>   ALSA_PLUGINS_VERSION = 1.2.7.1
>   ALSA_PLUGINS_SOURCE = alsa-plugins-$(ALSA_PLUGINS_VERSION).tar.bz2
>   ALSA_PLUGINS_SITE = https://www.alsa-project.org/files/pub/plugins
> -ALSA_PLUGINS_LICENSE = LGPL-2.1+
> -ALSA_PLUGINS_LICENSE_FILES = COPYING
> -ALSA_PLUGINS_DEPENDENCIES = host-pkgconf alsa-lib
> +ALSA_PLUGINS_LICENSE = LGPL-2.1+ (library), GPL-2.0+ (samplerate)
> +ALSA_PLUGINS_LICENSE_FILES = COPYING COPYING.GPL
> +ALSA_PLUGINS_DEPENDENCIES = host-pkgconf alsa-lib libsamplerate
>   
>   ALSA_PLUGINS_CONF_OPTS = \
> +	--enable-samplerate \
>   	--disable-jack \
>   	--disable-usbstream \
>   	--disable-pulseaudio \
> -	--disable-libav \
> -	--disable-maemo-plugin \
> -	--disable-maemo-resource-manager \
> -	--with-speex=no
> +	--disable-avcodec \
> +	--with-speex=builtin
>   
>   ifeq ($(BR2_PACKAGE_ALSA_UTILS),y)
>   ALSA_PLUGINS_DEPENDENCIES += alsa-utils
>   endif
>   
> -ifeq ($(BR2_PACKAGE_LIBSAMPLERATE),y)
> -ALSA_PLUGINS_CONF_OPTS += --enable-samplerate
> -ALSA_PLUGINS_DEPENDENCIES += libsamplerate
> -ALSA_PLUGINS_LICENSE += , GPL-2.0+ (samplerate plugin)
> -ALSA_PLUGINS_LICENSE_FILES += COPYING.GPL
> -else
> -ALSA_PLUGINS_CONF_OPTS += --disable-samplerate
> -endif
> -
>   $(eval $(autotools-package))
diff mbox series

Patch

diff --git a/package/alsa-plugins/Config.in b/package/alsa-plugins/Config.in
index ee0fb4c1d5..e85ff218dd 100644
--- a/package/alsa-plugins/Config.in
+++ b/package/alsa-plugins/Config.in
@@ -2,6 +2,7 @@  config BR2_PACKAGE_ALSA_PLUGINS
 	bool "alsa-plugins"
 	depends on BR2_PACKAGE_ALSA_LIB
 	select BR2_PACKAGE_ALSA_LIB_HWDEP
+	select BR2_PACKAGE_LIBSAMPLERATE
 	help
 	  Advanced Linux Sound Architecture Plugins
 
diff --git a/package/alsa-plugins/alsa-plugins.mk b/package/alsa-plugins/alsa-plugins.mk
index d23a81c5ee..8046720297 100644
--- a/package/alsa-plugins/alsa-plugins.mk
+++ b/package/alsa-plugins/alsa-plugins.mk
@@ -7,30 +7,20 @@ 
 ALSA_PLUGINS_VERSION = 1.2.7.1
 ALSA_PLUGINS_SOURCE = alsa-plugins-$(ALSA_PLUGINS_VERSION).tar.bz2
 ALSA_PLUGINS_SITE = https://www.alsa-project.org/files/pub/plugins
-ALSA_PLUGINS_LICENSE = LGPL-2.1+
-ALSA_PLUGINS_LICENSE_FILES = COPYING
-ALSA_PLUGINS_DEPENDENCIES = host-pkgconf alsa-lib
+ALSA_PLUGINS_LICENSE = LGPL-2.1+ (library), GPL-2.0+ (samplerate)
+ALSA_PLUGINS_LICENSE_FILES = COPYING COPYING.GPL
+ALSA_PLUGINS_DEPENDENCIES = host-pkgconf alsa-lib libsamplerate
 
 ALSA_PLUGINS_CONF_OPTS = \
+	--enable-samplerate \
 	--disable-jack \
 	--disable-usbstream \
 	--disable-pulseaudio \
-	--disable-libav \
-	--disable-maemo-plugin \
-	--disable-maemo-resource-manager \
-	--with-speex=no
+	--disable-avcodec \
+	--with-speex=builtin
 
 ifeq ($(BR2_PACKAGE_ALSA_UTILS),y)
 ALSA_PLUGINS_DEPENDENCIES += alsa-utils
 endif
 
-ifeq ($(BR2_PACKAGE_LIBSAMPLERATE),y)
-ALSA_PLUGINS_CONF_OPTS += --enable-samplerate
-ALSA_PLUGINS_DEPENDENCIES += libsamplerate
-ALSA_PLUGINS_LICENSE += , GPL-2.0+ (samplerate plugin)
-ALSA_PLUGINS_LICENSE_FILES += COPYING.GPL
-else
-ALSA_PLUGINS_CONF_OPTS += --disable-samplerate
-endif
-
 $(eval $(autotools-package))