diff mbox series

[1/2] package/alsa-plugins: fix dependencies for the alsa plugin package

Message ID 20230620173813.4590-1-ckhardin@gmail.com
State Accepted
Headers show
Series [1/2] package/alsa-plugins: fix dependencies for the alsa plugin package | expand

Commit Message

Charles Hardin June 20, 2023, 5:38 p.m. UTC
The alsa-utils will remove and create the /usr/share/alsa dir
as a whole and since the alsa plugins needs to add config into
this same directory it should come after those install steps.

Also, the bluez alsa needs the plugins installed to find them
during the configuration phases - so, interlock the plugins
when configured.

Signed-off-by: Charles Hardin <ckhardin@gmail.com>
---
 package/alsa-plugins/alsa-plugins.mk | 4 ++++
 package/bluez-alsa/bluez-alsa.mk     | 4 ++++
 2 files changed, 8 insertions(+)

Comments

Arnout Vandecappelle June 25, 2023, 7:57 p.m. UTC | #1
On 20/06/2023 19:38, Charles Hardin wrote:
> The alsa-utils will remove and create the /usr/share/alsa dir
> as a whole and since the alsa plugins needs to add config into
> this same directory it should come after those install steps.
> 
> Also, the bluez alsa needs the plugins installed to find them
> during the configuration phases - so, interlock the plugins
> when configured.
> 
> Signed-off-by: Charles Hardin <ckhardin@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/alsa-plugins/alsa-plugins.mk | 4 ++++
>   package/bluez-alsa/bluez-alsa.mk     | 4 ++++
>   2 files changed, 8 insertions(+)
> 
> diff --git a/package/alsa-plugins/alsa-plugins.mk b/package/alsa-plugins/alsa-plugins.mk
> index 5728ebfe37..d23a81c5ee 100644
> --- a/package/alsa-plugins/alsa-plugins.mk
> +++ b/package/alsa-plugins/alsa-plugins.mk
> @@ -20,6 +20,10 @@ ALSA_PLUGINS_CONF_OPTS = \
>   	--disable-maemo-resource-manager \
>   	--with-speex=no
>   
> +ifeq ($(BR2_PACKAGE_ALSA_UTILS),y)
> +ALSA_PLUGINS_DEPENDENCIES += alsa-utils
> +endif
> +
>   ifeq ($(BR2_PACKAGE_LIBSAMPLERATE),y)
>   ALSA_PLUGINS_CONF_OPTS += --enable-samplerate
>   ALSA_PLUGINS_DEPENDENCIES += libsamplerate
> diff --git a/package/bluez-alsa/bluez-alsa.mk b/package/bluez-alsa/bluez-alsa.mk
> index 83dfce6177..649810b0ad 100644
> --- a/package/bluez-alsa/bluez-alsa.mk
> +++ b/package/bluez-alsa/bluez-alsa.mk
> @@ -20,6 +20,10 @@ BLUEZ_ALSA_CONF_OPTS = \
>   	--with-alsaplugindir=/usr/lib/alsa-lib \
>   	--with-alsaconfdir=/etc/alsa/conf.d
>   
> +ifeq ($(BR2_PACKAGE_ALSA_PLUGINS),y)
> +BLUEZ_ALSA_DEPENDENCIES += alsa-plugins
> +endif
> +
>   ifeq ($(BR2_PACKAGE_FDK_AAC),y)
>   BLUEZ_ALSA_DEPENDENCIES += fdk-aac
>   BLUEZ_ALSA_CONF_OPTS += --enable-aac
Peter Korsgaard July 16, 2023, 6:15 a.m. UTC | #2
>>>>> "Charles" == Charles Hardin <ckhardin@gmail.com> writes:

 > The alsa-utils will remove and create the /usr/share/alsa dir
 > as a whole and since the alsa plugins needs to add config into
 > this same directory it should come after those install steps.

 > Also, the bluez alsa needs the plugins installed to find them
 > during the configuration phases - so, interlock the plugins
 > when configured.

 > Signed-off-by: Charles Hardin <ckhardin@gmail.com>

Committed to 2023.02.x and 2023.05.x, thanks.
diff mbox series

Patch

diff --git a/package/alsa-plugins/alsa-plugins.mk b/package/alsa-plugins/alsa-plugins.mk
index 5728ebfe37..d23a81c5ee 100644
--- a/package/alsa-plugins/alsa-plugins.mk
+++ b/package/alsa-plugins/alsa-plugins.mk
@@ -20,6 +20,10 @@  ALSA_PLUGINS_CONF_OPTS = \
 	--disable-maemo-resource-manager \
 	--with-speex=no
 
+ifeq ($(BR2_PACKAGE_ALSA_UTILS),y)
+ALSA_PLUGINS_DEPENDENCIES += alsa-utils
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSAMPLERATE),y)
 ALSA_PLUGINS_CONF_OPTS += --enable-samplerate
 ALSA_PLUGINS_DEPENDENCIES += libsamplerate
diff --git a/package/bluez-alsa/bluez-alsa.mk b/package/bluez-alsa/bluez-alsa.mk
index 83dfce6177..649810b0ad 100644
--- a/package/bluez-alsa/bluez-alsa.mk
+++ b/package/bluez-alsa/bluez-alsa.mk
@@ -20,6 +20,10 @@  BLUEZ_ALSA_CONF_OPTS = \
 	--with-alsaplugindir=/usr/lib/alsa-lib \
 	--with-alsaconfdir=/etc/alsa/conf.d
 
+ifeq ($(BR2_PACKAGE_ALSA_PLUGINS),y)
+BLUEZ_ALSA_DEPENDENCIES += alsa-plugins
+endif
+
 ifeq ($(BR2_PACKAGE_FDK_AAC),y)
 BLUEZ_ALSA_DEPENDENCIES += fdk-aac
 BLUEZ_ALSA_CONF_OPTS += --enable-aac