diff mbox series

[v2,3/4] package/mpd: introduce id3tag feature dependency

Message ID 20221005091032.3014-4-br015@umbiko.net
State Accepted
Headers show
Series User-visible Config.in feature sub-options | expand

Commit Message

Andreas Ziegler Oct. 5, 2022, 9:10 a.m. UTC
id3tag is a sub-feature that is needed to extract information from mp3 files.
It selects the corresponding library and handles config settings. Two other
features need this sub-feature, but handle all library selections themselves
and omit enabling the id3tag feature. In consequence, users have to remember
to select both mp3 library and id3tag, otherwise the mpd executable will not
process mp3 files.

Reflect feature dependency in mpd Config.in to make id3tag selection automatic.

Signed-off-by: Andreas Ziegler <br015@umbiko.net>
---
Changes v1 -> v2:
 - make this a separate patch 

 package/mpd/Config.in | 4 ++--
 package/mpd/mpd.mk    | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

Comments

Thomas Petazzoni Aug. 6, 2023, 7:46 p.m. UTC | #1
On Wed,  5 Oct 2022 11:10:31 +0200
Andreas Ziegler <br015@umbiko.net> wrote:

> id3tag is a sub-feature that is needed to extract information from mp3 files.
> It selects the corresponding library and handles config settings. Two other
> features need this sub-feature, but handle all library selections themselves
> and omit enabling the id3tag feature. In consequence, users have to remember
> to select both mp3 library and id3tag, otherwise the mpd executable will not
> process mp3 files.
> 
> Reflect feature dependency in mpd Config.in to make id3tag selection automatic.
> 
> Signed-off-by: Andreas Ziegler <br015@umbiko.net>
> ---
> Changes v1 -> v2:
>  - make this a separate patch 

Applied to master, thanks.

Thomas
Peter Korsgaard Sept. 11, 2023, 7:23 a.m. UTC | #2
>>>>> "Andreas" == Andreas Ziegler <br015@umbiko.net> writes:

 > id3tag is a sub-feature that is needed to extract information from mp3 files.
 > It selects the corresponding library and handles config settings. Two other
 > features need this sub-feature, but handle all library selections themselves
 > and omit enabling the id3tag feature. In consequence, users have to remember
 > to select both mp3 library and id3tag, otherwise the mpd executable will not
 > process mp3 files.

 > Reflect feature dependency in mpd Config.in to make id3tag selection automatic.

 > Signed-off-by: Andreas Ziegler <br015@umbiko.net>
 > ---
 > Changes v1 -> v2:
 >  - make this a separate patch 

Committed to 2023.02.x and 2023.05.x, thanks.
diff mbox series

Patch

diff --git a/package/mpd/Config.in b/package/mpd/Config.in
index 2606008e90..daf1469cae 100644
--- a/package/mpd/Config.in
+++ b/package/mpd/Config.in
@@ -127,7 +127,7 @@  config BR2_PACKAGE_MPD_LIBSNDFILE
 config BR2_PACKAGE_MPD_MAD
 	bool "mad"
 	default y
-	select BR2_PACKAGE_LIBID3TAG
+	select BR2_PACKAGE_MPD_ID3TAG
 	select BR2_PACKAGE_LIBMAD
 	help
 	  Enable mad input support.
@@ -141,7 +141,7 @@  config BR2_PACKAGE_MPD_MODPLUG
 
 config BR2_PACKAGE_MPD_MPG123
 	bool "mpg123"
-	select BR2_PACKAGE_LIBID3TAG
+	select BR2_PACKAGE_MPD_ID3TAG
 	select BR2_PACKAGE_MPG123
 	help
 	  Enable mpg123 input support.
diff --git a/package/mpd/mpd.mk b/package/mpd/mpd.mk
index feab894f0f..1269b90661 100644
--- a/package/mpd/mpd.mk
+++ b/package/mpd/mpd.mk
@@ -190,7 +190,7 @@  MPD_CONF_OPTS += -Dsoxr=disabled
 endif
 
 ifeq ($(BR2_PACKAGE_MPD_MAD),y)
-MPD_DEPENDENCIES += libid3tag libmad
+MPD_DEPENDENCIES += libmad
 MPD_CONF_OPTS += -Dmad=enabled
 else
 MPD_CONF_OPTS += -Dmad=disabled
@@ -204,7 +204,7 @@  MPD_CONF_OPTS += -Dmodplug=disabled
 endif
 
 ifeq ($(BR2_PACKAGE_MPD_MPG123),y)
-MPD_DEPENDENCIES += libid3tag mpg123
+MPD_DEPENDENCIES += mpg123
 MPD_CONF_OPTS += -Dmpg123=enabled
 else
 MPD_CONF_OPTS += -Dmpg123=disabled