diff mbox series

[v2,1/4] package/mpd: fix reversed logic in tcp disable

Message ID 20221005091032.3014-2-br015@umbiko.net
State Accepted
Headers show
Series User-visible Config.in feature sub-options | expand

Commit Message

Andreas Ziegler Oct. 5, 2022, 9:10 a.m. UTC
Signed-off-by: Andreas Ziegler <br015@umbiko.net>
---
Changes v1 -> v2:
 - make this a separate patch 

 package/mpd/mpd.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Aug. 6, 2023, 7:42 p.m. UTC | #1
Hello Andreas,

On Wed,  5 Oct 2022 11:10:29 +0200
Andreas Ziegler <br015@umbiko.net> wrote:

> Signed-off-by: Andreas Ziegler <br015@umbiko.net>

I've extended this explanation with some details on when the issue was
introduced:

    package/mpd: fix reversed logic in tcp disable
    
    In commit 54b9008d482923131191da75f09966483f4ecac1 ("package/mpd: bump
    to version 0.21.11"), mpd was migrated from using the autotools build
    system to the meson build system.
    
    As part of this, the BR2_PACKAGE_MPD_TCP was incorrectly modified,
    leading BR2_PACKAGE_MPD_TCP disabled to actually enable TCP, and
    BR2_PACKAGE_MPD_TCP enabled to not explicitly enable TCP support.
    
    This commit fixes that by handling this option in the common way.
    
    Signed-off-by: Andreas Ziegler <br015@umbiko.net>
    Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

> +# default setting is 'true'
>  ifneq ($(BR2_PACKAGE_MPD_TCP),y)
> -MPD_CONF_OPTS += -Dtcp=true
> +MPD_CONF_OPTS += -Dtcp=false
>  endif

Changed to:

ifeq ($(BR2_PACKAGE_MPD_TCP),y)
MPD_CONF_OPTS += -Dtcp=true
else
MPD_CONF_OPTS += -Dtcp=false
endif

Applied to master with those changes.

Best regards,

Thomas
Peter Korsgaard Sept. 11, 2023, 7:22 a.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni via buildroot <buildroot@buildroot.org> writes:

 > Hello Andreas,
 > On Wed,  5 Oct 2022 11:10:29 +0200
 > Andreas Ziegler <br015@umbiko.net> wrote:

 >> Signed-off-by: Andreas Ziegler <br015@umbiko.net>

 > I've extended this explanation with some details on when the issue was
 > introduced:

 >     package/mpd: fix reversed logic in tcp disable
    
 >     In commit 54b9008d482923131191da75f09966483f4ecac1 ("package/mpd: bump
 >     to version 0.21.11"), mpd was migrated from using the autotools build
 >     system to the meson build system.
    
 >     As part of this, the BR2_PACKAGE_MPD_TCP was incorrectly modified,
 >     leading BR2_PACKAGE_MPD_TCP disabled to actually enable TCP, and
 >     BR2_PACKAGE_MPD_TCP enabled to not explicitly enable TCP support.
    
 >     This commit fixes that by handling this option in the common way.
    
 >     Signed-off-by: Andreas Ziegler <br015@umbiko.net>
 >     Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Committed to 2023.02.x and 2023.05.x, thanks.
diff mbox series

Patch

diff --git a/package/mpd/mpd.mk b/package/mpd/mpd.mk
index 5c15953984..4d73e6de03 100644
--- a/package/mpd/mpd.mk
+++ b/package/mpd/mpd.mk
@@ -285,8 +285,9 @@  else
 MPD_CONF_OPTS += -Dsqlite=disabled
 endif
 
+# default setting is 'true'
 ifneq ($(BR2_PACKAGE_MPD_TCP),y)
-MPD_CONF_OPTS += -Dtcp=true
+MPD_CONF_OPTS += -Dtcp=false
 endif
 
 ifeq ($(BR2_PACKAGE_MPD_TREMOR),y)