diff mbox series

[2/4] package/php: simplify icu configure options

Message ID 20220611131845.2605483-2-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [1/4] package/php: remove wddx extension | expand

Commit Message

Bernd Kuhls June 11, 2022, 1:18 p.m. UTC
Since php-7.4 upstream switched to pkg-config to detect icu:
https://github.com/php/php-src/commit/20fa2e7b58c519cc148d9658456b695884b1ecf4

Remove all unneeded code from php.mk.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/php/php.mk | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/package/php/php.mk b/package/php/php.mk
index 39db9d3a7c..d9c2edd839 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -176,13 +176,8 @@  endif
 endif
 
 ifeq ($(BR2_PACKAGE_PHP_EXT_INTL),y)
-PHP_CONF_OPTS += --enable-intl --with-icu-dir=$(STAGING_DIR)/usr
-PHP_CXXFLAGS += "`$(STAGING_DIR)/usr/bin/icu-config --cxxflags`"
+PHP_CONF_OPTS += --enable-intl
 PHP_DEPENDENCIES += icu
-# The intl module is implemented in C++, but PHP fails to use
-# g++ as the compiler for the final link. As a workaround,
-# tell it to link libstdc++.
-PHP_EXTRA_LIBS += -lstdc++
 endif
 
 ifeq ($(BR2_PACKAGE_PHP_EXT_GMP),y)