diff mbox series

[1/4] package/php: remove wddx extension

Message ID 20220611131845.2605483-1-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [1/4] package/php: remove wddx extension | expand

Commit Message

Bernd Kuhls June 11, 2022, 1:18 p.m. UTC
Upstream removed the wddx extension with version 7.4:
https://github.com/php/php-src/commit/6bbb18a0b6bef11222caaa55c00abdbcbb55d54b

and moved it to pecl: https://pecl.php.net/package/wddx

The pecl package is unmaintained however so we do not add it as a new
package to buildroot.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 Config.in.legacy       | 8 ++++++++
 package/php/Config.ext | 7 -------
 package/php/php.mk     | 5 -----
 3 files changed, 8 insertions(+), 12 deletions(-)

Comments

Arnout Vandecappelle June 14, 2022, 6:44 p.m. UTC | #1
On 11/06/2022 15:18, Bernd Kuhls wrote:
> Upstream removed the wddx extension with version 7.4:
> https://github.com/php/php-src/commit/6bbb18a0b6bef11222caaa55c00abdbcbb55d54b
> 
> and moved it to pecl: https://pecl.php.net/package/wddx
> 
> The pecl package is unmaintained however so we do not add it as a new
> package to buildroot.
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---

  Applied all 4 to master, thanks.

  Regards,
  Arnout

>   Config.in.legacy       | 8 ++++++++
>   package/php/Config.ext | 7 -------
>   package/php/php.mk     | 5 -----
>   3 files changed, 8 insertions(+), 12 deletions(-)
> 
> diff --git a/Config.in.legacy b/Config.in.legacy
> index 853a8917be..9d7bdfab10 100644
> --- a/Config.in.legacy
> +++ b/Config.in.legacy
> @@ -144,6 +144,14 @@ endif
>   
>   ###############################################################################
>   
> +comment "Legacy options removed in 2022.08"
> +
> +config BR2_PACKAGE_PHP_EXT_WDDX
> +	bool "php wddx removed"
> +	select BR2_LEGACY
> +	help
> +	  The WDDX extension was removed from php.
> +
>   comment "Legacy options removed in 2022.05"
>   
>   config BR2_PACKAGE_KTAP
> diff --git a/package/php/Config.ext b/package/php/Config.ext
> index 1c2af9fd15..d5f8659016 100644
> --- a/package/php/Config.ext
> +++ b/package/php/Config.ext
> @@ -385,13 +385,6 @@ config BR2_PACKAGE_PHP_EXT_SIMPLEXML
>   	help
>   	  SimpleXML support
>   
> -config BR2_PACKAGE_PHP_EXT_WDDX
> -	bool "WDDX"
> -	select BR2_PACKAGE_EXPAT
> -	select BR2_PACKAGE_PHP_EXT_LIBXML2
> -	help
> -	  WDDX support
> -
>   config BR2_PACKAGE_PHP_EXT_XML
>   	bool "XML Parser"
>   	select BR2_PACKAGE_PHP_EXT_LIBXML2
> diff --git a/package/php/php.mk b/package/php/php.mk
> index f649a9bb8b..39db9d3a7c 100644
> --- a/package/php/php.mk
> +++ b/package/php/php.mk
> @@ -150,11 +150,6 @@ PHP_CONF_OPTS += --with-libxml
>   PHP_DEPENDENCIES += libxml2
>   endif
>   
> -ifeq ($(BR2_PACKAGE_PHP_EXT_WDDX),y)
> -PHP_CONF_OPTS += --enable-wddx --with-libexpat-dir=$(STAGING_DIR)/usr
> -PHP_DEPENDENCIES += expat
> -endif
> -
>   ifeq ($(BR2_PACKAGE_PHP_EXT_ZIP),y)
>   PHP_DEPENDENCIES += libzip
>   endif
Peter Korsgaard July 18, 2022, 7:14 a.m. UTC | #2
On 11/06/2022 15.18, Bernd Kuhls wrote:
> Upstream removed the wddx extension with version 7.4:
> https://github.com/php/php-src/commit/6bbb18a0b6bef11222caaa55c00abdbcbb55d54b
> 
> and moved it to pecl: https://pecl.php.net/package/wddx
> 
> The pecl package is unmaintained however so we do not add it as a new
> package to buildroot.
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

Committed to 2022.02.x and 2022.05.x, thanks.
diff mbox series

Patch

diff --git a/Config.in.legacy b/Config.in.legacy
index 853a8917be..9d7bdfab10 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -144,6 +144,14 @@  endif
 
 ###############################################################################
 
+comment "Legacy options removed in 2022.08"
+
+config BR2_PACKAGE_PHP_EXT_WDDX
+	bool "php wddx removed"
+	select BR2_LEGACY
+	help
+	  The WDDX extension was removed from php.
+
 comment "Legacy options removed in 2022.05"
 
 config BR2_PACKAGE_KTAP
diff --git a/package/php/Config.ext b/package/php/Config.ext
index 1c2af9fd15..d5f8659016 100644
--- a/package/php/Config.ext
+++ b/package/php/Config.ext
@@ -385,13 +385,6 @@  config BR2_PACKAGE_PHP_EXT_SIMPLEXML
 	help
 	  SimpleXML support
 
-config BR2_PACKAGE_PHP_EXT_WDDX
-	bool "WDDX"
-	select BR2_PACKAGE_EXPAT
-	select BR2_PACKAGE_PHP_EXT_LIBXML2
-	help
-	  WDDX support
-
 config BR2_PACKAGE_PHP_EXT_XML
 	bool "XML Parser"
 	select BR2_PACKAGE_PHP_EXT_LIBXML2
diff --git a/package/php/php.mk b/package/php/php.mk
index f649a9bb8b..39db9d3a7c 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -150,11 +150,6 @@  PHP_CONF_OPTS += --with-libxml
 PHP_DEPENDENCIES += libxml2
 endif
 
-ifeq ($(BR2_PACKAGE_PHP_EXT_WDDX),y)
-PHP_CONF_OPTS += --enable-wddx --with-libexpat-dir=$(STAGING_DIR)/usr
-PHP_DEPENDENCIES += expat
-endif
-
 ifeq ($(BR2_PACKAGE_PHP_EXT_ZIP),y)
 PHP_DEPENDENCIES += libzip
 endif