diff mbox series

[v2,4/4] package/odb: add dependency on host-libodb

Message ID 20220310095602.2435745-5-kamel.bouhara@bootlin.com
State Accepted
Headers show
Series Add odb host variant and fix gcc-11 build | expand

Commit Message

Kamel Bouhara March 10, 2022, 9:56 a.m. UTC
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

host-odb installs the ODB compiler, which when executed at runtime,
needs access to the libodb headers. In order to have them installed,
add a dependency on host-libodb.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Kamel Bouhara <kamel.bouhara@bootlin.com>
[Kamel: Add optional host-libodb-boost dependency]
---
 package/odb/odb.mk | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard March 23, 2022, 9:03 p.m. UTC | #1
>>>>> "Kamel" == Kamel Bouhara via buildroot <buildroot@buildroot.org> writes:

 > From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
 > host-odb installs the ODB compiler, which when executed at runtime,
 > needs access to the libodb headers. In order to have them installed,
 > add a dependency on host-libodb.

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
 > Signed-off-by: Kamel Bouhara <kamel.bouhara@bootlin.com>
 > [Kamel: Add optional host-libodb-boost dependency]

Committed to 2021.02.x, 2021.11.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/odb/odb.mk b/package/odb/odb.mk
index 85c7ccb8bb..a234069952 100644
--- a/package/odb/odb.mk
+++ b/package/odb/odb.mk
@@ -10,7 +10,13 @@  ODB_SOURCE = odb-$(ODB_VERSION).tar.bz2
 ODB_SITE = https://www.codesynthesis.com/download/odb/$(ODB_VERSION_MAJOR)
 ODB_LICENSE = GPL-3.0
 ODB_LICENSE_FILES = LICENSE
-HOST_ODB_DEPENDENCIES = host-libcutl
+# host-libodb is not needed to build host-odb, but it is needed to use
+# the ODB compiler, as it install header files that are needed at
+# runtime by the odb compiler.
+HOST_ODB_DEPENDENCIES = host-libcutl host-libodb
+ifeq ($(BR2_PACKAGE_LIBODB_BOOST),y)
+HOST_ODB_DEPENDENCIES += host-libodb-boost
+endif
 HOST_ODB_CONF_ENV = CXXFLAGS="$(HOST_CXXFLAGS) -std=c++11"
 
 # Prevent odb from trying to install the gcc plugin into the hosts