diff mbox series

[v2,3/4] package/libodb-boost: add host variant

Message ID 20220310095602.2435745-4-kamel.bouhara@bootlin.com
State Accepted
Headers show
Series Add odb host variant and fix gcc-11 build | expand

Commit Message

Kamel Bouhara March 10, 2022, 9:56 a.m. UTC
Add host variant of libodb-boost required by the ODB compiler.
The libodb-boost headers are needed at compile time, and
therefore installed in $(HOST_DIR).

Signed-off-by: Kamel Bouhara <kamel.bouhara@bootlin.com>
---
 package/libodb-boost/libodb-boost.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Arnout Vandecappelle March 21, 2022, 9:01 p.m. UTC | #1
On 10/03/2022 10:56, Kamel Bouhara via buildroot wrote:
> Add host variant of libodb-boost required by the ODB compiler.
> The libodb-boost headers are needed at compile time, and
> therefore installed in $(HOST_DIR).
> 
> Signed-off-by: Kamel Bouhara <kamel.bouhara@bootlin.com>
> ---
>   package/libodb-boost/libodb-boost.mk | 2 ++
>   1 file changed, 2 insertions(+)
> 
> diff --git a/package/libodb-boost/libodb-boost.mk b/package/libodb-boost/libodb-boost.mk
> index bac5f1e78f..39c9f91030 100644
> --- a/package/libodb-boost/libodb-boost.mk
> +++ b/package/libodb-boost/libodb-boost.mk
> @@ -12,6 +12,8 @@ LIBODB_BOOST_INSTALL_STAGING = YES
>   LIBODB_BOOST_LICENSE = GPL-2.0
>   LIBODB_BOOST_LICENSE_FILES = LICENSE
>   LIBODB_BOOST_DEPENDENCIES = boost libodb
> +HOST_LIBODB_BOOST_DEPENDENCIES = hoost-boost host-libodb
>   LIBODB_BOOST_CONF_ENV = CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"

  I have not double-checked (since I don't know for which GCC version exactly 
this -std=c++11 is needed), but I expect that if -std=c++11 is needed for target 
build, it's also going to be needed for host build. So I added 
HOST_LIBODB_BOOST_CONF_ENV.


  Series applied to master with that fixed, thanks.

  Regards,
  Arnout


>   
>   $(eval $(autotools-package))
> +$(eval $(host-autotools-package))
Kamel Bouhara March 22, 2022, 9:40 a.m. UTC | #2
On Mon, Mar 21, 2022 at 10:01:40PM +0100, Arnout Vandecappelle wrote:
>
>
> On 10/03/2022 10:56, Kamel Bouhara via buildroot wrote:
> > Add host variant of libodb-boost required by the ODB compiler.
> > The libodb-boost headers are needed at compile time, and
> > therefore installed in $(HOST_DIR).
> >
> > Signed-off-by: Kamel Bouhara <kamel.bouhara@bootlin.com>
> > ---
> >   package/libodb-boost/libodb-boost.mk | 2 ++
> >   1 file changed, 2 insertions(+)
> >
> > diff --git a/package/libodb-boost/libodb-boost.mk b/package/libodb-boost/libodb-boost.mk
> > index bac5f1e78f..39c9f91030 100644
> > --- a/package/libodb-boost/libodb-boost.mk
> > +++ b/package/libodb-boost/libodb-boost.mk
> > @@ -12,6 +12,8 @@ LIBODB_BOOST_INSTALL_STAGING = YES
> >   LIBODB_BOOST_LICENSE = GPL-2.0
> >   LIBODB_BOOST_LICENSE_FILES = LICENSE
> >   LIBODB_BOOST_DEPENDENCIES = boost libodb
> > +HOST_LIBODB_BOOST_DEPENDENCIES = hoost-boost host-libodb
> >   LIBODB_BOOST_CONF_ENV = CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
>
>  I have not double-checked (since I don't know for which GCC version exactly
> this -std=c++11 is needed), but I expect that if -std=c++11 is needed for
> target build, it's also going to be needed for host build. So I added
> HOST_LIBODB_BOOST_CONF_ENV.
>

It seems required seems GCC 11: http://lists.busybox.net/pipermail/buildroot/2021-August/618575.html

Thanks,
Kamel

>
>  Series applied to master with that fixed, thanks.
>
>  Regards,
>  Arnout
>
>
> >   $(eval $(autotools-package))
> > +$(eval $(host-autotools-package))
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot

--
Kamel Bouhara, Bootlin
Embedded Linux and kernel engineering
https://bootlin.com
Peter Korsgaard March 23, 2022, 9:03 p.m. UTC | #3
>>>>> "Kamel" == Kamel Bouhara via buildroot <buildroot@buildroot.org> writes:

 > Add host variant of libodb-boost required by the ODB compiler.
 > The libodb-boost headers are needed at compile time, and
 > therefore installed in $(HOST_DIR).

 > Signed-off-by: Kamel Bouhara <kamel.bouhara@bootlin.com>

Committed to 2021.02.x, 2021.11.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/libodb-boost/libodb-boost.mk b/package/libodb-boost/libodb-boost.mk
index bac5f1e78f..39c9f91030 100644
--- a/package/libodb-boost/libodb-boost.mk
+++ b/package/libodb-boost/libodb-boost.mk
@@ -12,6 +12,8 @@  LIBODB_BOOST_INSTALL_STAGING = YES
 LIBODB_BOOST_LICENSE = GPL-2.0
 LIBODB_BOOST_LICENSE_FILES = LICENSE
 LIBODB_BOOST_DEPENDENCIES = boost libodb
+HOST_LIBODB_BOOST_DEPENDENCIES = hoost-boost host-libodb
 LIBODB_BOOST_CONF_ENV = CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
 
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))