diff mbox series

[4/5] package/sratom: new package

Message ID 20220107222613.4124764-4-james.hilliard1@gmail.com
State Superseded, archived
Headers show
Series [1/5] package/serd: new package | expand

Commit Message

James Hilliard Jan. 7, 2022, 10:26 p.m. UTC
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 DEVELOPERS                 |  1 +
 package/Config.in          |  1 +
 package/sratom/Config.in   | 10 ++++++++++
 package/sratom/sratom.hash |  4 ++++
 package/sratom/sratom.mk   | 21 +++++++++++++++++++++
 5 files changed, 37 insertions(+)
 create mode 100644 package/sratom/Config.in
 create mode 100644 package/sratom/sratom.hash
 create mode 100644 package/sratom/sratom.mk

Comments

Gilles Talis Jan. 13, 2022, 7 a.m. UTC | #1
Hi James, all,


Le ven. 7 janv. 2022 à 23:27, James Hilliard
<james.hilliard1@gmail.com> a écrit :
>
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>  DEVELOPERS                 |  1 +
>  package/Config.in          |  1 +
>  package/sratom/Config.in   | 10 ++++++++++
>  package/sratom/sratom.hash |  4 ++++
>  package/sratom/sratom.mk   | 21 +++++++++++++++++++++
>  5 files changed, 37 insertions(+)
>  create mode 100644 package/sratom/Config.in
>  create mode 100644 package/sratom/sratom.hash
>  create mode 100644 package/sratom/sratom.mk
>
> diff --git a/DEVELOPERS b/DEVELOPERS
> index 6c6e93f089..f8aa809294 100644
> --- a/DEVELOPERS
> +++ b/DEVELOPERS
> @@ -1302,6 +1302,7 @@ F:        package/python-yarl/
>  F:     package/python-zopfli/
>  F:     package/serd/
>  F:     package/sord/
> +F:     package/sratom/
>  F:     package/zchunk/
>
>  N:     James Knight <james.knight@collins.com>
> diff --git a/package/Config.in b/package/Config.in
> index a439a456a4..51a4180569 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -1369,6 +1369,7 @@ menu "Audio/Sound"
>         source "package/spandsp/Config.in"
>         source "package/speex/Config.in"
>         source "package/speexdsp/Config.in"
> +       source "package/sratom/Config.in"
>         source "package/taglib/Config.in"
>         source "package/tinyalsa/Config.in"
>         source "package/tremor/Config.in"
> diff --git a/package/sratom/Config.in b/package/sratom/Config.in
> new file mode 100644
> index 0000000000..771e82073d
> --- /dev/null
> +++ b/package/sratom/Config.in
> @@ -0,0 +1,10 @@
> +config BR2_PACKAGE_SRATOM
> +       bool "sratom"
> +       select BR2_PACKAGE_LV2
> +       select BR2_PACKAGE_SERD
> +       select BR2_PACKAGE_SORD
> +       help
> +         Sratom is a library for serialising LV2 atoms to and from
> +         RDF, particularly the Turtle syntax.
> +
> +         https://drobilla.net/software/sratom.html
> diff --git a/package/sratom/sratom.hash b/package/sratom/sratom.hash
> new file mode 100644
> index 0000000000..64d460b2ea
> --- /dev/null
> +++ b/package/sratom/sratom.hash
> @@ -0,0 +1,4 @@
> +# Locally calculated after checking signature
> +# https://download.drobilla.net/sratom-0.6.8.tar.bz2.asc
> +sha256  3acb32b1adc5a2b7facdade2e0818bcd6c71f23f84a1ebc17815bb7a0d2d02df  sratom-0.6.8.tar.bz2
> +sha256  3fc429d6b944fa20306357196a28bb4dd7c25e2d67edebec771f44de5bd7f9e8  COPYING
> diff --git a/package/sratom/sratom.mk b/package/sratom/sratom.mk
> new file mode 100644
> index 0000000000..e1e0f4e033
> --- /dev/null
> +++ b/package/sratom/sratom.mk
> @@ -0,0 +1,21 @@
> +################################################################################
> +#
> +# sratom
> +#
> +################################################################################
> +
> +SRATOM_VERSION = 0.6.8
> +SRATOM_SITE = https://download.drobilla.net
> +SRATOM_SOURCE = sratom-$(SRATOM_VERSION).tar.bz2
> +SRATOM_LICENSE = ISC
> +SRATOM_LICENSE_FILES = COPYING
> +SRATOM_DEPENDENCIES = host-pkgconf lv2 serd sord
> +SRATOM_INSTALL_STAGING = YES
> +
> +SRATOM_CONF_OPTS += --no-coverage
> +
> +ifeq ($(BR2_STATIC_LIBS),y)
> +SRATOM_CONF_OPTS += --static --no-shared
> +endif
> +
> +$(eval $(waf-package))
> --
> 2.25.1
>
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot

Ran compilation test on arm64 with external toolchain.
Also ran the test-pkg utility which did not go through for two
configurations due to dependency failure.
But:
Tested-by: Gilles Talis <gilles.talis@gmail.com>
anyway.
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 6c6e93f089..f8aa809294 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1302,6 +1302,7 @@  F:	package/python-yarl/
 F:	package/python-zopfli/
 F:	package/serd/
 F:	package/sord/
+F:	package/sratom/
 F:	package/zchunk/
 
 N:	James Knight <james.knight@collins.com>
diff --git a/package/Config.in b/package/Config.in
index a439a456a4..51a4180569 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1369,6 +1369,7 @@  menu "Audio/Sound"
 	source "package/spandsp/Config.in"
 	source "package/speex/Config.in"
 	source "package/speexdsp/Config.in"
+	source "package/sratom/Config.in"
 	source "package/taglib/Config.in"
 	source "package/tinyalsa/Config.in"
 	source "package/tremor/Config.in"
diff --git a/package/sratom/Config.in b/package/sratom/Config.in
new file mode 100644
index 0000000000..771e82073d
--- /dev/null
+++ b/package/sratom/Config.in
@@ -0,0 +1,10 @@ 
+config BR2_PACKAGE_SRATOM
+	bool "sratom"
+	select BR2_PACKAGE_LV2
+	select BR2_PACKAGE_SERD
+	select BR2_PACKAGE_SORD
+	help
+	  Sratom is a library for serialising LV2 atoms to and from
+	  RDF, particularly the Turtle syntax.
+
+	  https://drobilla.net/software/sratom.html
diff --git a/package/sratom/sratom.hash b/package/sratom/sratom.hash
new file mode 100644
index 0000000000..64d460b2ea
--- /dev/null
+++ b/package/sratom/sratom.hash
@@ -0,0 +1,4 @@ 
+# Locally calculated after checking signature
+# https://download.drobilla.net/sratom-0.6.8.tar.bz2.asc
+sha256  3acb32b1adc5a2b7facdade2e0818bcd6c71f23f84a1ebc17815bb7a0d2d02df  sratom-0.6.8.tar.bz2
+sha256  3fc429d6b944fa20306357196a28bb4dd7c25e2d67edebec771f44de5bd7f9e8  COPYING
diff --git a/package/sratom/sratom.mk b/package/sratom/sratom.mk
new file mode 100644
index 0000000000..e1e0f4e033
--- /dev/null
+++ b/package/sratom/sratom.mk
@@ -0,0 +1,21 @@ 
+################################################################################
+#
+# sratom
+#
+################################################################################
+
+SRATOM_VERSION = 0.6.8
+SRATOM_SITE = https://download.drobilla.net
+SRATOM_SOURCE = sratom-$(SRATOM_VERSION).tar.bz2
+SRATOM_LICENSE = ISC
+SRATOM_LICENSE_FILES = COPYING
+SRATOM_DEPENDENCIES = host-pkgconf lv2 serd sord
+SRATOM_INSTALL_STAGING = YES
+
+SRATOM_CONF_OPTS += --no-coverage
+
+ifeq ($(BR2_STATIC_LIBS),y)
+SRATOM_CONF_OPTS += --static --no-shared
+endif
+
+$(eval $(waf-package))