diff mbox series

[3/5] package/lv2: new package

Message ID 20220107222613.4124764-3-james.hilliard1@gmail.com
State Superseded, archived
Headers show
Series [1/5] package/serd: new package | expand

Commit Message

James Hilliard Jan. 7, 2022, 10:26 p.m. UTC
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 DEVELOPERS            |  1 +
 package/Config.in     |  1 +
 package/lv2/Config.in |  8 ++++++++
 package/lv2/lv2.hash  |  4 ++++
 package/lv2/lv2.mk    | 32 ++++++++++++++++++++++++++++++++
 5 files changed, 46 insertions(+)
 create mode 100644 package/lv2/Config.in
 create mode 100644 package/lv2/lv2.hash
 create mode 100644 package/lv2/lv2.mk

Comments

Gilles Talis Jan. 13, 2022, 6:57 a.m. UTC | #1
Hi James, all

Le ven. 7 janv. 2022 à 23:26, James Hilliard
<james.hilliard1@gmail.com> a écrit :
>
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>  DEVELOPERS            |  1 +
>  package/Config.in     |  1 +
>  package/lv2/Config.in |  8 ++++++++
>  package/lv2/lv2.hash  |  4 ++++
>  package/lv2/lv2.mk    | 32 ++++++++++++++++++++++++++++++++
>  5 files changed, 46 insertions(+)
>  create mode 100644 package/lv2/Config.in
>  create mode 100644 package/lv2/lv2.hash
>  create mode 100644 package/lv2/lv2.mk
>
> diff --git a/DEVELOPERS b/DEVELOPERS
> index bc54ab590c..6c6e93f089 100644
> --- a/DEVELOPERS
> +++ b/DEVELOPERS
> @@ -1254,6 +1254,7 @@ F:        package/exfatprogs/
>  F:     package/gensio/
>  F:     package/lua-std-debug/
>  F:     package/lua-std-normalize/
> +F:     package/lv2/
>  F:     package/pipewire/
>  F:     package/python-aioconsole/
>  F:     package/python-aiodns/
> diff --git a/package/Config.in b/package/Config.in
> index 6133d6ce32..a439a456a4 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -1358,6 +1358,7 @@ menu "Audio/Sound"
>         source "package/libsoundtouch/Config.in"
>         source "package/libsoxr/Config.in"
>         source "package/libvorbis/Config.in"
> +       source "package/lv2/Config.in"
>         source "package/mp4v2/Config.in"
>         source "package/openal/Config.in"
>         source "package/opencore-amr/Config.in"
> diff --git a/package/lv2/Config.in b/package/lv2/Config.in
> new file mode 100644
> index 0000000000..aeeb6d0451
> --- /dev/null
> +++ b/package/lv2/Config.in
> @@ -0,0 +1,8 @@
> +config BR2_PACKAGE_LV2
> +       bool "lv2"
> +       help
> +         LV2 is a plugin standard for audio systems. It defines
> +         a minimal yet extensible C API for plugin code and a
> +         format for plugin "bundles".
> +
> +         https://lv2plug.in/
> diff --git a/package/lv2/lv2.hash b/package/lv2/lv2.hash
> new file mode 100644
> index 0000000000..ed21620bee
> --- /dev/null
> +++ b/package/lv2/lv2.hash
> @@ -0,0 +1,4 @@
> +# Locally calculated after checking signature
> +# https://lv2plug.in/spec/lv2-1.18.2.tar.bz2.asc
> +sha256  4e891fbc744c05855beb5dfa82e822b14917dd66e98f82b8230dbd1c7ab2e05e  lv2-1.18.2.tar.bz2
> +sha256  0b0b07d852e3ce7fa04986e141f73001bd7f260683968f0a19e02dbcc4131aa6  COPYING
> diff --git a/package/lv2/lv2.mk b/package/lv2/lv2.mk
> new file mode 100644
> index 0000000000..589b518545
> --- /dev/null
> +++ b/package/lv2/lv2.mk
> @@ -0,0 +1,32 @@
> +################################################################################
> +#
> +# lv2
> +#
> +################################################################################
> +
> +LV2_VERSION = 1.18.2
> +LV2_SITE = https://lv2plug.in/spec
> +LV2_SOURCE = lv2-$(LV2_VERSION).tar.bz2
> +LV2_LICENSE = ISC
> +LV2_LICENSE_FILES = COPYING
> +LV2_DEPENDENCIES = host-pkgconf
> +LV2_INSTALL_STAGING = YES
> +
> +LV2_CONF_OPTS += \
> +       --no-coverage \
> +       --no-check-links \
> +       --copy-headers
> +
> +ifeq ($(BR2_PACKAGE_CAIRO),y)
> +LV2_DEPENDENCIES += cairo
> +endif
> +
> +ifeq ($(BR2_PACKAGE_LIBSNDFILE),y)
> +LV2_DEPENDENCIES += libsndfile
> +endif
> +
> +ifeq ($(BR2_PACKAGE_LIBGTK2),y)
> +LV2_DEPENDENCIES += libgtk2
> +endif
> +
> +$(eval $(waf-package))
> --
> 2.25.1
>
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot

I'm OK with your patch. Looks good to me.
test-pkg utility reported two failures though:
                   bootlin-armv5-uclibc [1/6]: OK
                    bootlin-armv7-glibc [2/6]: OK
                  bootlin-armv7m-uclibc [3/6]: FAILED
                    bootlin-x86-64-musl [4/6]: OK
                     br-arm-full-static [5/6]: FAILED
                           sourcery-arm [6/6]: OK

I will let you and the maintainers decide if the patch can be committed.
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index bc54ab590c..6c6e93f089 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1254,6 +1254,7 @@  F:	package/exfatprogs/
 F:	package/gensio/
 F:	package/lua-std-debug/
 F:	package/lua-std-normalize/
+F:	package/lv2/
 F:	package/pipewire/
 F:	package/python-aioconsole/
 F:	package/python-aiodns/
diff --git a/package/Config.in b/package/Config.in
index 6133d6ce32..a439a456a4 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1358,6 +1358,7 @@  menu "Audio/Sound"
 	source "package/libsoundtouch/Config.in"
 	source "package/libsoxr/Config.in"
 	source "package/libvorbis/Config.in"
+	source "package/lv2/Config.in"
 	source "package/mp4v2/Config.in"
 	source "package/openal/Config.in"
 	source "package/opencore-amr/Config.in"
diff --git a/package/lv2/Config.in b/package/lv2/Config.in
new file mode 100644
index 0000000000..aeeb6d0451
--- /dev/null
+++ b/package/lv2/Config.in
@@ -0,0 +1,8 @@ 
+config BR2_PACKAGE_LV2
+	bool "lv2"
+	help
+	  LV2 is a plugin standard for audio systems. It defines
+	  a minimal yet extensible C API for plugin code and a
+	  format for plugin "bundles".
+
+	  https://lv2plug.in/
diff --git a/package/lv2/lv2.hash b/package/lv2/lv2.hash
new file mode 100644
index 0000000000..ed21620bee
--- /dev/null
+++ b/package/lv2/lv2.hash
@@ -0,0 +1,4 @@ 
+# Locally calculated after checking signature
+# https://lv2plug.in/spec/lv2-1.18.2.tar.bz2.asc
+sha256  4e891fbc744c05855beb5dfa82e822b14917dd66e98f82b8230dbd1c7ab2e05e  lv2-1.18.2.tar.bz2
+sha256  0b0b07d852e3ce7fa04986e141f73001bd7f260683968f0a19e02dbcc4131aa6  COPYING
diff --git a/package/lv2/lv2.mk b/package/lv2/lv2.mk
new file mode 100644
index 0000000000..589b518545
--- /dev/null
+++ b/package/lv2/lv2.mk
@@ -0,0 +1,32 @@ 
+################################################################################
+#
+# lv2
+#
+################################################################################
+
+LV2_VERSION = 1.18.2
+LV2_SITE = https://lv2plug.in/spec
+LV2_SOURCE = lv2-$(LV2_VERSION).tar.bz2
+LV2_LICENSE = ISC
+LV2_LICENSE_FILES = COPYING
+LV2_DEPENDENCIES = host-pkgconf
+LV2_INSTALL_STAGING = YES
+
+LV2_CONF_OPTS += \
+	--no-coverage \
+	--no-check-links \
+	--copy-headers
+
+ifeq ($(BR2_PACKAGE_CAIRO),y)
+LV2_DEPENDENCIES += cairo
+endif
+
+ifeq ($(BR2_PACKAGE_LIBSNDFILE),y)
+LV2_DEPENDENCIES += libsndfile
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGTK2),y)
+LV2_DEPENDENCIES += libgtk2
+endif
+
+$(eval $(waf-package))