diff mbox series

[1/4] coreaudio: rename misnamed variable fake_as

Message ID 20201213130528.5863-1-vr_qemu@t-online.de
State New
Headers show
Series coreaudio bug fix and clean up | expand

Commit Message

Volker Rümelin Dec. 13, 2020, 1:05 p.m. UTC
While the variable once was used to fake audio settings, since
commit ed2a4a7941 "audio: proper support for float samples in
mixeng" this is no longer true. Rename the variable to obt_as.
This is the same naming scheme as in audio/sdlaudio.c

Tested-by: Howard Spoelstra <hsp.cat7@gmail.com>
Signed-off-by: Volker Rümelin <vr_qemu@t-online.de>
---
 audio/coreaudio.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Gerd Hoffmann Dec. 15, 2020, 8:16 a.m. UTC | #1
On Sun, Dec 13, 2020 at 02:05:25PM +0100, Volker Rümelin wrote:
> While the variable once was used to fake audio settings, since
> commit ed2a4a7941 "audio: proper support for float samples in
> mixeng" this is no longer true. Rename the variable to obt_as.
> This is the same naming scheme as in audio/sdlaudio.c
> 
> Tested-by: Howard Spoelstra <hsp.cat7@gmail.com>
> Signed-off-by: Volker Rümelin <vr_qemu@t-online.de>

Added all to audio queue.

thanks,
  Gerd
diff mbox series

Patch

diff --git a/audio/coreaudio.c b/audio/coreaudio.c
index 4b4365660f..0ee85052c4 100644
--- a/audio/coreaudio.c
+++ b/audio/coreaudio.c
@@ -482,7 +482,7 @@  static int coreaudio_init_out(HWVoiceOut *hw, struct audsettings *as,
     Audiodev *dev = drv_opaque;
     AudiodevCoreaudioPerDirectionOptions *cpdo = dev->u.coreaudio.out;
     int frames;
-    struct audsettings fake_as;
+    struct audsettings obt_as;
 
     /* create mutex */
     err = pthread_mutex_init(&core->mutex, NULL);
@@ -491,8 +491,8 @@  static int coreaudio_init_out(HWVoiceOut *hw, struct audsettings *as,
         return -1;
     }
 
-    fake_as = *as;
-    as = &fake_as;
+    obt_as = *as;
+    as = &obt_as;
     as->fmt = AUDIO_FORMAT_F32;
     audio_pcm_init_info (&hw->info, as);