diff mbox series

[10/19] ARM: renesas: Simplify weak symbols

Message ID 20240227160912.412181-11-marek.vasut+renesas@mailbox.org
State Accepted
Commit 217d7191b1c2803c821e7c285c4c85320829d3a3
Delegated to: Marek Vasut
Headers show
Series ARM: renesas: Rename R-Mobile to Renesas | expand

Commit Message

Marek Vasut Feb. 27, 2024, 4:05 p.m. UTC
Simplify the weak symbols use in cpu_info.c by using the __weak macro.
The result is identical, but the syntax is much simpler. Furthermore,
drop three more rmobile* symbols which are now unused.

Signed-off-by: Marek Vasut <marek.vasut+renesas@mailbox.org>
---
Cc: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
Cc: Paul Barker <paul.barker.ct@bp.renesas.com>
Cc: Tom Rini <trini@konsulko.com>
---
 arch/arm/mach-rmobile/cpu_info.c | 12 +++---------
 1 file changed, 3 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/arch/arm/mach-rmobile/cpu_info.c b/arch/arm/mach-rmobile/cpu_info.c
index 66ac6b3fcfb..2f9a4374a96 100644
--- a/arch/arm/mach-rmobile/cpu_info.c
+++ b/arch/arm/mach-rmobile/cpu_info.c
@@ -36,26 +36,20 @@  __weak const u8 *rzg_get_cpu_name(void)
 	return 0;
 }
 
-static u32 __rmobile_get_cpu_type(void)
+__weak u32 renesas_get_cpu_type(void)
 {
 	return 0x0;
 }
-u32 renesas_get_cpu_type(void)
-		__attribute__((weak, alias("__rmobile_get_cpu_type")));
 
-static u32 __rmobile_get_cpu_rev_integer(void)
+__weak u32 renesas_get_cpu_rev_integer(void)
 {
 	return 0;
 }
-u32 renesas_get_cpu_rev_integer(void)
-		__attribute__((weak, alias("__rmobile_get_cpu_rev_integer")));
 
-static u32 __rmobile_get_cpu_rev_fraction(void)
+__weak u32 renesas_get_cpu_rev_fraction(void)
 {
 	return 0;
 }
-u32 renesas_get_cpu_rev_fraction(void)
-		__attribute__((weak, alias("__rmobile_get_cpu_rev_fraction")));
 
 /* CPU information table */
 static const struct {