diff mbox

[U-Boot,1/2] Blackfin: drop initcode.o from combined object

Message ID 1290213082-8689-1-git-send-email-vapier@gentoo.org
State Accepted
Commit 4024242669a47cd4e138d0b6805a24e6d3d270e7
Delegated to: Mike Frysinger
Headers show

Commit Message

Mike Frysinger Nov. 20, 2010, 12:31 a.m. UTC
We explicitly link in the initcode.o in the Blackfin linker script, so
there is no need to merge it into the main common object for the linker
to pull in itself.  This also fixes duplicate symbol errors with the new
partial linking logic.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
 arch/blackfin/cpu/Makefile |    4 ----
 1 files changed, 0 insertions(+), 4 deletions(-)
diff mbox

Patch

diff --git a/arch/blackfin/cpu/Makefile b/arch/blackfin/cpu/Makefile
index 7c5400e..4a9e577 100644
--- a/arch/blackfin/cpu/Makefile
+++ b/arch/blackfin/cpu/Makefile
@@ -29,10 +29,6 @@  COBJS-y  += serial.o
 COBJS-y  += traps.o
 COBJS-$(CONFIG_HW_WATCHDOG)  += watchdog.o
 
-ifeq ($(CONFIG_BFIN_BOOT_MODE),BFIN_BOOT_BYPASS)
-COBJS-y  += initcode.o
-endif
-
 SRCS     := $(SEXTRA:.o=.S) $(SOBJS:.o=.S) $(COBJS-y:.o=.c)
 OBJS     := $(addprefix $(obj),$(COBJS-y) $(SOBJS))
 EXTRA    := $(addprefix $(obj),$(EXTRA))