mbox series

[U-Boot,v5,0/2] SF: add support for sst26wf016, sst26wf032, sst26wf064

Message ID 20180410114045.22121-1-Eugeniy.Paltsev@synopsys.com
Headers show
Series SF: add support for sst26wf016, sst26wf032, sst26wf064 | expand

Message

Eugeniy Paltsev April 10, 2018, 11:40 a.m. UTC
Add support for the SST sst26wf016, sst26wf032 and sst26wf064 flash IC:

sst26wf*** flash series block protection implementation differs from other
SST series, so we add implementation for sst26wf*** lock/unlock/is_locked
functions.

Add sst26wf016, sst26wf032 and sst26wf064 flash IC info to spi_flash_ids list.

Changes v4->v5:
 * Return EACCES when flash is locked instead of custom define (SF_LOCKED)
 * Add SST26_CTL_* prefix to sst27 lock ops enum.
 * Move all sst26 code inside of existing CONFIG_SPI_FLASH_SST #ifdef.

Changes v3->v4:
 * Make sst26_process_bpr() and sst26_lock_ctl() functions static.

Changes v2->v3:
 * Move SST26 command defenition to sf_internal.h
 * Merge sst26_set_bpr, sst26_clear_bpr and sst26_check_bpr functions
   into single sst26_process_bpr function.
 * Use SF_UNLOCKED/SF_LOCKED instead of magic numbers in
   sst26_lock_ctl()

Changes v1->v2:
 * Use generic defines from linux/sizes.h instead of custom ones.

Eugeniy Paltsev (2):
  SPI Flash: add support of sst26wf* flash ICs protection ops
  SF: add support for sst26wf016, sst26wf032, sst26wf064

 drivers/mtd/spi/sf_internal.h   |  18 +++++
 drivers/mtd/spi/spi_flash.c     | 165 ++++++++++++++++++++++++++++++++++++++++
 drivers/mtd/spi/spi_flash_ids.c |   3 +
 3 files changed, 186 insertions(+)

Comments

Jagan Teki April 19, 2018, 11:25 a.m. UTC | #1
On Tue, Apr 10, 2018 at 5:10 PM, Eugeniy Paltsev
<Eugeniy.Paltsev@synopsys.com> wrote:
> Add support for the SST sst26wf016, sst26wf032 and sst26wf064 flash IC:
>
> sst26wf*** flash series block protection implementation differs from other
> SST series, so we add implementation for sst26wf*** lock/unlock/is_locked
> functions.
>
> Add sst26wf016, sst26wf032 and sst26wf064 flash IC info to spi_flash_ids list.
>
> Changes v4->v5:
>  * Return EACCES when flash is locked instead of custom define (SF_LOCKED)
>  * Add SST26_CTL_* prefix to sst27 lock ops enum.
>  * Move all sst26 code inside of existing CONFIG_SPI_FLASH_SST #ifdef.
>
> Changes v3->v4:
>  * Make sst26_process_bpr() and sst26_lock_ctl() functions static.
>
> Changes v2->v3:
>  * Move SST26 command defenition to sf_internal.h
>  * Merge sst26_set_bpr, sst26_clear_bpr and sst26_check_bpr functions
>    into single sst26_process_bpr function.
>  * Use SF_UNLOCKED/SF_LOCKED instead of magic numbers in
>    sst26_lock_ctl()
>
> Changes v1->v2:
>  * Use generic defines from linux/sizes.h instead of custom ones.
>
> Eugeniy Paltsev (2):
>   SPI Flash: add support of sst26wf* flash ICs protection ops
>   SF: add support for sst26wf016, sst26wf032, sst26wf064

Applied to u-boot-spi/master