diff mbox series

[OpenWrt-Devel] ath79: align GL-AR750S boardname to other GL.iNet devices

Message ID mailman.12301.1546344197.2376.openwrt-devel@lists.openwrt.org
State Accepted
Delegated to: Mathias Kresin
Headers show
Series [OpenWrt-Devel] ath79: align GL-AR750S boardname to other GL.iNet devices | expand

Commit Message

Thomas Richard via openwrt-devel Jan. 1, 2019, 12:03 p.m. UTC
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
As the official device name is GL-AR750S, rename the board accordingly.

Signed-off-by: Christoph Krapp <achterin@googlemail.com>
---
 target/linux/ath79/base-files/etc/board.d/02_network     | 2 +-
 .../base-files/etc/hotplug.d/firmware/11-ath10k-caldata  | 9 +++------
 ...63_glinet_ar750s.dts => qca9563_glinet_gl-ar750s.dts} | 2 +-
 target/linux/ath79/image/generic.mk                      | 4 ++--
 4 files changed, 7 insertions(+), 10 deletions(-)
 rename target/linux/ath79/dts/{qca9563_glinet_ar750s.dts => qca9563_glinet_gl-ar750s.dts} (98%)

Comments

Christian Lamparter Jan. 1, 2019, 5:23 p.m. UTC | #1
On Tuesday, January 1, 2019 1:03:22 PM CET Christoph Krapp via openwrt-devel wrote:
> The sender domain has a DMARC Reject/Quarantine policy which disallows
> sending mailing list messages using the original "From" header.
> 
> To mitigate this problem, the original message has been wrapped
> automatically by the mailing list software.
I had this problem (DMARC Reject/Quarantine policy) in the past as well.
If you want to fix it you need to convert your account from googlemail.com 
to gmail.com (and update your git config and commits to reflect the change). 

As for the patch:

>-define Device/glinet_ar750s
>+define Device/glinet_gl-ar750s
>   ATH_SOC := qca9563
>   DEVICE_TITLE := GL.iNet GL-AR750S
>   DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
>   IMAGE_SIZE := 16000k
>   SUPPORTED_DEVICES += gl-ar750s
> endef
>-TARGET_DEVICES += glinet_ar750s
>+TARGET_DEVICES += glinet_gl-ar750s

The "Device/glinet_ar750s" change to "Device/glinet_gl-ar750s" will likely
break sysupgrade from existing "glinet_ar750s" images. This is because the
now deprecated glinet_ar750s identifier was not added to the
SUPPORTED_DEVICES variable. Other than that, it looks good.

Regards,
Christian
Thomas Richard via openwrt-devel Jan. 1, 2019, 6:42 p.m. UTC | #2
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
> I had this problem (DMARC Reject/Quarantine policy) in the past as well.
> If you want to fix it you need to convert your account from googlemail.com
> to gmail.com (and update your git config and commits to reflect the change).
Thx for the hint. Will try that next time.

> The "Device/glinet_ar750s" change to "Device/glinet_gl-ar750s" will likely
> break sysupgrade from existing "glinet_ar750s" images. This is because the
> now deprecated glinet_ar750s identifier was not added to the
> SUPPORTED_DEVICES variable. Other than that, it looks good.
As the support for this device got merged 2 days ago i don't think its
that important.
Furthermore commits like 8ba76d6 & 6e78d54 got merged without the requested
addition, even tough these devices are support way longer.

Regards,
Christoph
Mathias Kresin Jan. 1, 2019, 6:47 p.m. UTC | #3
01/01/2019 18:23, Christian Lamparter:
> The "Device/glinet_ar750s" change to "Device/glinet_gl-ar750s" will likely
> break sysupgrade from existing "glinet_ar750s" images. This is because the
> now deprecated glinet_ar750s identifier was not added to the
> SUPPORTED_DEVICES variable. Other than that, it looks good.

Should be fine here, as no ath79 release image for the ar750s exists. At 
least I only take care of compatibility to release images.

Mathias
Piotr Dymacz Jan. 1, 2019, 6:48 p.m. UTC | #4
Hi Christian,

On 01.01.2019 18:23, Christian Lamparter wrote:
> On Tuesday, January 1, 2019 1:03:22 PM CET Christoph Krapp via openwrt-devel wrote:
>> The sender domain has a DMARC Reject/Quarantine policy which disallows
>> sending mailing list messages using the original "From" header.
>> 
>> To mitigate this problem, the original message has been wrapped
>> automatically by the mailing list software.
> I had this problem (DMARC Reject/Quarantine policy) in the past as well.
> If you want to fix it you need to convert your account from googlemail.com
> to gmail.com (and update your git config and commits to reflect the change).
> 
> As for the patch:
> 
>>-define Device/glinet_ar750s
>>+define Device/glinet_gl-ar750s
>>   ATH_SOC := qca9563
>>   DEVICE_TITLE := GL.iNet GL-AR750S
>>   DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
>>   IMAGE_SIZE := 16000k
>>   SUPPORTED_DEVICES += gl-ar750s
>> endef
>>-TARGET_DEVICES += glinet_ar750s
>>+TARGET_DEVICES += glinet_gl-ar750s
> 
> The "Device/glinet_ar750s" change to "Device/glinet_gl-ar750s" will likely
> break sysupgrade from existing "glinet_ar750s" images. This is because the
> now deprecated glinet_ar750s identifier was not added to the
> SUPPORTED_DEVICES variable. Other than that, it looks good.

And this is fine as there hasn't been any stable release with ath79.
Please, keep the correct name only.
diff mbox series

Patch

diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index e24c58e208..6776506893 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -100,7 +100,7 @@  ath79_setup_interfaces()
 	tplink,tl-wr810n-v2)
 		ucidef_set_interfaces_lan_wan "eth1" "eth0"
 		;;
-	glinet,ar750s)
+	glinet,gl-ar750s)
 		ucidef_add_switch "switch0" \
 			"0@eth0" "2:lan:2" "3:lan:1" "1:wan"
 		;;
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 441893a752..faee781970 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -99,13 +99,10 @@  case "$FIRMWARE" in
 	elecom,wrc-1750ghbk2-i)
 		ath10kcal_extract "ART" 20480 2116
 		;;
-	glinet,ar750s|\
-	tplink,re450-v2)
-		ath10kcal_extract "art" 20480 2116
-		ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
-		;;
 	engenius,ews511ap|\
-	glinet,gl-x750)
+	glinet,gl-ar750s|\
+	glinet,gl-x750|\
+	tplink,re450-v2)
 		ath10kcal_extract "art" 20480 2116
 		ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
 		;;
diff --git a/target/linux/ath79/dts/qca9563_glinet_ar750s.dts b/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
similarity index 98%
rename from target/linux/ath79/dts/qca9563_glinet_ar750s.dts
rename to target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
index ab33bc13e3..439acaae85 100644
--- a/target/linux/ath79/dts/qca9563_glinet_ar750s.dts
+++ b/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
@@ -7,7 +7,7 @@ 
 #include "qca956x.dtsi"
 
 / {
-	compatible = "glinet,ar750s", "qca,qca9563";
+	compatible = "glinet,gl-ar750s", "qca,qca9563";
 	model = "GL.iNet GL-AR750S";
 
 	chosen {
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 326633835d..858c1662cc 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -289,14 +289,14 @@  define Device/glinet_gl-ar300m-nor
 endef
 TARGET_DEVICES += glinet_gl-ar300m-nor
 
-define Device/glinet_ar750s
+define Device/glinet_gl-ar750s
   ATH_SOC := qca9563
   DEVICE_TITLE := GL.iNet GL-AR750S
   DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
   IMAGE_SIZE := 16000k
   SUPPORTED_DEVICES += gl-ar750s
 endef
-TARGET_DEVICES += glinet_ar750s
+TARGET_DEVICES += glinet_gl-ar750s
 
 define Device/glinet_gl-x750
   ATH_SOC := qca9531