diff mbox series

[OpenWrt-Devel,openwrt-devel,5/8] uboot-at91: bump linux4sam_5.8 to linux4sam_6.0

Message ID e80ff67f5a4cb0a6cd83c60ef0e39102b1eb03f7.1539384007.git.sandeepsheriker.mallikarjun@microchip.com
State Changes Requested
Delegated to: John Crispin
Headers show
Series [OpenWrt-Devel,openwrt-devel,1/8] at91:renaming subtraget legacy to sam9x | expand

Commit Message

Sandeep Sheriker Oct. 12, 2018, 10:41 p.m. UTC
1. add support to build u-boot binaries for at91sam9x5ek socs
2. removed sama5d27_som1_ek_spiflash defconfig since this is
   removed in linux4sam_6.0 release
3. add -Wno-format-security in cflags for build success.

Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
---
 package/boot/uboot-at91/Makefile | 24 +++++++++++++-----------
 1 file changed, 13 insertions(+), 11 deletions(-)

Comments

Hauke Mehrtens Oct. 20, 2018, 1:05 p.m. UTC | #1
On 10/13/2018 12:41 AM, Sandeep Sheriker Mallikarjun wrote:
> 1. add support to build u-boot binaries for at91sam9x5ek socs
> 2. removed sama5d27_som1_ek_spiflash defconfig since this is
>    removed in linux4sam_6.0 release
> 3. add -Wno-format-security in cflags for build success.
> 
> Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
> ---
>  package/boot/uboot-at91/Makefile | 24 +++++++++++++-----------
>  1 file changed, 13 insertions(+), 11 deletions(-)
> 
> diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
> index 9304ab4..31ed7c7 100644
> --- a/package/boot/uboot-at91/Makefile
> +++ b/package/boot/uboot-at91/Makefile
> @@ -7,12 +7,12 @@
>  
>  include $(TOPDIR)/rules.mk
>  
> -PKG_VERSION:=linux4sam_5.8
> +PKG_VERSION:=linux4sam_6.0
>  PKG_RELEASE:=1
>  
>  PKG_SOURCE_PROTO:=git
>  PKG_SOURCE_URL:=https://github.com/linux4sam/u-boot-at91.git
> -PKG_SOURCE_VERSION:=59f202622154f82e708a6ca2bf86350a5c1b2d33
> +PKG_SOURCE_VERSION:=1e7d2e5973c1fb780e55e28a801c6c574158ac14
>  
>  include $(INCLUDE_DIR)/u-boot.mk
>  include $(INCLUDE_DIR)/package.mk
> @@ -38,6 +38,14 @@ define U-Boot/at91sam9x5ek_nandflash
>  				 at91sam9x35ek
>  endef
>  
> +define U-Boot/at91sam9x5ek_mmc
> +  NAME:=AT91SAM9X5-EK board (SDcard)
> +  BUILD_SUBTARGET:=sam9x
> +  BUILD_DEVICES:=at91sam9g15ek at91sam9g25ek \
> +                 at91sam9g35ek at91sam9x25ek \
> +				 at91sam9x35ek
> +endef
> +
>  define U-Boot/sama5d3_xplained_nandflash
>    NAME:=SAMA5D3 Xplained board (NandFlash)
>    BUILD_SUBTARGET:=sama5d3
> @@ -86,12 +94,6 @@ define U-Boot/sama5d27_som1_ek_mmc
>    BUILD_DEVICES:=at91-sama5d27_som1_ek
>  endef
>  
> -define U-Boot/sama5d27_som1_ek_spiflash
> -  NAME:=SAMA5D27 SOM1 Ek (QSPI Flash)
> -  BUILD_SUBTARGET:=sama5d2
> -  BUILD_DEVICES:=at91-sama5d27_som1_ek
> -endef
> -
>  define U-Boot/sama5d2_ptc_ek_nandflash
>    NAME:=SAMA5D2 PTC Ek (Nand Flash)
>    BUILD_SUBTARGET:=sama5d2
> @@ -107,6 +109,7 @@ endef
>  UBOOT_TARGETS := \
>  	at91sam9m10g45ek_nandflash \
>  	at91sam9x5ek_nandflash \
> +	at91sam9x5ek_mmc \
>  	sama5d3_xplained_nandflash \
>  	sama5d3_xplained_mmc \
>  	sama5d2_xplained_mmc \
> @@ -115,16 +118,15 @@ UBOOT_TARGETS := \
>  	sama5d4_xplained_spiflash \
>  	sama5d4_xplained_nandflash\
>      sama5d27_som1_ek_mmc \
> -    sama5d27_som1_ek_spiflash \
>  	sama5d2_ptc_ek_nandflash \
>  	sama5d2_ptc_ek_mmc
>  
>  define Build/Compile
>    +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
>       CROSS_COMPILE=$(TARGET_CROSS) \
> -	 DTC=$(LINUX_DIR)/scripts/dtc/dtc \
> +	 DTC=$(PKG_BUILD_DIR)/scripts/dtc/dtc \
>       KCFLAGS="$(filter-out -fstack-protector \
> -      -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft"
> +      -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft -Wno-format-security"

Could you please fix the problem with the string handling in your code
instead of ignoring the warnings, this could be a security problem.

>  endef
>  
>  $(eval $(call BuildPackage/U-Boot))
>
diff mbox series

Patch

diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 9304ab4..31ed7c7 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -7,12 +7,12 @@ 
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=linux4sam_5.8
+PKG_VERSION:=linux4sam_6.0
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/linux4sam/u-boot-at91.git
-PKG_SOURCE_VERSION:=59f202622154f82e708a6ca2bf86350a5c1b2d33
+PKG_SOURCE_VERSION:=1e7d2e5973c1fb780e55e28a801c6c574158ac14
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
@@ -38,6 +38,14 @@  define U-Boot/at91sam9x5ek_nandflash
 				 at91sam9x35ek
 endef
 
+define U-Boot/at91sam9x5ek_mmc
+  NAME:=AT91SAM9X5-EK board (SDcard)
+  BUILD_SUBTARGET:=sam9x
+  BUILD_DEVICES:=at91sam9g15ek at91sam9g25ek \
+                 at91sam9g35ek at91sam9x25ek \
+				 at91sam9x35ek
+endef
+
 define U-Boot/sama5d3_xplained_nandflash
   NAME:=SAMA5D3 Xplained board (NandFlash)
   BUILD_SUBTARGET:=sama5d3
@@ -86,12 +94,6 @@  define U-Boot/sama5d27_som1_ek_mmc
   BUILD_DEVICES:=at91-sama5d27_som1_ek
 endef
 
-define U-Boot/sama5d27_som1_ek_spiflash
-  NAME:=SAMA5D27 SOM1 Ek (QSPI Flash)
-  BUILD_SUBTARGET:=sama5d2
-  BUILD_DEVICES:=at91-sama5d27_som1_ek
-endef
-
 define U-Boot/sama5d2_ptc_ek_nandflash
   NAME:=SAMA5D2 PTC Ek (Nand Flash)
   BUILD_SUBTARGET:=sama5d2
@@ -107,6 +109,7 @@  endef
 UBOOT_TARGETS := \
 	at91sam9m10g45ek_nandflash \
 	at91sam9x5ek_nandflash \
+	at91sam9x5ek_mmc \
 	sama5d3_xplained_nandflash \
 	sama5d3_xplained_mmc \
 	sama5d2_xplained_mmc \
@@ -115,16 +118,15 @@  UBOOT_TARGETS := \
 	sama5d4_xplained_spiflash \
 	sama5d4_xplained_nandflash\
     sama5d27_som1_ek_mmc \
-    sama5d27_som1_ek_spiflash \
 	sama5d2_ptc_ek_nandflash \
 	sama5d2_ptc_ek_mmc
 
 define Build/Compile
   +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
      CROSS_COMPILE=$(TARGET_CROSS) \
-	 DTC=$(LINUX_DIR)/scripts/dtc/dtc \
+	 DTC=$(PKG_BUILD_DIR)/scripts/dtc/dtc \
      KCFLAGS="$(filter-out -fstack-protector \
-      -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft"
+      -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft -Wno-format-security"
 endef
 
 $(eval $(call BuildPackage/U-Boot))