diff mbox series

[v1] x86 64: Add driver for Silicom Platform device

Message ID DU0PR04MB9660CEF3C80D29F09CD2750EBDAAA@DU0PR04MB9660.eurprd04.prod.outlook.com
State New
Headers show
Series [v1] x86 64: Add driver for Silicom Platform device | expand

Commit Message

Xiaojun Liu Nov. 6, 2023, 8:42 a.m. UTC
Add Silicom platform driver for Swisscom BB
and Cordoba family products.
This platform driver provides support for various functions
via the linux LED framework, GPIO framework,
Hardware Monitoring (HWMON) and device attributes.
    
Signed-off-by: Xiaojun Liu mailto:xiaojun.liu@silicom.co.il
--

package/kernel/silicom-platform/Makefile | 44 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)
diff mbox series

Patch

diff --git a/package/kernel/silicom-platform/Makefile b/package/kernel/silicom-platform/Makefile
new file mode 100644
index 0000000000..a3770cd3e0
--- /dev/null
+++ b/package/kernel/silicom-platform/Makefile
@@ -0,0 +1,44 @@ 
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=silicom-platform
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/silicom-ltd/openwrt-silc-drv.git
+PKG_SOURCE_DATE:=2023-11-03
+PKG_SOURCE_VERSION:=fa48edb29dc88af35f3d5eda80258ebff4fdbefe
+PKG_MIRROR_HASH:=07ae21062417110897770983eabadb69c87b1e9824e33b63c3a4313c4a7b37a0
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=COPYING
+
+PKG_MAINTAINER:=Xiaojun Liu <xiaojun.liu@silicom.co.il>
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/silicom-platform
+  SUBMENU:=Other modules
+  TITLE:=Silicom Platform driver for Swisscom BB and Cordoba family products 
+  FILES:=\
+	$(PKG_BUILD_DIR)/$(PKG_NAME)/silicom-platform.ko
+  AUTOLOAD:=$(call AutoProbe,silicom-platform)
+endef
+
+define KernelPackage/silicom-platform/description
+  This platform driver provides support for various functions via
+  the Linux LED framework, GPIO framework, Hardware Monitoring (HWMON)
+  and device attributes.
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+        $(KERNEL_MAKE) $(PKG_JOBS) \
+		M="$(PKG_BUILD_DIR)/$(PKG_NAME)" \
+		modules
+endef
+
+$(eval $(call KernelPackage,silicom-platform))