diff mbox series

Subject: [PATCH] x86 64: Add new device Cordoba Edge Platform

Message ID DU0PR04MB96607F2237498AD5BAFA467CBDD4A@DU0PR04MB9660.eurprd04.prod.outlook.com
State New
Headers show
Series Subject: [PATCH] x86 64: Add new device Cordoba Edge Platform | expand

Commit Message

Xiaojun Liu Oct. 19, 2023, 2:44 a.m. UTC
Add new device Cordoba Edge Platform
Device name: Cordoba Edge Platform
hardware specifications: CPU - Intel Atom C3000
                         WiFi - mt7915e

Signed-off-by: Xiaojun Liu mailto:xiaojun.liu@silicom.co.il
---
target/linux/x86/image/64.mk | 11 +++++++++++
1 file changed, 11 insertions(+)

Comments

Philip Prindeville Oct. 23, 2023, 5:04 a.m. UTC | #1
Doesn't this just have ixgbe and igc NIC's?  And the mt7915e of course.

Don't think we need the amd-xgbe, bnx2, e1000e, e1000, r8169, tg3 drivers.

The BIOS we've been using has some odd enumeration of the PCI bus, so you might want to include a patch for target/linux/x86/base-files/etc/board.d/02_network

And bind the PCI addresses to the ethernet device names.



> On Oct 18, 2023, at 8:44 PM, Xiaojun Liu <xiaojun.liu@silicom.co.il> wrote:
> 
> Add new device Cordoba Edge Platform
> Device name: Cordoba Edge Platform
> hardware specifications: CPU - Intel Atom C3000
>                          WiFi - mt7915e
> 
> Signed-off-by: Xiaojun Liu mailto:xiaojun.liu@silicom.co.il
> ---
> target/linux/x86/image/64.mk | 11 +++++++++++
> 1 file changed, 11 insertions(+)
> 
> diff --git a/target/linux/x86/image/64.mk b/target/linux/x86/image/64.mk
> index 5ec9978b66..04ce0be13a 100644
> --- a/target/linux/x86/image/64.mk
> +++ b/target/linux/x86/image/64.mk
> @@ -8,3 +8,14 @@ define Device/generic
>    GRUB2_VARIANT := generic
> endef
> TARGET_DEVICES += generic
> +
> +define Device/cordoba
> +  DEVICE_VENDOR := Cordoba
> +  DEVICE_MODEL := x86/64
> +  DEVICE_PACKAGES += \
> +        kmod-amazon-ena kmod-amd-xgbe kmod-bnx2 kmod-e1000e kmod-e1000 \
> +        kmod-forcedeth kmod-fs-vfat kmod-igb kmod-igc kmod-ixgbe kmod-r8169 \
> +        kmod-tg3 kmod-mt7915-firmware
> +  GRUB2_VARIANT := generic
> +endef
> +TARGET_DEVICES += cordoba
> 
>
Xiaojun Liu Oct. 23, 2023, 9:42 a.m. UTC | #2
Thanks for your reminding!  I will update my patch to fix these issues.

-----Original Message-----
From: Philip Prindeville <philipp_subx@redfish-solutions.com> 
Sent: Monday, October 23, 2023 1:05 PM
To: Xiaojun Liu <xiaojun.liu@silicom.co.il>
Cc: openwrt-devel@lists.openwrt.org
Subject: Re: Subject: [PATCH] x86 64: Add new device Cordoba Edge Platform

Doesn't this just have ixgbe and igc NIC's?  And the mt7915e of course.

Don't think we need the amd-xgbe, bnx2, e1000e, e1000, r8169, tg3 drivers.

The BIOS we've been using has some odd enumeration of the PCI bus, so you might want to include a patch for target/linux/x86/base-files/etc/board.d/02_network

And bind the PCI addresses to the ethernet device names.



> On Oct 18, 2023, at 8:44 PM, Xiaojun Liu <xiaojun.liu@silicom.co.il> wrote:
> 
> Add new device Cordoba Edge Platform
> Device name: Cordoba Edge Platform
> hardware specifications: CPU - Intel Atom C3000
>                          WiFi - mt7915e
> 
> Signed-off-by: Xiaojun Liu mailto:xiaojun.liu@silicom.co.il
> ---
> target/linux/x86/image/64.mk | 11 +++++++++++
> 1 file changed, 11 insertions(+)
> 
> diff --git a/target/linux/x86/image/64.mk 
> b/target/linux/x86/image/64.mk index 5ec9978b66..04ce0be13a 100644
> --- a/target/linux/x86/image/64.mk
> +++ b/target/linux/x86/image/64.mk
> @@ -8,3 +8,14 @@ define Device/generic
>    GRUB2_VARIANT := generic
> endef
> TARGET_DEVICES += generic
> +
> +define Device/cordoba
> +  DEVICE_VENDOR := Cordoba
> +  DEVICE_MODEL := x86/64
> +  DEVICE_PACKAGES += \
> +        kmod-amazon-ena kmod-amd-xgbe kmod-bnx2 kmod-e1000e kmod-e1000 \
> +        kmod-forcedeth kmod-fs-vfat kmod-igb kmod-igc kmod-ixgbe kmod-r8169 \
> +        kmod-tg3 kmod-mt7915-firmware
> +  GRUB2_VARIANT := generic
> +endef
> +TARGET_DEVICES += cordoba
> 
>
diff mbox series

Patch

diff --git a/target/linux/x86/image/64.mk b/target/linux/x86/image/64.mk
index 5ec9978b66..04ce0be13a 100644
--- a/target/linux/x86/image/64.mk
+++ b/target/linux/x86/image/64.mk
@@ -8,3 +8,14 @@  define Device/generic
   GRUB2_VARIANT := generic
endef
TARGET_DEVICES += generic
+
+define Device/cordoba
+  DEVICE_VENDOR := Cordoba
+  DEVICE_MODEL := x86/64
+  DEVICE_PACKAGES += \
+        kmod-amazon-ena kmod-amd-xgbe kmod-bnx2 kmod-e1000e kmod-e1000 \
+        kmod-forcedeth kmod-fs-vfat kmod-igb kmod-igc kmod-ixgbe kmod-r8169 \
+        kmod-tg3 kmod-mt7915-firmware
+  GRUB2_VARIANT := generic
+endef
+TARGET_DEVICES += cordoba