diff mbox series

[OpenWrt-Devel,RFC,2/2] apm821xx: utilize softoff on the MyBook Live Series

Message ID 7f843b505843bd1fee347a1b46df6513de8bf735.1566587318.git.chunkeey@gmail.com
State RFC
Headers show
Series [OpenWrt-Devel,RFC,1/2] softoff: add softoff utility | expand

Commit Message

Christian Lamparter Aug. 23, 2019, 9:06 p.m. UTC
This was a requested feature on the forum some long time ago.
The original vendor firmware from Western Digital allowed the
device to enter a shutdown-like state and remain there
indefinitely.

Because OpenWrt sets the platform's nowayout watchdog, this
device will reboot after some time even when poweroff gets
called and the kernel supposed to just do its infinite loop
thing.

With this somewhat universal "softoff" the device will be
able to enter a similar-but-different shutdown-like state
with the HDDs in a safer standby mode so it can be moved
and disconnected.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
---
 target/linux/apm821xx/image/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index acfd478755..82e84f72f9 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -230,7 +230,8 @@  ifeq ($(SUBTARGET),sata)
 define Device/wd_mybooklive
   DEVICE_VENDOR := Western Digital
   DEVICE_MODEL := My Book Live Series (Single + Duo)
-  DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-basic
+  DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage \
+		     kmod-fs-vfat wpad-basic softoff
   DEVICE_TYPE := nas
   DEVICE_DTS := wd-mybooklive
   SUPPORTED_DEVICES += mbl wd,mybooklive-duo