diff mbox

[OpenWrt-Devel,ar71xx] add support for tp-link wr841n v10 image generation

Message ID 56153B9F.7060507@posteo.net
State Changes Requested
Headers show

Commit Message

Daniel Petre Oct. 7, 2015, 3:34 p.m. UTC
This adds support to generate images for tp-link wr841n v10 which is almost identical with tp-link wr841n v9 but with a faster cpu at 650 Mhz. Tested on a european version.

Signed-off-by: Daniel Petre <daniel.petre@posteo.net>

Comments

John Crispin Oct. 11, 2015, 3:27 p.m. UTC | #1
Hi,

On 07/10/2015 17:34, Daniel Petre wrote:
> This adds support to generate images for tp-link wr841n v10 which is almost identical with tp-link wr841n v9 but with a faster cpu at 650 Mhz. Tested on a european version.
> 
> Signed-off-by: Daniel Petre <daniel.petre@posteo.net>
> 
> --- a/target/linux/ar71xx/image/Makefile
> +++ b/target/linux/ar71xx/image/Makefile
> @@ -529,6 +529,13 @@ define Device/tl-wr841n-v9
>      TPLINK_HWID := 0x08410009
>  endef
>  
> +define Device/tl-wr841n-v10
> +    $(Device/tplink-4mlzma)
> +    BOARDNAME := TL-WR841N-v9

this looks wrong

also please prefix your patches with ar71xx: and not [ar71xx]

	John



> +    DEVICE_PROFILE := TLWR841
> +    TPLINK_HWID := 0x08410010
> +endef
> +
>  define Device/tl-wr842n-v2
>      $(Device/tplink-8mlzma)
>      BOARDNAME := TL-WR842N-v2
> @@ -549,7 +556,7 @@ define Device/tl-wr847n-v8
>      DEVICE_PROFILE := TLWR841
>      TPLINK_HWID := 0x08470008
>  endef
> -TARGET_DEVICES += tl-wr841n-v8 tl-wr841n-v9 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
> +TARGET_DEVICES += tl-wr841n-v8 tl-wr841n-v9 tl-wr841n-v10 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
>  
>  define Device/tl-wr941nd-v5
>      $(Device/tplink-4mlzma)
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
Bastian Bittorf Oct. 11, 2015, 7:31 p.m. UTC | #2
* John Crispin <blogic@openwrt.org> [11.10.2015 20:40]:
> also please prefix your patches with ar71xx: and not [ar71xx]

can please somebody change the text in
https://dev.openwrt.org/wiki/SubmittingPatches
@ "13. The canonical patch format"

-> Subject: [PATCH 001/123] [section] summary phrase

i made this mistake several times by looking at this
link and it seems a lot of other people too.

bye, bastian
Bastian Bittorf Oct. 16, 2015, 7:42 a.m. UTC | #3
* Bastian Bittorf <bittorf@bluebottle.com> [11.10.2015 21:31]:
> * John Crispin <blogic@openwrt.org> [11.10.2015 20:40]:
> > also please prefix your patches with ar71xx: and not [ar71xx]
> 
> can please somebody change the text in
> https://dev.openwrt.org/wiki/SubmittingPatches
> @ "13. The canonical patch format"
> 
> -> Subject: [PATCH 001/123] [section] summary phrase
> 
> i made this mistake several times by looking at this
> link and it seems a lot of other people too.

Still not fixed. Seems this can only be changed with an
admin-account. So Felix, John?

bye, bastian
diff mbox

Patch

--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -529,6 +529,13 @@  define Device/tl-wr841n-v9
     TPLINK_HWID := 0x08410009
 endef
 
+define Device/tl-wr841n-v10
+    $(Device/tplink-4mlzma)
+    BOARDNAME := TL-WR841N-v9
+    DEVICE_PROFILE := TLWR841
+    TPLINK_HWID := 0x08410010
+endef
+
 define Device/tl-wr842n-v2
     $(Device/tplink-8mlzma)
     BOARDNAME := TL-WR842N-v2
@@ -549,7 +556,7 @@  define Device/tl-wr847n-v8
     DEVICE_PROFILE := TLWR841
     TPLINK_HWID := 0x08470008
 endef
-TARGET_DEVICES += tl-wr841n-v8 tl-wr841n-v9 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
+TARGET_DEVICES += tl-wr841n-v8 tl-wr841n-v9 tl-wr841n-v10 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
 
 define Device/tl-wr941nd-v5
     $(Device/tplink-4mlzma)